LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-03-2009, 10:59 AM   #1
p03p
Member
 
Registered: Feb 2009
Posts: 52

Rep: Reputation: 15
Wake on lan settings in ethtool


Hi all,

Im trying to remote power on my debian machine with gnome with the wake on lan function.

I enabled it on my mainboard and was configuring my ethtool.

There i see:
root@lappy:~# ethtool eth0
Settings for eth0:
Supports Wake-on: g
Wake-on: d
Link detected: yes

and after this command ethtool -s eth0 wol g

i get this:
root@lappy:~# ethtool eth0
Settings for eth0:
Supports Wake-on: g
Wake-on: g
Link detected: yes

So i enabled it on software and hardware. Now im trying to sent the magic packets with a windows tool "wake on lan"
I see that the package has been sent but the pc wont turn on. So when i check the ethtool settings again i see that it turned to:

Wake-on: d

What am i missing?
 
Old 03-04-2009, 05:51 AM   #2
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
WOL seems to be broken in the kernel at the moment.
Search for WOL broken Kernel
The problem seems to be that when your computer shuts down, it fully shuts down your LAN card, so it is no longer listening for the magic packet.
There have been some "workarounds" posted, but none of them worked for me
 
Old 04-02-2009, 04:30 AM   #3
omababy
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Rep: Reputation: 0
Put this in "/etc/network/if-up.d/wol-enable"

Code:
#!/bin/bash
/usr/sbin/ethtool -s eth0 wol g
make it executable.

Last edited by omababy; 04-02-2009 at 04:35 AM.
 
Old 07-14-2009, 06:01 AM   #4
sipu123
LQ Newbie
 
Registered: Jul 2009
Posts: 4

Rep: Reputation: 0
hello i have applied these changes and WOL is working fine when i used it to wake my machine from turn off mode....

But it is not working when i switches my machine to sleep mode. My machine is not responding to magic packet sent , if it is in sleep mode. Also this all happens with ubuntu only .....If i go to sleep mode through Windows 7 ultimate. Then my machine can detect the magic packet and resume all the state of machine as earlier.

Can WOL for sleep/suspend/hibernate is possible in ubuntu......if yes do we require some more changes and what are those changes required.

please reply.
 
Old 07-14-2009, 06:11 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
sipu123;

Please do not make multiple posts with the same question. In this case, you have stated "I have applied these changes" in response to 4 different threads---I'm not goin to check in detail, but I doubt that this really fits all four.

Normally, you should start a new thread with a new question (but search first, and make reference to other relevant threads.)

Reported
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wake on lan settings sniffer_raghav Linux - Networking 1 11-17-2008 01:07 PM
ethtool - Doesn't display settings lensem Linux - Networking 4 06-27-2008 12:15 PM
ethtool can't seem to enable wake-on-LAN (wol) on my NIC bellsal Linux - Newbie 4 10-28-2007 04:28 AM
wake on lan magic packet does not wake. albean Linux - Networking 1 06-30-2007 03:57 PM
LXer: How to add ethtool duplex settings to a network card permanently LXer Syndicated Linux News 0 09-28-2006 03:21 PM


All times are GMT -5. The time now is 06:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration