LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-27-2008, 12:36 AM   #1
hemi_426
Member
 
Registered: Apr 2008
Location: KSA-jeddah
Distribution: CentOS, gentoo, slackware
Posts: 80

Rep: Reputation: 15
vtund tun0: Disabled Privacy Extensions


hello guys
im trying to establish a tunnel using vtund u can check my vtund.conf wich returns no problems when i start the Vtund daemon here:
Quote:
options
{
type stand;
port 5000;
bindaddr
{
iface eth0;
};
syslog deamon;
ppp /usr/sbin/pppd;
ifconfig /sbin/ifconfig;
route /sbin/route;
firewall /usr/sbin/iptables;
}
test
{
passwd test;
# type ether; #### only by server
# device tap00;
# proto tcp; #### only by server
persist yes; #### only by client
# keepalive yes; #### only by server
timeout 360;
# compress no; #### only by server
# encrypt no; #### only by server
stat yes;
speed 100:200;
up
{
ifconfig "%% 10.10.0.1 pointopoint 10.10.0.2 mtu 1450";
route "add -net 10.0.0.0 netmask 255.255.255.0 gw 10.10.0.2";
firewall "-A forward -s 10.0.0.0/24 -d 0.0.0.0/0 -j MASQ";
};
}
my problem is after i start the client and the server i notice this message at the client side:
Quote:
May 27 04:10:45 mybox vtund[22891]: Connecting to officebutler.no-ip.biz
May 27 04:10:45 mybox vtund[22891]: Session test[officebutler.no-ip.biz] opened
May 27 04:10:45 mybox vtund[22891]: Traffic shaping is not supported
May 27 04:10:45 mybox kernel: tun0: Disabled Privacy Extensions
May 27 04:10:45 mybox vtund[22891]: Session test[officebutler.no-ip.biz] closed
i did modprobe tun before i start the vtund on both sides
but i dont have any idea about this "tun0: Disabled Privacy Extensions"?
thanx a lot everybody in advance
 
Old 05-27-2008, 12:45 AM   #2
hemi_426
Member
 
Registered: Apr 2008
Location: KSA-jeddah
Distribution: CentOS, gentoo, slackware
Posts: 80

Original Poster
Rep: Reputation: 15
by the way this is a tunnel on a ADSL connection on both sides the PPPOE is inside the modems so is the type "tun" is good idea??
when i changed the type tp "ether" i dont get than extension error anymore instead i started to get this at the server side
Quote:
May 27 10:45:31 office vtund[6858]: Session test[79.172.174.3:46106] opened
May 27 10:45:31 office avahi-daemon[2329]: New relevant interface tap0.IPv4 for mDNS.
May 27 10:45:31 office avahi-daemon[2329]: Joining mDNS multicast group on interface tap0.IPv4 with address 10.10.0.2.
May 27 10:45:31 office avahi-daemon[2329]: Registering new address record for 10.10.0.2 on tap0.
May 27 10:45:31 office avahi-daemon[2329]: Withdrawing address record for 10.10.0.2 on tap0.
May 27 10:45:31 office avahi-daemon[2329]: Leaving mDNS multicast group on interface tap0.IPv4 with address 10.10.0.2.
May 27 10:45:31 office avahi-daemon[2329]: iface.c: interface_mdns_mcast_join() called but no local address available.
May 27 10:45:31 office avahi-daemon[2329]: Interface tap0.IPv4 no longer relevant for mDNS.
May 27 10:45:31 office avahi-daemon[2329]: New relevant interface tap0.IPv4 for mDNS.
May 27 10:45:31 office avahi-daemon[2329]: Joining mDNS multicast group on interface tap0.IPv4 with address 10.10.0.1.
May 27 10:45:31 office avahi-daemon[2329]: Registering new address record for 10.10.0.1 on tap0.
May 27 10:45:31 office vtund[6858]: Traffic shaping is not supported
May 27 10:45:31 office avahi-daemon[2329]: Interface tap0.IPv4 no longer relevant for mDNS.
May 27 10:45:31 office avahi-daemon[2329]: Leaving mDNS multicast group on interface tap0.IPv4 with address 10.10.0.1.
May 27 10:45:31 office avahi-daemon[2329]: Withdrawing address record for 10.10.0.1 on tap0.
May 27 10:45:31 office vtund[6858]: Session test closed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
difference between tun0 and tun1 birjodh Linux - Networking 5 06-22-2007 06:04 PM
Need tun0 for fedora5. Help!! allkit Linux - Networking 1 03-27-2007 05:14 PM
vtund bug????? please help p01nt3r Linux - Networking 0 03-23-2006 01:37 PM
Tun module loaded, how to create tun0? swiftnet Linux - Software 0 09-05-2005 06:20 PM
firefox - disabling "extensions have been disabled" warning lukebeales Linux - Software 0 12-16-2004 10:40 PM


All times are GMT -5. The time now is 09:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration