LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-05-2003, 04:10 PM   #1
baronsam
Member
 
Registered: Oct 2003
Posts: 44

Rep: Reputation: 15
vsftpd very very secure, so secure i can't use it...


I've been trying to set up vsftpd all day, and I'm calling out for help because the more i've done the worse it's been getting !

it started out fine, I tried to change the configuration so that I could chroot a user to a directory, and now vsftpd won't even run, I get "you must enable xinetd to use this service"

xinetd is running fine, and I believe all the rest of the configuration is as it should,
so i'm at my wit's end,

i've looked at the relevant posts here but i don't think i missed anything

any help would be greatly appreciated

all best,

--sam

redhat 9
 
Old 10-05-2003, 04:19 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Welcome to LQ.

Are you trying to run vsftpd as stand alone or from xinetd?

Can you post vsftpd.conf
 
Old 10-05-2003, 04:52 PM   #3
baronsam
Member
 
Registered: Oct 2003
Posts: 44

Original Poster
Rep: Reputation: 15
thanks for answering, it's very kind because i'm really going crazy here..

it's /etc/vsftpd/vsftpd.conf
not directly etc/vsftpd.conf
and i don't know how to change that

# Access rights
anonymous_enable=YES
local_enable=NO
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
# Security
anon_world_readable_only=YES
connect_from_port_20=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000
# Features
xferlog_enable=YES
ls_recurse_enable=NO
ascii_download_enable=NO
async_abor_enable=YES
# Performance
one_process_model=YES
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=50000

this isn't at all what I want, but i read so many posts around here saying that changes made problems that i just loaded a plain one.
what i really want is a plain one with comments without anonymous and with chroot.

i'm running vsftpd from xinetd (or not, actually with the error i get, but at least i'd like to)

all best,

--sam

Last edited by baronsam; 10-05-2003 at 05:14 PM.
 
Old 10-06-2003, 12:32 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Try this config file
Code:
#
# Allow anonymous FTP?
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
idle_session_timeout=600
# Keep local users in their home dirs
chroot_local_user=yes
pam_service_name=vsftpd
#enable for standalone mode
#listen=YES
#tcp_wrappers=YES
I tend to use standalone mode but I think for xinetd the config file must be in /etc/
 
Old 10-06-2003, 06:12 PM   #5
baronsam
Member
 
Registered: Oct 2003
Posts: 44

Original Poster
Rep: Reputation: 15
thanks for your help, i solved the problem

i used standalone mode and my problems went away.

all best,

--sam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD with secure & non-secure logins Ricci Graham Linux - Software 5 04-07-2005 04:12 PM
How secure Am I? chbin Linux - Security 5 03-14-2005 01:19 PM
Secure email (SSL vs. secure authentication) jrdioko Linux - Newbie 2 11-28-2004 01:39 PM
vsftpd, and premoicuous. Is it secure? jsbush Linux - Security 2 11-04-2003 12:16 PM
Vsftpd Folder ownerships - Is this secure? Korff Linux - Security 2 06-06-2003 01:05 PM


All times are GMT -5. The time now is 04:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration