LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-05-2005, 03:06 AM   #1
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Rep: Reputation: 30
vsFTPd user's not working?


okay then, i'm running slackware 10.1 and vsftpd and i'm having problems with login in as different users

here is what it looks like when i log in as root using the bash command line

root@LearnS:/# ftp localhost
Connected to localhost.
220 Slackbox FTP
Name (localhost:root): root
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

here is what it looks like when i log in as a user using the bash command line.

root@LearnS:/# ftp localhost
Connected to localhost.
220 Slackbox FTP
Name (localhost:root): matthewsp
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp>

is there some way that i can choose users with FTP access or enable certain local users or something simple like that i'm missing.

as far as i understand all i need to do is add a new users with the 'adduser' command?
 
Old 05-05-2005, 12:14 PM   #2
michaelsanford
Member
 
Registered: Feb 2005
Location: Ottawa/Montréal
Distribution: Slackware + Darwin (MacOS X)
Posts: 468

Rep: Reputation: 30
They need to have a "valid" shell (i.e., a shell that appears in /etc/shells) The trick to this is that you can give someone an "ftp only" account by giving them a shell like /dev/null and putting /dev/null in /etc/shells. Then they can't log in over SSH but they can FTP.

So if you gave matthewsp a valid shell it should work.

Are you sure you didn't, say, mistype the password when you made the account (since the error is login incorrect)?
 
Old 05-05-2005, 01:07 PM   #3
clinton
Member
 
Registered: Oct 2003
Location: Vancouver
Distribution: RH Enterprise AS 3
Posts: 47

Rep: Reputation: 15
I believe the login "shell"

/sbin/nologin

is designed specifically with this sort of issue in mind.
 
Old 05-05-2005, 02:37 PM   #4
michaelsanford
Member
 
Registered: Feb 2005
Location: Ottawa/Montréal
Distribution: Slackware + Darwin (MacOS X)
Posts: 468

Rep: Reputation: 30
While that is true it doesn't come as a default on all distributions, Slackware being one of them.

Of course you can replace it with any custom script you like. As an aside, this is mine:
Code:
#!/bin/sh
echo "Access denied"
exit 1
 
Old 05-05-2005, 03:18 PM   #5
zhar
LQ Newbie
 
Registered: May 2005
Distribution: Fedora Core 3
Posts: 1

Rep: Reputation: 0
On this subject. Whats the easiest way I can give someone FTP access on my linux box. Primarily for a game server I am running (allow map uploads, config uploads. etc.

I want to add users and set their permissions. Still learning this stuff.

I am using Fedora Core 3 btw.
 
Old 05-05-2005, 06:17 PM   #6
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
hey you guys were right about the /bin/sh thing, once i changed it to /bin/bash and i could login via the command line no problems!

but i still can't log in via IE ... when i go to my ISP's ftp i get a login box, but i don't seam to get one when going to my own ftp://192.168.0.20, is there some way of doing this?
 
Old 05-05-2005, 10:26 PM   #7
michaelsanford
Member
 
Registered: Feb 2005
Location: Ottawa/Montréal
Distribution: Slackware + Darwin (MacOS X)
Posts: 468

Rep: Reputation: 30
Aah no login box. Well in that case, does your firewall block FTP ?

PS Re: setting up FTP http://www.linuxquestions.org/questi...ticle&artid=17
 
Old 05-06-2005, 01:04 AM   #8
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
no my firewall dosn't block anything i've opened it up completely. i'd still like to be able to get the login box but someone has told me the way around this

ftp://userass@domain.com/

now although this has worked, it takes me to the root path "/" not to my user's home folder? am i mistaken in asumming thats were it is ment to go? or is there someway to insure that is were it goes? and if anyone can tell me how to force a login box to open up on IE that'd be great!
 
Old 05-06-2005, 01:04 AM   #9
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Original Poster
Rep: Reputation: 30
no my firewall dosn't block anything i've opened it up completely. i'd still like to be able to get the login box but someone has told me the way around this

ftp://userassword@domain.com

now although this has worked, it takes me to the root path "/" not to my user's home folder? am i mistaken in assuming thats were it is meant to go? or is there someway to insure that is were it goes? and if anyone can tell me how to force a login box to open up on IE that'd be great!

Last edited by paul_mat; 05-06-2005 at 01:07 AM.
 
Old 05-06-2005, 02:00 AM   #10
michaelsanford
Member
 
Registered: Feb 2005
Location: Ottawa/Montréal
Distribution: Slackware + Darwin (MacOS X)
Posts: 468

Rep: Reputation: 30
Ah I think I can explain your problem. Since you entered NO username as the FTP URL in your browser your browser probably mistakenly assumed you were logging in anonymously and sent the anonymous credentials without ever asking you for yours.

If you enter ftp://username@domain.com without a password you should be prompted for one.

As for the folder you see...normally it should take you to that user's ~/ folder, which shouldn't be / but in some cases a browser may just issue a "cd /" and if your user isn't chroot-ed it'll take you all the way up to /, even if you can't access anything but ~/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd behind router not working in some cases setdosa Linux - Networking 9 05-09-2008 10:22 AM
vsftpd not working pradsy90 Linux - Software 2 05-09-2008 10:19 AM
Can't get vsftpd working Kropotkin Linux - Networking 3 07-18-2005 03:23 PM
vsftpd not working remotely nmucats Linux - Networking 1 12-21-2004 09:56 PM
vsftpd umask not working k-bot Linux - Software 1 03-10-2004 05:29 PM


All times are GMT -5. The time now is 04:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration