LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-06-2005, 10:01 PM   #1
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Rep: Reputation: 30
VSFTPD refusing login/denying cause anon only


Hello all, I am trying to set my ftp server up and running into a few problems. I m behind a cable router/modem. I am attempting to login to 192.168.0.13 from another machine behind my firewall (.0.10). Once I try i get

This ftp is anonoymouse only.

If I try with my internet IP and the ftp in the DMZ then I get connection refused.

Here is a copy of /etc/vsftpd.conf
btw using ubuntu latest one as of Oct 6, 2005

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone? vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
aonnect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories. See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
#
# Debian customization
#
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default. These settings are more Debian-friendly.
#
# This option should be the name of a directory which is empty. Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/vsftpd.pem


Thanx for any help
 
Old 10-07-2005, 06:26 PM   #2
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
Well I made a few small changes which got me working from behind my firewall.

Allow anonymous FTP? (Beware - allowed by default if you comment this out).

needed to be commented out now looks like

# Allow anonymous FTP? (Beware - allowed by default if you comment this out)

The other was

aonnect_from_port_20=YES

which now reads

connect_from_port_20=yes

I found these by just opening xterm and running vsftpd no sudo or anything and it told me these lines were messed up. Once fixed I ran with sudo vsftpd and it ran no errors and I was able to log in from behind my firewall. I am now attempting to get this available from the outside.
 
Old 10-08-2005, 08:38 PM   #3
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
Hello all. Well it turns out that it works from outside my network. So in short I can access the ftp server from behind the fire wall at 192.168.0.11. However when I tried to test the ftp server by putting in my real IP after placing my FTP server in the DMZ it did not work. When I tried it from work it actually worked with 0 problems. I logged in using my local account fine. Could cd, ls and mkdir np.

Now I believe the reason for this is that the router will only allow/route port 21 to one machine at a time. If there is any one out there that can correct me then please do as I do not intend to mislead.
 
Old 10-09-2005, 09:22 PM   #4
destuxor
Member
 
Registered: Oct 2005
Posts: 51

Rep: Reputation: 16
I put this little VSFTPD howto on my website a few months ago: http://gentoobox.rh.ncsu.edu/vsftpd-help.html
It was written for an older version, but I hear the samples work perfectly for newer revisions.
gonus: this might not be helpful, but I wrote this script to help test ports (in perl):
Code:
#!/usr/bin/perl -w
#
use strict;
use warnings;
use IO::Socket::INET;

my ($host, $port) = @ARGV or die "Please specify a host and port to listen on.\n";

sub open_socket
{
        my $listen_socket = new IO::Socket::INET (
                LocalHost => $host,
                LocalPort => $port,
                Listen    => 2,
                Proto     => 'tcp',
                Reuse     => 1);
        if ($listen_socket) {
                $listen_socket -> autoflush (1);
        } else {
                die "Unable to create listening socket: $@\n";
        }
        print "done. Now listening on port $host:$port...\n";
        my $socket_handle = $listen_socket -> accept();
        return $socket_handle;
}

while (1)
{
        print "Creating socket...";
        my $socket_handle = &open_socket();
        print "Client connected.\n";
        print $socket_handle "You have connected successfully.\nType something in and I'll echo it, then quit.\n> ";
        my $input = <$socket_handle>;
        print $socket_handle $input."Goodbye.\n";
        close $socket_handle;
}
When I use it, I'll SSH into the machine in question, run the program, then attempt to telnet into the host/port in question. I have no idea why you could maintain only one connection at a time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD:How to have vsftpd ask for anon user to "send email for password"? dmurray8888 Linux - Networking 1 08-31-2008 07:04 PM
Allowing/Denying login by group twsnnva Linux - Security 2 03-22-2005 04:14 PM
vsftpd anon uploads das9570 Linux - Networking 0 01-16-2005 10:21 PM
Can't login to ftp as user only anon? Monkey Linux - Newbie 1 03-07-2002 12:19 AM
Denying remote root login with SuSE 7.1 midnightcommander Linux - Networking 2 07-08-2001 07:51 PM


All times are GMT -5. The time now is 09:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration