LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-12-2004, 02:10 PM   #1
gagda1
LQ Newbie
 
Registered: May 2004
Location: Canada
Distribution: Fedora core 2
Posts: 28

Rep: Reputation: 15
Unhappy vsftpd "chroot_local_user=YES" not working


Hello,
I run vsftp on Fedora core 1. I created a local user (ftpuser) to access the ftp. The folder is /var/ftp/test. I gave read write access to this folder to ftpuser. I don't want this user to access/see any other folder. The problem is that the ftpuser can browse all folders on the machine... He can go up to /var/ftp then /var then / etc. I read that I could prevent that by setting
chroot_local_user=YES in vsftpd.conf and setting the home of ftpuser to /var/ftp/test. However, as soon as I set chroot_local_user=YES in vsftpd.conf, vsftp daemon fails when I restart it. The status is vsftpd dead but subsys locked.

Any idea?

Thanks,
David.
 
Old 05-12-2004, 02:17 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Are you use vsftpd via xinetd or in standalone mode?
 
Old 05-12-2004, 07:09 PM   #3
gagda1
LQ Newbie
 
Registered: May 2004
Location: Canada
Distribution: Fedora core 2
Posts: 28

Original Poster
Rep: Reputation: 15
Standalone
 
Old 05-12-2004, 08:02 PM   #4
gagda1
LQ Newbie
 
Registered: May 2004
Location: Canada
Distribution: Fedora core 2
Posts: 28

Original Poster
Rep: Reputation: 15
Smile

Finally found something working!

I added in /etc/vsftpd/vsftpd.conf

#chroot_local_user = YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list

Added my ftpuser to the /etc/vsftpd.chroot_list. Actually, this file contains only my ftp users.

Added all local users I don't want to be able to connect via FTP in
/etc/vsftpd.ftpusers

Now, my ftpuser is restricted to its home folder. I tried with other ftp users I created and it is working fine. Other local users listed in vsftpd.ftpusers cannot connect to ftp since they get a login incorrect error.

To me it looks good but is this setting secure to make sure a user won't be able to access files other than the ones in the ftp?

It is kind of risky because it is easy to create a new local user and forget to add it in the vsftpd.ftpusers to prevent him from accessing the ftp.

Finally, from time to time in the shell I get the message :
Mutex destroy failure: Device or resource busy
What's that?

Thanks,
David.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD:How to have vsftpd ask for anon user to "send email for password"? dmurray8888 Linux - Networking 1 08-31-2008 06:04 PM
commands "init" and "modprobe" not working Diagmato Fedora 2 07-22-2005 11:44 PM
VSFTPD Debian VSFTPD "unrecognised variable in config file" DCT Linux - Software 0 05-29-2004 11:59 PM
How to have vsftpd ask for anon user to "send email for password"? dmurray8888 Linux - Software 0 04-27-2004 03:08 PM
vsftpd - "real" vs. "virtual" users clau_bolson Linux - Networking 2 11-17-2003 06:22 AM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration