LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-28-2003, 08:50 PM   #1
Xgkkp
LQ Newbie
 
Registered: Aug 2003
Location: South-East England
Distribution: Ubuntu
Posts: 7

Rep: Reputation: 0
vsftpd - strange remote behaviour


So, I am relatively new to Linux, and I set up an ftp on my friends computer so I could download some of his files, It's Red hat 8 running vsftpd (I hope!)

anyway, When on his machine or logged in remotely via ssh, I can say "Ftp localhost" and it works fine, asks for my username/password and then allows me to view my files.

Now, when I came home and tried to do the same, it said :

Code:
[xgkkp@nick xgkkp]$ ftp 80.X.XXX.X
Connected to 80.X.XXX.X (80.X.X.X).
421 Service not available, remote server has closed connection
ftp>
Does anyone have a clue what is going on? He's directly connected through a cable modem, and I am through a firewall-type-thing.

Thanks a lot,

Nick

Last edited by Xgkkp; 08-29-2003 at 10:05 AM.
 
Old 08-29-2003, 01:40 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Welcome to LQ.

Check to see if he has any firewalls running at his end:
iptables -L
 
Old 08-29-2003, 02:11 PM   #3
Xgkkp
LQ Newbie
 
Registered: Aug 2003
Location: South-East England
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
RH-Lokkit-0-50-INPUT  all  --  anywhere             anywhere

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
RH-Lokkit-0-50-INPUT  all  --  anywhere             anywhere

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain RH-Lokkit-0-50-INPUT (2 references)
target     prot opt source               destination
ACCEPT     udp  --  cache2.ntli.net      anywhere           udp spt:domain dpts:1025:65535
ACCEPT     udp  --  cache1.ntli.net      anywhere           udp spt:domain dpts:1025:65535
ACCEPT     tcp  --  anywhere             anywhere           tcp dpt:ssh flags:SYN,RST,ACK/SYN
ACCEPT     udp  --  anywhere             anywhere           udp spts:bootps:bootpc dpts:bootps:bootpc
ACCEPT     udp  --  anywhere             anywhere           udp spts:bootps:bootpc dpts:bootps:bootpc
ACCEPT     all  --  anywhere             anywhere
REJECT     tcp  --  anywhere             anywhere           tcp dpts:0:1023 flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT     tcp  --  anywhere             anywhere           tcp dpt:nfs flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT     udp  --  anywhere             anywhere           udp dpts:0:1023 reject-with icmp-port-unreachable
REJECT     udp  --  anywhere             anywhere           udp dpt:nfs reject-with icmp-port-unreachable
REJECT     tcp  --  anywhere             anywhere           tcp dpts:x11:6009 flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT     tcp  --  anywhere             anywhere           tcp dpt:xfs flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable


I have no idea how to read this

Last edited by Xgkkp; 08-29-2003 at 02:19 PM.
 
Old 08-29-2003, 02:27 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
IT looks like you are blockign port 21 (ftp). Try running "lokkit" and change the firewall settings to allow ftp. Either that or disable the firewall (not recommended but good for testing):
iptables -F

Ideally you should make your own firewall rules instead of using lokkit as it is much more advanced yet easier to understand.
 
Old 08-30-2003, 12:21 PM   #5
Xgkkp
LQ Newbie
 
Registered: Aug 2003
Location: South-East England
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
Ahhh thanks very much, it works perfectly.

Out of curiosity, what would have been the equivalent command to manaully add an iptable rule?
 
Old 08-30-2003, 12:50 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Something like:
iptables -A INPUT -p tcp --dport 21 -j ACCEPT
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot connect to mysql database externally lsimon4180 Linux - Software 17 03-02-2005 12:28 PM
Apache 1.3 - can't connect externally slightcrazed Linux - Software 2 02-03-2004 10:16 AM
could not connect my vsftpd server exper Linux - Networking 2 07-26-2003 02:54 AM
Can't connect to vsFTPd through ssh tunnel Sizam Linux - Networking 0 06-27-2003 12:30 PM
VSFTPD Running But Cannot Connect from another machine SForsgren Linux - General 10 05-01-2003 11:55 PM


All times are GMT -5. The time now is 09:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration