LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-25-2008, 10:55 PM   #1
sohailkmu
Member
 
Registered: Oct 2008
Posts: 81
Blog Entries: 1

Rep: Reputation: 15
Question vsftpd and Mozilla firefox problem


I have installed vsftpd on red hat enterprise as 4. The problem is when I log in to the ftp server through internet explorer 6.0 it is OK. But when I log in the ftp server and click the "Up to Higher Level Directory" Link it eventually shows all of my server's partitions. I am not logging in through anonymous.

What should I do.
 
Old 12-26-2008, 04:13 PM   #2
harry edwards
Member
 
Registered: Nov 2007
Location: Lincolnshire, UK
Distribution: CentOS, Fedora, and Suse
Posts: 365

Rep: Reputation: 48
There is normally an option to "jail" a user. so they can only see their home directory and sub-directories.

In /etc/vsftpd.conf set the following:
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list

In /etc/vsftpd.chroot_list, put in those usernames who are allowed to change their root directory, those who are not in the list cannot change the root directory.

Once the above have been changed restart vsftp.

Hope that helps.
 
Old 12-28-2008, 11:18 PM   #3
sohailkmu
Member
 
Registered: Oct 2008
Posts: 81
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Thumbs up

Quote:
Originally Posted by harry edwards View Post
There is normally an option to "jail" a user. so they can only see their home directory and sub-directories.

In /etc/vsftpd.conf set the following:
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list

In /etc/vsftpd.chroot_list, put in those usernames who are allowed to change their root directory, those who are not in the list cannot change the root directory.

Once the above have been changed restart vsftp.

Hope that helps.
Thanks a lot for your response. It really worked fine.

I have got another problem

I want one user to upload files to ftp server. I have changed the ownership of the directory to that of the user. It is working fine in Internet explorer 6.0 i.e I copy a file and paste it. But with Mozilla firefox or opera or internet explorer 7.0 it cannot be done. Kindly guide me.

Last edited by sohailkmu; 12-29-2008 at 01:41 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Mozilla Thunderbird to Find New Home as Mozilla Foundation Focuses on Mozilla Firefox LXer Syndicated Linux News 0 07-27-2007 09:16 AM
Mozilla FireFox problem? bastjan Linux - Software 1 06-06-2007 05:03 AM
problem with mozilla/firefox gordonbrown63 Linux - Software 0 12-17-2004 05:55 PM
Serious Problem with Mozilla Firefox Mrrrr. Nice Guy Linux - Software 17 12-01-2004 06:33 PM
I have a problem with Mozilla Firefox RJARRRPCGP Linux - Newbie 7 11-20-2004 06:58 PM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration