Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 10-26-2003, 03:47 AM   #1
LQ Newbie
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
Question vsftp problem running with xinetd

Hi everybody,
I'm new in linux since few weeks ago but I'm very happy I decided finally to give it a try.
I set up the ftp server and I got no problems when running in standalone mode, but when I try configuring it to run with xinetd something goes wrong and I cannot figure out what it is. Following the documents I found on the net specially in the vsftp website (I got a box running RedHat 9), I should put the ftp service file in /etc/xinetd.d/vsftpd directory so xinetd would read the server path (as configured in xinetd.conf) to vsftpd starting the server I guess with the configuration parameters encountered in vsftpd.conf file.
What happen is the ftp starts but in anonymous mode, when in my vsftpd.conf anonymous is set to No. And the showing directoryroot is /pub, the same I set in vsftp.conf, but there's no content in it.
Thanks for your help and suggestions and be pacient. :-)
Old 10-26-2003, 07:56 AM   #2
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
By default the config file should be:

The default with redhat is to be:

So make a symlink to /etc and you should be good to go:
ln -s /etc/vsftpd/vsftpd.conf /etc/vsftpd.conf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running APACHE through XINETD 1jamie Linux - Networking 8 11-13-2009 03:55 PM
VSFTP does not start from xinetd joelhalbert Linux - Software 0 12-06-2003 12:09 PM
XINETD not running polo76 Linux - Newbie 0 09-08-2003 07:47 AM
Xinetd Running Amok - RH 8 RWild Linux - Networking 2 02-23-2003 02:48 PM
running samba worked, running it out of xinetd doesn't? system Linux - Networking 1 12-24-2001 04:15 AM

All times are GMT -5. The time now is 04:08 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration