LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-28-2003, 06:32 PM   #1
mielke
LQ Newbie
 
Registered: Feb 2003
Posts: 1

Rep: Reputation: 0
vpnclient issues with pppoe dsl connection in suse 8.1


Hi,

If I start vpnclient before opening up my dsl connection (pppoe) I get the following output from my attempts to use the vpnclient.

spunky:~ # ipseclog ipsc.log
Cisco Systems VPN Client Version 3.7.2 (Rel)
Copyright (C) 1998-2002 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Linux
Running on: Linux 2.4.19-4GB #1 Fri Sep 13 13:14:56 UTC 2002 i686
------ kept up in one window moved to another --------

spunky:~ # /etc/init.d/vpnclient_init start
\Starting /usr/local/bin/vpnclient: Warning: loading /lib/modules/2.4.19-4GB/CiscoVPN/cisco_ipsec will taint the kernel: no license
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module cisco_ipsec loaded, with warnings
Done
spunky:~ #


Then in /var/log/messages:

Feb 28 16:29:23 spunky kernel: Cisco Systems VPN Client Version 3.7.2 (Rel) kernel module loaded
Feb 28 16:29:31 spunky /etc/hotplug/net.agent[1515]: No HW description found ... exiting


Then I can see cipsec0 device:

spunky:~ # ifconfig cipsec0
cipsec0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
BROADCAST MULTICAST MTU:1400 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

spunky:~ #


Then I run vpnclient:

spunky:~ # vpnclient connect hks
Cisco Systems VPN Client Version 3.7.2 (Rel)
Copyright (C) 1998-2002 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Linux
Running on: Linux 2.4.19-4GB #1 Fri Sep 13 13:14:56 UTC 2002 i686

Initializing the IPSec link.
Contacting the gateway at 63.125.196.3
Remote peer is no longer responding.
There are no new notification messages at this time.
spunky:~ #


Then I see in /var/log/messages:

Feb 28 16:32:05 spunky pppd[544]: Starting link
Feb 28 16:32:05 spunky pppd[544]: Sending PADI
Feb 28 16:32:05 spunky pppd[544]: HOST_UNIQ successful match
Feb 28 16:32:05 spunky pppd[544]: HOST_UNIQ successful match
Feb 28 16:32:05 spunky pppd[544]: Got connection: 5155
Feb 28 16:32:05 spunky pppd[544]: Connecting PPPoE socket: 00:b0:64:bf:5b:13 5551 eth0 0x8088ae8
Feb 28 16:32:05 spunky pppd[544]: Connect: ppp0 <--> eth0
Feb 28 16:32:05 spunky pppd[544]: Setting MTU to 1492.
Feb 28 16:32:05 spunky pppd[544]: Couldn't increase MRU to 1500
Feb 28 16:32:07 spunky pppd[544]: Setting MTU to 1492.
Feb 28 16:32:08 spunky pppd[544]: Local IP address changed to 64.222.35.169
Feb 28 16:32:08 spunky pppd[544]: Remote IP address changed to 10.17.2.1
Feb 28 16:32:09 spunky pppd[544]: Open UDP 64.222.35.169:500 -> 63.125.196.3:500
Feb 28 16:32:09 spunky modify_resolvconf: Service pppd modified /etc/resolv.conf. See info block in this file
Feb 28 16:32:09 spunky pppd[544]: Script /etc/ppp/ip-up finished (pid 1556), status = 0x0
Feb 28 16:32:10 spunky kernel: unknown mac header length (22)
Feb 28 16:32:20 spunky last message repeated 2 times

Then I see in my ipsec log:

spunky:~ # cat ipsc.log
1 16:32:04.576 02/28/2003 Sev=Info/4 CLI/0x43900002
Started vpnclient:
Cisco Systems VPN Client Version 3.7.2 (Rel)
Copyright (C) 1998-2002 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Linux
Running on: Linux 2.4.19-4GB #1 Fri Sep 13 13:14:56 UTC 2002 i686

2 16:32:04.693 02/28/2003 Sev=Info/4 CVPND/0x4340000F
Started cvpnd:
Cisco Systems VPN Client Version 3.7.2 (Rel)
Copyright (C) 1998-2002 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Linux
Running on: Linux 2.4.19-4GB #1 Fri Sep 13 13:14:56 UTC 2002 i686

3 16:32:05.598 02/28/2003 Sev=Info/4 CM/0x43100002
Begin connection process

4 16:32:05.599 02/28/2003 Sev=Info/4 CM/0x43100004
Establish secure connection using Ethernet

5 16:32:05.599 02/28/2003 Sev=Info/4 CM/0x43100026
Attempt connection with server "63.125.196.3"

6 16:32:05.599 02/28/2003 Sev=Info/6 IKE/0x4300003B
Attempting to establish a connection with 63.125.196.3.

7 16:32:05.712 02/28/2003 Sev=Info/4 IKE/0x43000013
SENDING >>> ISAKMP OAK AG (SA, KE, NON, ID, VID, VID, VID, VID, VID) to 63.125.196.3

8 16:32:05.713 02/28/2003 Sev=Info/4 IPSEC/0x43700009
IPSec driver already started

9 16:32:05.713 02/28/2003 Sev=Info/4 IPSEC/0x43700014
Deleted all keys

10 16:32:06.738 02/28/2003 Sev=Info/6 IPSEC/0x4370002A
PPPoE Protocol has been detected.

11 16:32:10.758 02/28/2003 Sev=Info/4 IKE/0x43000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 63.125.196.3

12 16:32:15.798 02/28/2003 Sev=Info/4 IKE/0x43000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 63.125.196.3

13 16:32:20.838 02/28/2003 Sev=Info/4 IKE/0x43000013
SENDING >>> ISAKMP OAK AG (Retransmission) to 63.125.196.3

14 16:32:25.878 02/28/2003 Sev=Warning/2 IKE/0xC300007C
Exceeded 3 IKE SA negotiation retransmits... peer is not responding

15 16:32:25.878 02/28/2003 Sev=Info/4 CM/0x43100014
Unable to establish Phase 1 SA with server "63.125.196.3" because of "DEL_REASON_PEER_NOT_RESPONDING"

16 16:32:25.878 02/28/2003 Sev=Info/5 CM/0x43100027
Initializing CVPNDrv

17 16:32:26.998 02/28/2003 Sev=Info/4 IPSEC/0x43700009
IPSec driver already started

18 16:32:26.998 02/28/2003 Sev=Info/4 IPSEC/0x43700014
Deleted all keys

19 16:32:26.998 02/28/2003 Sev=Info/4 IPSEC/0x4370000D
Key(s) deleted by Interface (192.168.99.1)



I can see UDP traffic leaving my system with iptraf. I can not see any traffic coming in on my ppp0 device on iptraf.

If I go to a friends house and connect using dhcp I get further and get prompted for my username and password on the same system. If I boot into windows at home with the dsl connection I make it to that same point. I am wondering what cI am doing wrong here in linux. It seems that vpnclient does not like my pppoe connection on my linux system.

Any ideas here would be great.

Thanks,

Brian Mielke
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unique PPPoE Connection/Problem SUSE 9.0 foxtrot Linux - Networking 2 10-10-2005 06:44 AM
CONNECTION TO PPPOE DSL ON ubuntu skinnyman100 Linux - Networking 1 05-28-2005 11:07 AM
dsl connection with suse 9.1 Husche Linux - Newbie 2 02-08-2005 03:28 PM
dsl connection with suse 9.1 Husche Linux - Networking 0 02-07-2005 03:06 PM
DSL, PPPOE, Fedora, have connection but cannot access internet cfiles Linux - Networking 5 02-05-2004 07:46 PM


All times are GMT -5. The time now is 06:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration