LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 03-25-2008, 01:15 PM   #1
stuartornum
Member
 
Registered: Feb 2006
Posts: 44

Rep: Reputation: 15
VPN - Default Gateway / Routing Issues, pptpd


Hi All,

I reckon there is a simple fix to this, I just can't figure it out.

My Setup

Server
CentOS 4.6 (Xen)
PPTPD Server
Webmin
VPN Server local IP: 192.168.2.1

Client
Windows XP Pro
VPN assigned local IP: 192.168.2.101

So Far

I have managed to get the server installed and working 95%.

From the Windows client I can connect, it gives me the correct IP I assigned to a particular user, I can also ping the server ok.

However I cannot ping any public IP's.

Here is netstat -nr from the Windows client *BEFORE* connecting to the VPN:
Code:
Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x3 ...00 0b cd 5b 64 52 ...... HP WLAN 802.11b/g W400 - Packet Scheduler Minipo
rt
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0         10.1.1.1       10.1.1.21       25
         10.1.1.0    255.255.255.0        10.1.1.21       10.1.1.21       25
        10.1.1.21  255.255.255.255        127.0.0.1       127.0.0.1       25
   10.255.255.255  255.255.255.255        10.1.1.21       10.1.1.21       25
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
        224.0.0.0        240.0.0.0        10.1.1.21       10.1.1.21       25
  255.255.255.255  255.255.255.255        10.1.1.21       10.1.1.21       1
Default Gateway:          10.1.1.1
===========================================================================
Persistent Routes:
  None
Here is netstat -nr from the Windows client *AFTER* connecting to the VPN:
Code:
Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x3 ...00 0b cd 5b 64 52 ...... HP WLAN 802.11b/g W400 - Packet Scheduler Minipo
rt
0xa0002 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0         10.1.1.1       10.1.1.21       26
          0.0.0.0          0.0.0.0    192.168.2.101   192.168.2.101       1
         10.1.1.0    255.255.255.0        10.1.1.21       10.1.1.21       25
        10.1.1.21  255.255.255.255        127.0.0.1       127.0.0.1       25
   10.255.255.255  255.255.255.255        10.1.1.21       10.1.1.21       25
    77.74.198.161  255.255.255.255         10.1.1.1       10.1.1.21       25
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
    192.168.2.101  255.255.255.255        127.0.0.1       127.0.0.1       50
    192.168.2.255  255.255.255.255    192.168.2.101   192.168.2.101       50
        224.0.0.0        240.0.0.0        10.1.1.21       10.1.1.21       25
        224.0.0.0        240.0.0.0    192.168.2.101   192.168.2.101       1
  255.255.255.255  255.255.255.255        10.1.1.21       10.1.1.21       1
  255.255.255.255  255.255.255.255    192.168.2.101   192.168.2.101       1
Default Gateway:     192.168.2.101
===========================================================================
Persistent Routes:
  None
Shouldn't the default gateway when connected to the VPN be the VPN servers local IP (192.168.2.1), instead of the client assigned IP, in this case 192.168.2.101

Thanks in advanced
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vpn routing without the gateway karen.pertierra Linux - Networking 1 03-18-2007 06:39 AM
Help with vpn pptpd andybrr Red Hat 2 10-26-2006 04:07 PM
issues with VPN pptpd server onorua Linux - Networking 1 08-25-2006 03:45 PM
VPN with pptpd m1111 Linux - Networking 0 02-07-2006 01:42 PM
Default Gateway Not Listed In Routing Table krazyace78 Linux - Networking 0 10-05-2004 12:09 PM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration