LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 12-09-2009, 11:31 PM   #1
Joe_Zhu
Member
 
Registered: Dec 2003
Distribution: Debian, RedHat
Posts: 32

Rep: Reputation: 15
VPN connection issue


Hi i am using ubuntu 9.10 32bit.

recently i setup a PPTP VPN server in my linksys router running DD WRT at home.
and in the ubuntu laptop in my office, i configure manually a vpn connection by following the instruction in following webpage http://pptpclient.sourceforge.net/howto-debian.phtml
http://pptpclient.sourceforge.net/ro...utomatic-setup

at first i thought it is successful, i can ping, SSH, FTP to my NAS from my laptop, however, when i try to open the web interface, it never come up in my browser.
here is my routing table in the ubuntu laptop after the pptp connected.
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.1 * 255.255.255.255 UH 0 0 0 ppp0
119246039114.ct 10.0.34.254 255.255.255.255 UGH 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 ppp0
10.0.34.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default 10.0.34.254 0.0.0.0 UG 100 0 0 eth0

192.168.1.0 is the remote network.

it is so strange!

then i try to connect by another windows laptop from office, it just works seamlessly.

anyone can help?

thanks!
Joseph
 
Old 12-10-2009, 12:36 AM   #2
Joe_Zhu
Member
 
Registered: Dec 2003
Distribution: Debian, RedHat
Posts: 32

Original Poster
Rep: Reputation: 15
Hi,
when i compare the windows pptp and linux pptp connection i found the different in the gateway.
in linux:
ppp0 Link encap:Point-to-Point Protocol
inet addr:192.168.1.180 P-t-P:192.168.1.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1446 Metric:1

in windows

IP address........: 192.168.1.180
Subnetmask........: 255.255.255.255
Default Gateway...: 192.168.1.180

but i don't know why in linux the p-t-p will become 192.168.1.1 ? where to set it??

pls. help!
Joseph
 
Old 12-10-2009, 03:00 AM   #3
Web31337
Member
 
Registered: Sep 2009
Location: Russia
Distribution: Gentoo, LFS
Posts: 399
Blog Entries: 71

Rep: Reputation: 65
what about gateway in linux?
P-t-P is set by VPN serv.
can you ping 192.168.1.1? are you sure you enabled web interface for LAN? do you access it as http://192.168.1.1/ ? i presume it's an IP of router.
btw have no idea why windows tells a gateway is your own ip, it can't be.
what's wrong with subnet mask? i think it shouldn't be 255.255.255.255, usually it's 255.255.255.0.
i think you should look into your router's settings.

Last edited by Web31337; 12-10-2009 at 03:02 AM.
 
Old 12-10-2009, 07:28 AM   #4
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,278

Rep: Reputation: 91
No point to point has a subnet mask of 255.255.255.255 becuase it is a point to point that's normal. I don't know why the browser isn't working but it seems to me that his PPTP connection is working if he can ping ssh, etc... it seems more browser specific. We need to know the full story IP network range key IPs like the router, and the server setup on the DD-WRT linksys in order to help better.
 
Old 12-11-2009, 12:03 AM   #5
Joe_Zhu
Member
 
Registered: Dec 2003
Distribution: Debian, RedHat
Posts: 32

Original Poster
Rep: Reputation: 15
Hi,
my DD-WRT router ip address is 192.168.1.1, it is the default gateway for all equipment in this 192.168.1.0/24 network. it connect to ISP by ethernet and DHCP. (no modem, pppoe)

and the pptp server setting are;

Server IP: 192.168.1.1
Client IP(s): 192.168.1.180-190
broadcast support: enable
Force MPPE enceryption: enable

what will be the problem?

Joseph

p.s. i tried to change the server ip to 192.168.1.2, as told in DD-WRT wiki.
but still not work for my linux pptp client ...
again the windows client has no problem.

Last edited by Joe_Zhu; 12-11-2009 at 01:20 AM.
 
Old 12-11-2009, 08:01 AM   #6
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,278

Rep: Reputation: 91
Might this have anything to do with Proxyarp settings maybe data is not getting back to it properly, additionally your server address if I recall correctly should be the same as the server itself. However, it looks like everything is setup properly, and that you have networking, as you can use other services, I am baffled.
 
Old 12-11-2009, 09:54 AM   #7
Joe_Zhu
Member
 
Registered: Dec 2003
Distribution: Debian, RedHat
Posts: 32

Original Poster
Rep: Reputation: 15
Hi What is proxyarp? where i can set it in the ubuntu system?
pls. advice, thanks!!

Joseph
 
Old 12-13-2009, 08:21 PM   #8
Joe_Zhu
Member
 
Registered: Dec 2003
Distribution: Debian, RedHat
Posts: 32

Original Poster
Rep: Reputation: 15
hi,

I am studying the proxy arp issue, it seems that it should be in the router (DD WRT).

the router seems somehow not passing the traffic. i found my ssh session freeze after the connection established for awhile.

another point is the linux VPN client get the gateway ip address as specified by the router, but for windows machine, it just use the client ip address as the gateway and seem it make a different. so i guess it could be a work around that let my linux vpn client to set the gateway same as the it's ip in this ppp connection, but i don't know how to do it.....

thanks!
Joseph
 
Old 12-17-2009, 08:20 PM   #9
Joe_Zhu
Member
 
Registered: Dec 2003
Distribution: Debian, RedHat
Posts: 32

Original Poster
Rep: Reputation: 15
Hi All,

the pptp in my ubuntu still not work, however, i have a ip route add in the ip-up.d

which is
#!/bin/sh
if [ "${PPP_IPPARAM}" = "HOME_VPN" ]; then
/sbin/route add -net 192.168.1.0/24 dev ${IFNAME}
fi

after the ppp connection up,
in the route table, there are 2 entries regarding to the remote network '192.168.1.0'

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.1 * 255.255.255.255 UH 0 0 0 ppp0
xxxxxxxxxxxx.xx 10.0.34.254 255.255.255.255 UGH 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 ppp0
10.0.34.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default 10.0.34.254 0.0.0.0 UG 100 0 0 eth0

i would like to add the gateway 192.168.1.1 in 192.168.1.0 and hope it will be help.
but i tried to add gw option in the above route add statement but seems didn't work ....

any suggestion?

Joseph
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VPN Issue on Linux mavinod Linux - Software 3 05-12-2009 04:29 PM
VPN Connectivity Issue? your_shadow03 Linux - Newbie 7 04-22-2009 05:43 AM
Vpn Timing Issue? cmnorton Linux - Networking 1 10-15-2008 05:46 PM
VPN - is there a way to use VPN & normal connection at the same time? natv Linux - Networking 4 09-05-2007 08:48 AM
VPN and AIX issue Avernus Linux - Security 7 09-17-2003 02:36 PM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration