LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-30-2007, 08:42 PM   #1
asalford
Member
 
Registered: Nov 2003
Location: NC, USA
Distribution: unbuntu breazy
Posts: 140

Rep: Reputation: 15
vnuml tun device /dev/net/tun not found.


Thanks in advance for reading this post

running Dapper on an old laptop and trying to setup vnuml and keep getting the following error. the site has almost no info about the problem.

The ultimate goal is to setup a virtual router lab. if there are easier or better ways of doing this, I will be happy to entertain those ideas also. I have already loaded quagga & zebra

Here begins the saga.

configure: error: tun device /dev/net/tun not found. Please set the appropriate device using the --with-tun option.

but I ran config with the following options.

./configure --with-build_modules --with-tun=/dev/net/tun

I tried it with the module loaded and unloaded.
lsmod | grep tun
tun 11904 0

ubuntu reports the following
ls /dev/net/tun
/dev/net/tun
 
Old 01-30-2007, 11:11 PM   #2
asalford
Member
 
Registered: Nov 2003
Location: NC, USA
Distribution: unbuntu breazy
Posts: 140

Original Poster
Rep: Reputation: 15
found the answer

http://jungla.dit.upm.es/~vnuml/doc/...tml#debinstall
quote:
2. Installing from .deb package

An APT respository has been set up for VNUML related packages. The installation procedure is as follows:

1. Add the following line to the /etc/apt/sources.list file:

deb http://jungla.dit.upm.es/~vnuml/debian binary/

2. Update package list:

apt-get update

3. Install VNUML along the packages it depends on

apt-get install vnuml

In addition, although they are not mandatory packages to work with VNUML, it is strongly recommended you install the following:

apt-get install vlan xterm bridge-utils screen

end quote:
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenAFS on an OpenVPN tun device Gsee *BSD 0 05-08-2006 06:28 AM
need help: /dev/net/tun boxyou Linux - Networking 1 04-29-2005 03:11 AM
How do I use /dev/net/tun mike8s2 Linux - Networking 2 04-19-2005 09:01 PM
TUN device error palanisaravanan Linux - Networking 1 11-24-2004 01:17 AM
Getting FD for an existing tun device alanwolfen Programming 1 10-18-2004 12:39 PM


All times are GMT -5. The time now is 07:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration