LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-06-2011, 09:52 AM   #1
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Rep: Reputation: 15
vnc on Centos 5.7 worked and then didn't after restart


I have an old laptop that I want to have sit on a shelf. WOL is working properly and I thought I had vnc working for those few times I did want a gui.

I was able to connect to the laptop via TightVNC from my windows 7 box. After I restarted the Centos laptop, I could no longer vnc in.

Does this have something to do with the fact that no one is logged into the laptop yet, so there's no desktop to actually vnc into?

I've confirmed via "vino-preferences" and iptables that ports 5900 and 5901 are open. I think something online specified 5901 but TightVNC only seemed to work on 5900? I'm not sure on that one.

So what do I need to do to be able to vnc in without anyone having logged into the laptop at the console?

Thanks.
 
Old 11-06-2011, 11:19 AM   #2
bmarx
Member
 
Registered: Dec 2004
Distribution: Slackware, Arch, FreeBSD
Posts: 202

Rep: Reputation: 34
A simple check, but is vncserver running? Do you have it set to start up at boot? What happens if you try to telnet to port 5900?
 
1 members found this post helpful.
Old 11-06-2011, 02:11 PM   #3
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
No, it looks like it's not running

$ telnet 192.168.1.101 5900
Trying 192.168.1.101...
telnet: Unable to connect to remote host: Connection refused

$ telnet 192.168.1.101 5901
Trying 192.168.1.101...
telnet: Unable to connect to remote host: Connection refused

Is vncserver started when I log into the console? I'll try to figure out how to start it at boot then.
 
Old 11-06-2011, 04:18 PM   #4
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
Okay, I followed the directions at

http://wiki.centos.org/HowTos/VNC-Server

and I can now vnc in after boot up and I get a gnome login screen. Wonderful. I can open applications and what not, but then I tried to add a new user via the gui "system-config-users". It prompted me for the root password and then no window. I try to run it from the cmd line via sudo and get the following:

Xlib: connection to "couch:1.0" refused by server
Xlib: No protocol specified

system-config-users requires a currently running X server

Yeah, the laptop is called "couch". Anyways, um, I'm obviously running an server so what gives?
 
Old 11-06-2011, 05:15 PM   #5
Mavman
Member
 
Registered: Mar 2008
Location: Wasilla, Alaska
Distribution: CentOS
Posts: 36

Rep: Reputation: 1
I think the x server has to be running all the time.
Go to /etc/inittab and your line probably reads
Code:
id:3:initdefault:
Change that to -
Code:
id:5:initdefault:
That should make it force the gui as the default log on option, otherwise vnc probably won't work. You'll need to do a reboot after that or just do an 'init 5' to force the runlevel change and go into effect.
 
Old 11-06-2011, 06:17 PM   #6
frznchckn
Member
 
Registered: Jun 2006
Location: CA
Distribution: Ubuntu, CentOS, Scientific Linux
Posts: 97

Original Poster
Rep: Reputation: 15
I do have it set for runlevel 5. The gui login screen is the default, so I am running X

That error about not having an X session came from a terminal from within the VNC session. That's why I'm so confused as I definitely have X running.
 
Old 11-06-2011, 08:36 PM   #7
Mavman
Member
 
Registered: Mar 2008
Location: Wasilla, Alaska
Distribution: CentOS
Posts: 36

Rep: Reputation: 1
Well, the only 2 things I can think of right this minute would be to verify that the service is set to startup by itself (chkconfig vncserver on), and then make sure iptables isn't blocking it somehow.
 
  


Reply

Tags
centos5


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Editing lilo.conf didn't worked ? what i did wrong? RazorT4 Linux - Newbie 2 07-20-2010 09:43 AM
How can I do when the mouse didn't response without restart charlie-bgp Linux - Newbie 1 11-27-2008 12:16 AM
virtualbox, worked fine before a restart Jayla Linux - Software 2 05-28-2008 03:10 PM
Compiz worked then it didn't onthefritz Mandriva 3 11-02-2006 06:39 PM
rebooted server but it didn't restart! ? tester Linux - Newbie 0 08-29-2001 05:51 PM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration