LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-03-2006, 02:47 PM   #1
0p3r4
LQ Newbie
 
Registered: Oct 2005
Location: Sweden
Distribution: Debian/Ubuntu
Posts: 20

Rep: Reputation: 1
vmware guests not being able to reache the Internet


Hello,

I've set up the vmware-server on a Ubuntu-driven laptop (Thinkpad R40) in order to be able to run WinXP, and most things seem to work fine. However, I've not been able to get the network to function correctly, the Internet is unreachable.

I've been trying all kinds of configurations in the network-configuration of the server console, and nothing seems to work, among other things i tried setting the "Network Connection" to "Custom" pointing to /dev/wmnet0 which should be mapped to /dev/eth0, my wired ethernet connection. And that didnt solve anything either. Then I found this forum-page (http://www.ubuntuforums.org/showthread.php?t=183209) and found i hadn't installed the xinetd-package as told in the how-to. Said and done, I installed it and to be safe I also ran the vmware-config.pl application again after doing this, in case something had to be reconfigured in order to work.

After all of this was done, I still can't get in touch with the DHCP-server (at the ISP, I'm not running my own DHCP-server) using "ipconfig /renew" under WinXP. I've tried pinging other machines I have running (including the host of the server) with no sucess. At the moment the NIC-configuration is set to "Bridged" in the settings for the vm.

The one thing I'm noticing that might show something is badly configured from my side is that the icon showing nic-activity (the icon sitting next to the hdd and dvd (when running the vm in windowed mode) is showing no activity at all, whereas the hdd- and dvd-icons are flashing as they should.)

Anyone have any ideas on what i might have done wrong? I would be really grateful for any tips i might get.

PS. I hope my english isn't too bad, and if I've been unclear on anything, please tell me. DS.

Edit: added link to forum mentioned above

Last edited by 0p3r4; 08-03-2006 at 02:54 PM.
 
Old 08-03-2006, 03:52 PM   #2
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
Try using NAT instead of Bridged.

Does that work?
 
Old 08-03-2006, 05:19 PM   #3
0p3r4
LQ Newbie
 
Registered: Oct 2005
Location: Sweden
Distribution: Debian/Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 1
I have thought about the idea of going the NAT way, but as i dont have any routers at hand nor the know-how to setup this kind of system, this is really a last resort for me, I would much rather set it up using the simpler bridged way. However, if you have a good tip on how to setup the NAT without using multiple NIC's i would be more then interested to know about it ... Thanks for taking the time to answer btw.
 
Old 08-03-2006, 05:23 PM   #4
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
Open up VMWare, and on the Network Card Settings.. instead of using "Bridged" try "NAT"
 
Old 08-03-2006, 05:48 PM   #5
0p3r4
LQ Newbie
 
Registered: Oct 2005
Location: Sweden
Distribution: Debian/Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 1
Thumbs up

Trying NAT once again i got the same error as i did previously, namely this:
Code:
Could not open /dev/vmnet8: No such file or directory
Virtual device Ethernet0 will start disconnected.
However, feeling a bit strengthened from your recommendation, I tought i might as well try to set it up in the configuration. This proved to be much more easy than i expected, giving me the possibility to probe for an unused network (which i thought had to be done by assigning a static router ip as default gateway or something like that):

Code:
Configuring a NAT network for vmnet8.

Do you want this program to probe for an unused private subnet? (yes/no/help)
[yes]

Probing for an unused private subnet (this can take some time)...

The subnet 192.168.162.0/255.255.255.0 appears to be unused.

The following NAT networks have been defined:

. vmnet8 is a NAT network on private subnet 192.168.162.0.
And that was pretty much it (almost the same steps did setup the "host-only" connection type as well).

This time around i didn't experince any errors like before, and when i started the web browser, i worked like a charm!

I can't thank you enough for this mate ... Well, once more, thank you
 
Old 09-11-2006, 03:45 AM   #6
trox
Member
 
Registered: Jan 2006
Distribution: Linux Mint 12, FreeBSD, Ubuntu 12.10, Mac OS X
Posts: 83

Rep: Reputation: 15
VMware with Suse 10.1

Did you do this from the bash shell command line or from somewhere inside VMware? In whichever case could you share detailed instructions as I'm getting the exact same error.

Thanks so much,

trox
Quote:
Originally Posted by 0p3r4
Trying NAT once again i got the same error as i did previously, namely this:
Code:
Could not open /dev/vmnet8: No such file or directory
Virtual device Ethernet0 will start disconnected.
However, feeling a bit strengthened from your recommendation, I tought i might as well try to set it up in the configuration. This proved to be much more easy than i expected, giving me the possibility to probe for an unused network (which i thought had to be done by assigning a static router ip as default gateway or something like that):

Code:
Configuring a NAT network for vmnet8.

Do you want this program to probe for an unused private subnet? (yes/no/help)
[yes]

Probing for an unused private subnet (this can take some time)...

The subnet 192.168.162.0/255.255.255.0 appears to be unused.

The following NAT networks have been defined:

. vmnet8 is a NAT network on private subnet 192.168.162.0.


And that was pretty much it (almost the same steps did setup the "host-only" connection type as well).

This time around i didn't experince any errors like before, and when i started the web browser, i worked like a charm!

I can't thank you enough for this mate ... Well, once more, thank you
 
Old 09-11-2006, 04:18 AM   #7
trox
Member
 
Registered: Jan 2006
Distribution: Linux Mint 12, FreeBSD, Ubuntu 12.10, Mac OS X
Posts: 83

Rep: Reputation: 15
Cool VMware with Suse 10.1

Ok,
Figured it out minutes after posting my problem. I:
Closed out VMWare Workstation.
Went back to the command line.
Click here to see what I did from start to finish.

After the command line, I installed all the vmware tools and selected Bridge for my connection choices. I then restarted my virtual OS and it connected to the internet without issue.

Hope this helps someone. Lovin it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet conn using VMware annetteserrao Linux - Networking 21 01-04-2006 07:14 AM
Vmware and Internet! NathanCohen2003 Linux - Software 3 07-05-2004 01:32 AM
To All Filpino LQ Members/Guests: Use/Test Bayanihan! bongski55 Linux - Distributions 1 03-25-2004 12:00 PM
Samba guests and changes in /etc/passwd krajzega Linux - Networking 1 03-08-2004 07:53 AM
Search problem for guests Winno LQ Suggestions & Feedback 4 09-09-2003 01:39 PM


All times are GMT -5. The time now is 02:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration