LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-15-2010, 05:55 AM   #1
Barry1
LQ Newbie
 
Registered: Dec 2010
Location: Germany
Distribution: Debian GNU/Linux, Fedora Project and OpenSUSE LINUX
Posts: 22

Rep: Reputation: 1
Question VLAN-interface comes up slowly


Hi there,

I succesfully configured an OpenSuSE 11.2-System to use the internet via ETH and to connect to our NFS-Fileserver via VLAN.
This is working fine so far.
If rebooting the system (the file ifcfg-vlan** is working fine) the ETH and VLAN interface come up, but it seems that establishing the routing information over the VLAN takes too long:
The user home directories reside on the NFS-Server (autofs also working fine), but if one tries to login to the system (no matter if graphical or via ssh) fast after it comes up, the mounted dirs are not available.
I'm very sure the problem is connected with the route (set up via ifcfg-vlan** file): In one case I got via ssh on the machine and read about my missing home dir. Immediate after that I found missing route entries.
I hope the explainations are detailed enough.

Thanks for all suggestions.

Greets

Barry1

For further details, here is my ifcfg-vlan**

Code:
STARTMODE='auto'
ETHERDEVICE='eth0'
IPADDR='**.***.***.***/22'
 
Old 01-06-2011, 04:49 AM   #2
Barry1
LQ Newbie
 
Registered: Dec 2010
Location: Germany
Distribution: Debian GNU/Linux, Fedora Project and OpenSUSE LINUX
Posts: 22

Original Poster
Rep: Reputation: 1
Question

Hi,

sadly noone answered here.
I got some more details after enabling "debug-logging" in autofs - maybe this can help.
These lines
Code:
Jan  6 11:43:11 aspen automount[2877]: handle_packet: type = 5
Jan  6 11:43:11 aspen automount[2877]: handle_packet_missing_direct: token 4, name /home, request pid 4192
Jan  6 11:43:11 aspen automount[2877]: attempting to mount entry /home
Jan  6 11:43:11 aspen automount[2877]: lookup_mount: lookup(file): looking up /home
Jan  6 11:43:11 aspen automount[2877]: dev_ioctl_send_fail: token = 1
Jan  6 11:43:11 aspen automount[2877]: failed to mount /home
are from my /var/log/messages indicating, that the lookup for the nfs-server is not working.
The entries repeat lets say up to twenty times until it works.

Any suggestions?

Thanks

Bastian
 
  


Reply

Tags
autofs, opensuse112, route, vlan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting the default gateway to a VLAN interface pfust Linux - Networking 2 08-28-2010 07:59 AM
Route non-vlan packet to a vlan interface mic.sed Linux - Networking 2 04-23-2010 02:39 AM
Failed to remove VLAN interface. kanth001 Linux - Networking 1 03-01-2010 03:01 AM
Help in Vlan-Interface Paris Heng Linux - Networking 1 03-02-2009 05:20 PM
Using tcpdump on a sub-interface vlan mikeotieno Linux - Networking 3 09-24-2008 01:32 PM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration