-   Linux - Networking (
-   -   Using Function Keys with SSH (

bad_andy 01-26-2005 10:08 AM

Using Function Keys with SSH
Ok, I got my remote access working. Now I can log into my office server from home, and do everything I want to do....well, almost.

There's one application on the server that I need to run, but it relies on the function keys a lot. When I ssh into the server, all that the function keys give me are strange characters on the screen, like "[2" -- they don't actually do what they're supposed to do.

Has anyone experienced this, and is there any way to correct it?

nixcraft 01-26-2005 10:11 AM

Try to set from bash
export TERM=xterm

You also need to define keys F1, F2 using /etc/inputrc; if keys apps specific it might work or even not try out

bad_andy 01-26-2005 10:18 AM

Sorry, can you explain it a little better? know, for the newbies who might be reading. :)

bad_andy 01-26-2005 06:41 PM

Ok, i found a solution. I'm now running PuTTY with the keyboard option set to SCO. All the functions keys work now. :) Man, I'm loving this! :)

All times are GMT -5. The time now is 04:07 AM.