LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-22-2005, 08:19 PM   #1
Equin
Member
 
Registered: Oct 2004
Location: Merrimack, NH
Distribution: Ubuntu / Apple
Posts: 46

Rep: Reputation: 15
Unstable FTP connections


Hello everybody

I have been having some problems with FTP lately.... Ever since I got my SDSL, actually.

I am running VSFTPD on my Fedora Core 3 server - It is connected to a swich which is connected to my SDSL terminator. My m0n0wall is connected to the switch, too.

The server has a static IP address - 216.177.19.108

Anyway, when I get on a Windows based computer (hooked to a cable modem, not the DSL) and open IE and go to my FTP server, it asks for a password but times out. If I open a command line and connect, it goes just fine and lists the directory.

It seems to be a problem with listing directories, it'll just hang and time out.

I tried to disable passive mode in IE, it will work just fine - But when I tell others to do it, it doesn't work - Maybe I just did something different - lol

Anyway - Is there any way that anybody knows of to make this more... stable? Post if you have any more questions!

Thanks!
-Equin
 
Old 10-28-2005, 10:18 AM   #2
FliesLikeABrick
Member
 
Registered: Aug 2005
Location: NY,USA
Distribution: Debian, Gentoo, Ubuntu
Posts: 103

Rep: Reputation: 15
you need to configure vsftpd to allow passive connections to your server, so that clients that are behind a firewall can open data connections properly.


In short, this consists of opening a range of unpriviliged ports to your server (I use 50000 to 50200) and telling vsftpd that this range is opened for passive connections. Here is a snippet from my vsftpd.conf, the lines that i needed to change or add to get passive ftp working:

pasv_enable=YES
pasv_min_port=50000
pasv_max_port=50200
pasv_address=72.224.117.144


the first line tells it to enable passive connections (duh)
the next two are the high and low end of the range of ports to use. If you leave these lines out, it will assume that any ports > 1024 can be used
the last is the address that it should send to the client computers for them to connect to. If you do not have this, the server will likely send out it's LAN address if it is not directly connected to the internet.

If you google for "vsftp passive configuration" and the like, you will find a ton of information about this.

I'll try to watch this thread if you have any more questions, I spent a lot of time figuring this out and I'm pretty confident in what I think I know now :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP connections keep stalling Kovacs Slackware 2 07-12-2005 11:55 AM
FTP Dropping connections Seventh Linux - Software 1 06-05-2005 03:11 PM
FTP Outside Connections Denied Kelba Linux - Networking 3 09-06-2004 05:38 AM
Allow Ftp Connections with SuSE 9 aeruzcar Linux - Networking 3 03-24-2004 07:16 AM
ftp/telnet not accepting connections mstembri Linux - Newbie 6 10-05-2003 03:11 PM


All times are GMT -5. The time now is 10:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration