LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Unable to print to Samba printer from WinXP (http://www.linuxquestions.org/questions/linux-networking-3/unable-to-print-to-samba-printer-from-winxp-286315/)

TSloth 02-04-2005 04:35 PM

Unable to print to Samba printer from WinXP
 
I have a Mandrake system running Samba sharing a directory and a printer using SHARE security.
From a Win98 system I can access the shared directory and print on the printer. :)
From a WinXP system I can access the shared directory but can't print on the printer. :(
The WinXP system shows "Access denied, unable to connect" when I try to open the printer.

How can I get the WinXP system to print to the Samba printer?

my smb.conf follows...

Thank you,
- TSloth


_________________________
# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2005/01/27 13:45:04

# Global parameters
[global]
netbios name = PRISM
server string = Samba server %v
security = SHARE
passwd program = /usr/bin/passwd %u
passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *
passwd:*all*authentication*tokens*updated*successfully*
unix password sync = Yes
log level = 2
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
hosts allow = 192.168.1.

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p %s # using cups own drivers (use generic PostScript on clients).
lpq command = cups -o %p
lprm command = cancel %p-%j

[E]
comment = Shared
path = /mnt/win_e
read only = No
guest ok = Yes

Peacedog 02-04-2005 05:35 PM

Try adding this under [printers].

use client driver = yes

good luck.

TSloth 02-04-2005 10:49 PM

Peacedog,

You are so right!

I added

use client driver = yes

and it prints from XP now!

Thank you,
- TSloth

Peacedog 02-06-2005 05:13 PM

Glad you got it sorted.
good luck.


All times are GMT -5. The time now is 05:23 AM.