LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 11-20-2004, 09:47 AM   #1
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Rep: Reputation: 30
unable to connect to internet


I installed, compiled and booted kernel 2.6.9 and now I can't connect to the internet. My connection is ADSL from a laptop with no router or anything too fancy. I compiled pppoe in the kernel (tried compiling in and as module) and the network card also as module. The connection is configured with pppoeconf with no errors, but no connection either. I don't know what the problem could be.

ifconfig only shows eth0 and lo but it should also show ppp0

I have no problems with kernel 2.4.27 only 2.6 kernels.
 
Old 11-20-2004, 01:50 PM   #2
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Boot the 2.4.27 kernel and do an lsmod and make note of all modules. Then do the same with 2.6.9 kernel. If any modules are missing, then first try to modprobe them, if that doesn't work then you will need to configure the 2.6.9 kernel again and rebuild the kernel and modules.

NOTE: Sometimes if all you do is add a module then you just need to run make modules and make modules install but this doesn't always work.
 
Old 11-20-2004, 03:20 PM   #3
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks, I forgot the ppp parts.
Although when I compiled them as modules they wouldn't load. I got an error "modules wrong file type" or something similar to that. I went back and compiled those parts into the kernel and now all is well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to connect to internet ashwin_cse Fedora 9 07-30-2007 09:39 AM
Unable to connect to the Internet Melanieb Suse/Novell 4 08-17-2005 11:51 AM
Unable to connect to the Internet Melanieb Linux - Newbie 1 08-15-2005 05:52 PM
Unable to connect to the internet bear2x Linux - Networking 6 07-22-2005 08:42 AM
Unable to connect to the internet xxvm1 Mandriva 24 09-22-2004 08:59 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration