LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-29-2005, 09:48 PM   #1
mariusak
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian 3.0
Posts: 23

Rep: Reputation: 15
Unable to browse WORKGROUP when samba running


Hi!

I have a windows network with one CentOS box beeing the backup server. The 8 Windows XP Home SP2 clients can make backups to samba, and samba works as it it supposed to (configured using Webmin).

BUT:

As long as the samba server is running, I cannot browse the workgroup from a WinXP computer. If I type the name (\\COMPUTERNAME\) I can access other computers, but I cannot browse it (My Network Places\Microsoft Windows Network\WORKGROUP NAME).

When I click the workgroup name, it tells me: WORKGROUP NAME is not accessible. You might not have the permissions to use this network resource...

These options are set in global:

domain master = yes
local master = yes
preferred master = yes
os level = 65

..and the workgroup name is correct.

Any clues? Thanks alot for any reply, or indication on what to google on. Could not find anything which could help me on the net..

Have a nice day!

-Marius
 
Old 05-30-2005, 12:46 AM   #2
RoofRabbit
Member
 
Registered: Mar 2004
Location: Lenoir, NC USA
Distribution: Mandrake 10.2
Posts: 129

Rep: Reputation: 15
It might be a "Master" conflict problem. My lan works perfectly using:

Mandrake 9.1 Server (Internet Gateway too).
Win2kPro, WinXP, or Mandriva on my pc.
Win2kPro on my TV pc.
Win2kPro or Mandrake 9.1 on Wife's pc.

My Samba setup is described on this page:

http://roofrabbit.com/vsamba.html
 
Old 05-30-2005, 01:12 AM   #3
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
Check that the Linux Server has wins server...
add this to smb.conf..
wins server = yes

Last edited by saneax; 05-30-2005 at 01:15 AM.
 
Old 05-30-2005, 01:31 AM   #4
mariusak
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian 3.0
Posts: 23

Original Poster
Rep: Reputation: 15
still not any better..

hi!

Thanks for your tips, but non of the above helped :-(

wins is enabled, and i could not find any help on the page of RoofRabbit..

-Marius
 
Old 05-30-2005, 02:03 AM   #5
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
What's your work group name...
it shouldnt be more than 15 chars...
and on ur linux just check the output with 'findsmb'
does ur workgroup figure in the output ?

also post ur smb.conf... file
 
Old 05-30-2005, 04:24 AM   #6
mariusak
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian 3.0
Posts: 23

Original Poster
Rep: Reputation: 15
some new info..

The PC's on the network all have fixed IP's, and they alle get the Acces denied. However, my laptop has automatic IP settings, and I can access the Workgroup, but I can only see myself and the Canon printer. No other computers.

Because of some problem long back (is going to be changed soon) we use "Windows" IP's (169.254.......) in our network. Could this have anything to do with the problem?

Sorry about the "long" config file, but I have always used webmin to configure it (more or less at least) so that's why..

Thanks again for your help!



[global]
log file = /var/log/samba/%m.log
load printers = yes
idmap gid = 16777216-33554431
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
domain master = yes
winbind trusted domains only = yes
winbind use default domain = no
template shell = /bin/false
wins support = true
dns proxy = no
netbios name = YMEBACK
cups options = raw
server string = Yme Backup
idmap uid = 16777216-33554431
winbind enum users = no
default = homes
local master = yes
workgroup = Geo-recon
winbind enum groups = no
os level = 65
printcap name = /etc/printcap
valid users = horstad
security = user
preferred master = yes
max log size = 50
wins server = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
# Set public = yes to allow user 'guest account' to print
guest ok = no
writable = no
printable = yes

# This one is useful for people to share files
;[tmp]
; comment = Temporary file space
; path = /tmp
; read only = no
; public = yes

# A publicly accessible directory, but read only, except for people in
# the "staff" group
;[public]
;[public]
; comment = Public Stuff
; path = /home/samba
; public = yes
; read only = yes
; write list = @staff

# Other examples.
#
# A private printer, usable only by fred. Spool data will be placed in fred's
# home directory. Note that fred must have write access to the spool directory,
# wherever it is.
;[fredsprn]
; comment = Fred's Printer
; valid users = fred
; path = /homes/fred
; printer = freds_printer
; public = no
; writable = no
; printable = yes

# A private directory, usable only by fred. Note that fred requires write
# access to the directory.
;[fredsdir]
; comment = Fred's Service
; path = /usr/somewhere/private
; valid users = fred
; public = no
; writable = yes
; printable = no

# a service which has a different directory for each machine that connects
# this allows you to tailor configurations to incoming machines. You could
# also use the %u option to tailor it by user name.
# The %m gets replaced with the machine name that is connecting.
;[pchome]
; comment = PC Directories
; path = /usr/pc/%m
; public = no
; writable = yes

# A publicly accessible directory, read/write to all users. Note that all files
# created in the directory by users will be owned by the default user, so
# any user with access can delete any other user's files. Obviously this
# directory must be writable by the default user. Another user could of course
# be specified, in which case all files would be owned by that user instead.
;[public]
; path = /usr/somewhere/else/public
; public = yes
; only guest = yes
; writable = yes
; printable = no

# The following two entries demonstrate how to share a directory so that two
# users can place files there that will be owned by the specific users. In this
# setup, the directory should be writable by both users and should have the
# sticky bit set on it to prevent abuse. Obviously this could be extended to
# as many users as required.
;[myshare]
; comment = Mary's and Fred's stuff
; path = /usr/somewhere/shared
; valid users = mary fred
; public = no
; writable = yes
; printable = no
; create mask = 0765

[homes]
valid users =
writeable = yes
 
Old 05-30-2005, 04:28 AM   #7
tobias_r33per
Member
 
Registered: Aug 2003
Location: Sydney
Distribution: Fedora Core 14, Gentoo 2011, Mandriva 2010 Powerpack, Ubuntu 10.10
Posts: 49

Rep: Reputation: 17
In the smb.conf try adding the

browseable = yes

Command to the shares and make sure your Firewall has been configured correctly.
It may also be the networkj config on the Window$ end not the linux end.

You may need to revirew your network configureation.
 
Old 05-30-2005, 04:48 AM   #8
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
your config file is not appropriate...
I dont see the
security = users/ads/domain/server line...

I hope you are trying to act as a PDC server then ur conf file should have the bare minimum like I have... please avoid webmin, it nearly corrupts ur smb.conf file... unless u are a pro...

here is a sample smb.conf file of a PDC server I have...

[global]
netbios name = localhost
workgroup = workgroup
passdb backend = tdbsam

obey pam restrictions = yes
pam password change = yes
encrypt passwords = yes
unix password sync = yes

wins support = yes
add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/usermod -G %g %u
add machine script = /usr/sbin/useradd -s /bin/false -d /dev/null %u
logon script = scripts\logon.bat
os level = 33
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \\%N\profiles\%U
logon drive = H:
logon home = \\%N\%U
idmap uid = 15000-20000
idmap gid = 15000-20000
admin users = @admins
[homes]
comment = Home Directories
valid users = %S
read only = No
browseable = No
[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
read only = yes
write list = @admins
[profiles]
path = /var/lib/samba/profiles
read only = no
create mask = 0600
directory mask = 0700


also advise you to read the docs for howto configure samba as a PDC.. at http://www.samba.org/samba/docs/man/...samba-pdc.html
 
Old 05-30-2005, 05:31 AM   #9
mariusak
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian 3.0
Posts: 23

Original Poster
Rep: Reputation: 15
well well

As usual, if you (I) try to use a easy way to do it (webmin), in the end it does not work as you want it to..

So, as too many times before, there is not any other option that to read proper documentation and really learn it. How it works.

Thanks for your help, I will be back (in about a years time, when i have figured it all out, and can start to ask intelligent questions)..

Just for information, my laptop (which runs with automatic IP's now gets the same access error as the other machines (see above)..

Have a lovely day!

-Marius

-Browsable did not work
-I will look into your config file, but before I "paste" it into my system, I have to read some documentation:-)
 
Old 05-30-2005, 06:40 AM   #10
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
go to http://interstructures.com.. they have something which will let you do it in 15 minutes... just the easy, costly way
 
Old 05-30-2005, 06:44 AM   #11
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
Lightbulb

just in case some webmin developer ever comes across this post... try tomake things easier for end user. We should learn this from the MS guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't browse workgroup (suse 9.3) mbquartnut Linux - Networking 1 11-09-2005 10:04 PM
Samba - unable to sync browse lists MikeAtVillage Linux - Networking 6 06-29-2005 03:04 AM
Can't browse Windows Workgroup due to Samba? CanadianSlacker Linux - General 4 05-07-2004 06:49 PM
can't browse windows workgroup when linux box online revdshepard Linux - Networking 2 02-04-2004 02:14 PM
unable to browse samba share from windows 2003 kfloda Linux - Software 1 08-16-2003 07:14 AM


All times are GMT -5. The time now is 10:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration