LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 01-15-2013, 03:15 AM   #1
rj_gtx
LQ Newbie
 
Registered: Jan 2013
Posts: 13

Rep: Reputation: Disabled
unable to attach office files to yahoo


hello,

I'm having a problem attaching office files to yahoo mail.
when i browse for example an excell file, it keeps on loading like forever.
but when i compressed it using winrar, it completed attaching like 5 seconds...
my connection speed is 2mb/s i don't think it has something to do with my connection..

only the client PC's on the private network behind my squid transparent proxy is experiencing this problem
my PC is the only one who has full access to the internet cause Ive added a rule on squid to allow just my PCs IP.
Ive already allowed SMTP port on my IPtables.

heres my squid.conf:
Quote:
#

# Recommended minimum configuration:

#

acl manager proto cache_object

acl localhost src 127.0.0.1/32 ::1

acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1


# Example rule allowing access from your local networks.

# Adapt to list your (internal) IP networks from where browsing

# should be allowed

acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines


acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

#ACL blocksites
acl blocksites dstdomain "/etc/squid/blockedsites.squid"

#ACL blockkeywords
acl blockkeywords url_regex -i "/etc/squid/blockkeywords.squid"

#ACL allowip
acl allowip src "/etc/squid/allowip.squid"


#deny extension
acl extensiondeny url_regex -i "/etc/squid/extensiondeny"
acl download method GET
http_access deny extensiondeny download
http_access deny extensiondeny

#

# Recommended minimum Access Permission configuration:

#

# Only allow cachemgr access from localhost
http_access allow manager localhost

# Deny access to blocksites ACL
http_access deny blocksites !allowip

# Deny access to blockkeywords ACL
http_access deny blockkeywords !allowip
http_access deny manager



# Deny requests to certain unsafe ports
http_access deny !Safe_ports


# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports



# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost



#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#



# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost


# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 3128 intercept

# We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# Uncomment and adjust the following to add a disk cache directory.
#cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid


# Add any of your own refresh_pattern entries above these.

refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320

# set visible_hostname (specify hostname)
visible_hostname squid.server.commm
Somebody please tell me whats causing this...my office mates are getting pissed when compressing a single file every time they send an email
instead of directly sending the file itself..

when i try to attach a excell file, this comes out on the access log:
Quote:
1358234624.651 0 192.168.2.117 TCP_DENIED/403 3107 GET http://us-mg6.mail.yahoo.com/neo/php/attach.php? - NONE/- text/html
but when i compressed it using winrar, this comes out:
Quote:
358234686.060 508 192.168.2.117 TCP_MISS/200 1052 GET http://us-mg6.mail.yahoo.com/neo/php/attach.php? - DIRECT/203.84.197.9 text/html
 
Old 01-15-2013, 03:23 PM   #2
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,060

Rep: Reputation: 88
The squid support anti-virus. That block excell file uploading.
 
Old 01-15-2013, 04:50 PM   #3
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,626
Blog Entries: 1

Rep: Reputation: Disabled
Code:
less /etc/squid/extensiondeny
should yield a clue.
 
Old 01-15-2013, 07:47 PM   #4
rj_gtx
LQ Newbie
 
Registered: Jan 2013
Posts: 13

Original Poster
Rep: Reputation: Disabled
so, what rules should i add to squid for it to allow office files for upload?

thanks for your help.
 
Old 01-16-2013, 07:00 AM   #5
rj_gtx
LQ Newbie
 
Registered: Jan 2013
Posts: 13

Original Poster
Rep: Reputation: Disabled
the only content of that extensiondeny file is .torrent$
 
Old 01-16-2013, 03:31 PM   #6
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,060

Rep: Reputation: 88
You need check squid log file to find out which ACL rule block excell file. You configure multi rule to block traffic.
 
Old 01-17-2013, 08:18 PM   #7
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,626
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
but when i compressed it using winrar, it completed attaching like 5 seconds......
Why do you suspect Squid?
Maybe yahoo doesn't take .xls documents (that would be why winrar'd archives work, IMO).

Easy test, rename the file.xls you are trying to send to file.zip ( do NOT zip it up, just rename it) and send file.zip to yahoo and see what's what.

http://www.ehow.com/info_12173098_ex...ahoo-mail.html
 
Old 01-20-2013, 07:43 AM   #8
rj_gtx
LQ Newbie
 
Registered: Jan 2013
Posts: 13

Original Poster
Rep: Reputation: Disabled
this problem is solved....you might think this is crazy but when i delete the word "cum" on the blocked keywords list, now yahoo can upload office files....hahaha... thanks people...
 
Old 01-20-2013, 05:05 PM   #9
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,626
Blog Entries: 1

Rep: Reputation: Disabled
ouch, but good eye.
No way to circumvent that one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] mutt : someone@somedomain.com unable to attach file. angel115 Linux - Software 2 11-15-2010 06:12 AM
[SOLVED] Unable to attach a C file of 32.8 kilobytes TheIndependentAquarius LQ Suggestions & Feedback 28 05-06-2010 03:17 AM
ORA-24123: unable to attach to shared memory segment yrkhond Linux - Newbie 1 03-17-2008 08:17 PM
Cisco VPN client unable to attach to driver Baracuda Linux - Networking 3 06-22-2006 11:45 PM
attach sound files to events wallybsams Mandriva 2 10-24-2005 03:12 AM


All times are GMT -5. The time now is 06:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration