LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-11-2004, 09:36 AM   #1
TBomb
Member
 
Registered: May 2004
Location: Great Britain
Distribution: Slackware
Posts: 91

Rep: Reputation: 15
Unable to access internet


Slackware Linux 10.0
KDE 3.2.3
Internet Connection via ethernet -> router

I just upgraded to Slack 10.0, everything was apparantly working correctly. I've just done netconfig and put in the same settings that worked perfectly previously in Slackware 9.1. It works, I can ping other computers on my network, but when I tried going to google, I had a host not found error.

I thought it was a gateway error, so I checked it was set to 10.0.0.2, the router, and it was... So I tried pinging the router, and strangely I got a reply, yet it doesn't seem to want to give me internet access... I use this router for other computers on the network, and they are experiencing no difficulty accessing the network.
 
Old 08-11-2004, 09:48 AM   #2
TBomb
Member
 
Registered: May 2004
Location: Great Britain
Distribution: Slackware
Posts: 91

Original Poster
Rep: Reputation: 15
btw, I just tried pinging my WAN address, and it gets a reply from it, but still nothing from the rest of the internet...???
 
Old 08-11-2004, 10:22 AM   #3
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
Check the file /etc/resolv.conf
it should contain the name of your isp dns
nameserver nn.nn.nn.nn
 
Old 08-11-2004, 10:27 AM   #4
TBomb
Member
 
Registered: May 2004
Location: Great Britain
Distribution: Slackware
Posts: 91

Original Poster
Rep: Reputation: 15
The file is empty except for one line:

Code:
search thepenguin
thepenguin is the computers hostname.
 
Old 08-11-2004, 10:29 AM   #5
TBomb
Member
 
Registered: May 2004
Location: Great Britain
Distribution: Slackware
Posts: 91

Original Poster
Rep: Reputation: 15
Problem solved I added the line:

nameserver 10.0.0.2

the IP being that of my router, now it works. Strange though, I didn't have to use a nameserver before Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to get full internet access : only Google works !! samael26 Mandriva 15 11-11-2004 11:54 AM
ipchains ? Unable to access internet ... dns error ! mystique98ls Linux - Newbie 5 09-17-2004 09:06 AM
Unable to Access the Internet - not sure why zensufi Linux - Hardware 9 07-20-2004 06:14 PM
RH9- Unable to access the internet from Lan turkhat Red Hat 5 05-22-2004 06:04 AM
Unable to access internet after setting Firewall? novkhan Linux - Networking 1 04-26-2004 11:50 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration