LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Closed Thread
 
Search this Thread
Old 11-28-2007, 10:12 PM   #1
patrarch
LQ Newbie
 
Registered: Nov 2007
Posts: 2

Rep: Reputation: 0
udev rule failing to create iscsi symlinks


Hello. I posted this initially in the newbies section, then realized maybe it belonged here instead.

Any udev gurus out there?

I have a udev rule that simply creates a symbolic link in /dev given an iscsi device:

BUS="scsi", SYSFS{vendor}="EQLOGIC ", PROGRAM="/root/devpath2alias %k %n", SYMLINK="%c"

I know this rule is valid because it works perfectly when I run 'udevstart' manually, but I want the rule to run at boot, which it does not.

To generate the link name, I have a script that uses iscsi-ls to retrieve the TARGET NAME of an iscsi connection at /dev/sd[whatever]. Again, it works great - but not at boot.

Looking at the boot log, I noticed that the device nodes (/dev/sd[whatever]) are created AFTER my rule is executed! That is,

...
Nov 28 20:37:25 pndtest1 udev[7773]: configured rule in '/etc/udev/rules.d/95-local.rules' at line 4 applied, added symlink '%c'
...
Nov 28 20:37:26 pndtest1 udev[5145]: creating device node '/dev/sde4'
...

Is it possible that my rule is failing because the device node has not been assigned yet? If so, what would be the correct rule to write then? If not, why in the world is this happening?


Many many thanks for any help you can give me.

patrarch
 
Old 11-29-2007, 01:41 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
udev rule failing to create iscsi symlinks! patrarch Linux - Newbie 1 11-29-2007 03:42 PM
what udev rule to create /dev/inet/tcp? bbeers Slackware 2 02-21-2007 04:55 PM
need help with udev rule hussam Linux - Software 2 12-05-2006 03:30 AM
udev complains about symlinks binarybob0001 Linux - Software 6 10-16-2006 08:00 PM
How to manage hard disk partitions symlinks in udev? linx win Debian 1 01-11-2006 04:25 PM


All times are GMT -5. The time now is 11:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration