LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-30-2009, 03:36 PM   #1
rioguia
Member
 
Registered: Jun 2002
Posts: 411

Rep: Reputation: 30
Ubuntu wired connection missing default gateway


My 9.04 Ubuntu wired connection on my Dell Inspiron appears to be fine when I look at the configuration files and gui interfaces. It will ping my network fine and query dig successfully but no other services work. After I open a terminal and route -n shows no gateway

I added a gateway like below.
sudo route add default gw xxx.xxx.xxx.xxx (my route IP)

Then all services work fine.

What am I doing wrong?
 
Old 08-30-2009, 04:21 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hello rioguia,

I'm not familiar with ubuntu. But please post if you're using DHCP.

Markus
 
Old 08-31-2009, 11:22 AM   #3
rioguia
Member
 
Registered: Jun 2002
Posts: 411

Original Poster
Rep: Reputation: 30
Sorry for the lack of specifics.
I am using a static IP for this wired connection directly to a Netgear router.
 
Old 08-31-2009, 12:53 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Simply spoken, if you don't use DHCP there must be a configurationfile somewhere in your system where the gateway is specified. For example in Slackware there is a /etc/rc.d/rc.inet1.conf with a line:
Code:
gateway=""
where I can insert my gateway (if I didn't use DHCP).

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow internet in ubuntu 8.10 using pppoe wired connection T_1000 Ubuntu 5 04-16-2009 03:56 PM
Can't get the wired connection to work in Ubuntu AFayer Linux - Networking 1 03-11-2009 12:41 AM
No wired internet connection in Ubuntu 8.10 CrownAmbassador Linux - Hardware 15 11-29-2008 12:28 PM
Ubuntu Wired connection problems??? theunixwizard Linux - Networking 3 06-13-2008 11:33 AM
Fedora - missing default gateway on startup chriswei Linux - Networking 2 09-14-2004 03:09 PM


All times are GMT -5. The time now is 11:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration