LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-30-2006, 08:42 PM   #1
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Rep: Reputation: 0
type smb unknown when trying to mount xp mount via samba


When running Fedora Core 3 I was able to:

mount /mnt/kodiak

Now when upgraded to Fedora Core 5 the same command gives:

mount: unknown filesystem type 'smb'

My /etc/fstab line is:

//kodiak/C /mnt/kodiak smb noauto,user,rw 0 0

Any insights?

Thanks,
 
Old 10-30-2006, 10:52 PM   #2
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
i think you must change smb to smbfs
 
Old 10-31-2006, 09:50 AM   #3
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
re: smb or smbfs

Actually I already tried that. Still unknown filesystem. The smb worked fine in FC3.

Strange...

Thanks,
 
Old 10-31-2006, 01:11 PM   #4
okmyx
Member
 
Registered: May 2004
Location: Cornwall, UK
Distribution: Ubuntu 8.04
Posts: 464

Rep: Reputation: 31
Have you tried vfat as the filesystem
 
Old 10-31-2006, 01:32 PM   #5
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
vfat vs smb/smbfs

I didn't expect vfat to work, since it is being shared on the Linux side by samba - and unfortunately I was correct.

The smb notation works fine on my other (FC3) machine - the problem seems to be the upgrade from FC3 to FC5 - something was left out or improperly updated.

Thanks,
 
Old 11-01-2006, 06:51 PM   #6
caseyo2112
LQ Newbie
 
Registered: Nov 2006
Posts: 1

Rep: Reputation: 0
smbfs mount not working

I am having the same problem with a new FC5 install. Let me know if you find the solution.

Do you see smbfs listed when you type...

cat /proc/filesystems

I don't.
 
Old 11-01-2006, 10:56 PM   #7
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
I have found out so far that I must replace smbfs with cifs, but it only works if I:

mount -t cifs //192.168.1.100/C /mnt/kodiak

it will fail if I use

mount -t cifs //kodiak/C /mnt/kodiak

which is lame, since man mount.cifs says it should work and nmblookup (also part of samba) can find //kodiak just fine (and returns an IP of 192.168.1.100)
 
Old 11-01-2006, 11:40 PM   #8
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
mount -t cifs //192.168.1.100/C /mnt/kodiak
you use windows 2003 server?If I not mistaken we use cifs only with this OS

about the linux linux not understand host 'kodiak', it is definitely if you don't put it at dnsserver or /etc/hosts.
please add

kodiak 192.168.1.100
in /etc/hosts
 
Old 11-02-2006, 12:08 PM   #9
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks - that worked, except kodiak uses DHCP, and won't always be 192.168.1.100 - samba is supposed to accept //kodiak as a share name, and resolve the IP that way.

nmblookup //kodiak (also part of samba) returns 192.168.1.100 without any changes to /etc/hosts

is cifs really unable to use windows sharenames?!

Last edited by jpantone; 11-02-2006 at 12:10 PM.
 
Old 11-02-2006, 02:10 PM   #10
New2Linux2
Member
 
Registered: Jan 2004
Location: Arizona
Distribution: Debian
Posts: 147

Rep: Reputation: 43
This is probably a little late for you, but if you want to go back to mounting it as a smb share, try installing the smbfs package for your distro. I had to install that seperately from Samba on my Debian box to mount network shares from my W2K server.
 
Old 11-02-2006, 08:07 PM   #11
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
I had never try use it, but you can try add in wins in /etc/nsswitch.conf
 
Old 11-06-2006, 04:49 PM   #12
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
OK - found my answer....

to mount a windows XP share in FC 5 (as root) do:

mount -t cifs //XPHostname/Sharename /mountpoint -o rw,password="password"

the -o is for options, here read/write and password=password

to unmount:

umount /mountpoint

in fstab:

//XPHostname/Sharename /mountpoint cifs noauto,rw,password="password"

then you can just

mount /mountpoint
 
Old 11-06-2006, 04:51 PM   #13
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
To get the //XPHostname/Sharename to resolve winbind must be running at bootup, apparently it is not running by default. Use your favorite bootup configurator to get it going automatically at boot. (I really like webmin)
 
Old 11-06-2006, 04:52 PM   #14
jpantone
LQ Newbie
 
Registered: Mar 2003
Location: Poway, CA (San Diego)
Distribution: Fedora Core 5
Posts: 19

Original Poster
Rep: Reputation: 0
Can anyone point me to a page to change my Newbie to something else :-)
 
Old 11-07-2006, 07:49 PM   #15
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
please post more. from asking question to answering question. more than 30 post than u will level up to members. Just like New2Linux2, i think he just promoted.

If you want better title, I think you need to post more than 1000.
 
  


Reply

Tags
mount, smb, unknown


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
smb mount folders disappear on mount & konqueror smb fails: network unreachable tisource Linux - Networking 1 10-17-2007 01:30 AM
mount: unknown filesystem type 'devfs' error kushalkoolwal Debian 22 03-14-2006 05:14 AM
mount: unknown filesystem type 'NTFS' jnorcal Slackware 8 09-07-2005 07:18 PM
mount: unknown filesystem type 'ntfs' lowrida Linux - Newbie 3 08-01-2005 05:02 PM


All times are GMT -5. The time now is 03:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration