LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-09-2007, 11:03 AM   #1
ScottReed
Member
 
Registered: Dec 2005
Location: Montana
Distribution: Debian "squeeze"
Posts: 157

Rep: Reputation: 30
Question Two NICs - Slackware 10.2 - Strange behavior


Hi all -

I have the following setup, which is working fine:

eth0
Realtek 8169s onboard NIC
IP - 192.168.120.12
Mask - 255.255.255.128
GW - 192.168.120.1

eth0:0
Realtek 8169s onboard NIC
IP - 169.254.254.211
Mask - 255.255.0.0

ath0
Proxim Orinoco Wireless G
IP - 192.168.110.12
Mask - 255.255.0.0

This setup has been working fine for about a year. I am able to access my local network at 192.168.120.0 through eth0 and my renters network at 192.168.110.0 through ath0.

I am also able to access my Canopy infrastructure at 169.254.0.0 through the eth0:0 interface.

The default gw is 192.168.120.1 which is where all my internet traffic goes.

OK, so yesterday I decided to add a second NIC, a Netgear FA311, to illiminate the two ip's on the Realtek 8169s interface. I recompiled support for the card into my kernel (2.6.18.3) and installed the card.

As soon as I booted the machine with the new interface, I was unable to access 192.168.120.0 and 169.254.0.0

If I enabled the wireless interface, I could assign my regualr ip to the interface and access my renters network.

What gives here? I currently pulled the FA311 and went back to my original setup.

Thanks,
Scott
 
Old 02-09-2007, 11:55 AM   #2
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Are you sure you didn't mean for the netmask on your wireless interface to be 255.255.255.128? As it is now, it thinks that IP addresses on eth0 are on the same subnet and tries to send to them directly, but eth0 doesn't think that IPs on ath0 are on the same subnet. Generally it's Very Bad(tm) to put two different interfaces on the same subnet.

Try changing the nastmask on ath0 from 255.255.0.0 to 255.255.255.128 (or 255.255.255.0) and see if that fixes it. You also need to have IP forwarding enabled in the kernel.
 
Old 02-09-2007, 05:14 PM   #3
ScottReed
Member
 
Registered: Dec 2005
Location: Montana
Distribution: Debian "squeeze"
Posts: 157

Original Poster
Rep: Reputation: 30
Quote:
Are you sure you didn't mean for the netmask on your wireless interface to be 255.255.255.128? As it is now, it thinks that IP addresses on eth0 are on the same subnet and tries to send to them directly, but eth0 doesn't think that IPs on ath0 are on the same subnet. Generally it's Very Bad(tm) to put two different interfaces on the same subnet.
The wireless adapter is part of a completely seperate network on the otherside of the building I am in. They have their own router and their own network of pc's. I enable my wireless adapter when they need support and I can remote into their windows boxes, etc...

My eth0 interface is part of my own network. I have my own router and my own internet connection.

--Motorola Canopy Equipment--
|
--5-Port Switch--
|
--Renter Rtr WAN-- --My Router WAN-- --My Router SWITCH--
192.168.110.0 192.168.120.0 169.254.0.0
That is a rough diagram...

The renters have their own PPPoE account
I have my own PPPoE account
We share the same Canopy equipment

The reason I have two cat5's from my switch to my router is so that I can sit on the 169.254 network (the Canopy network) AND my network 192.168.120.0. I wanted to eliminate that CAT5 drop from the switch to my routers switch and use the second nic and go straigh to the 5-port router.

The way I have it setup now works, but it less than desireable. I'm not running DHCP on my router so that is the main reason why this setup works OK, but I really don't want the CAT5 going between the two switches.

Anyway, I do not have IP Forwarding in my kernel. Is that a requirement if I want two NIC's?

Thanks for the help so far
Scott
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange XEmacs Behavior trashbird1240 Slackware 6 01-04-2007 06:42 AM
Very Strange Behavior raysr Mandriva 4 08-31-2004 03:06 PM
Very strange issue with 2 NICs gauge73 Linux - Networking 15 10-16-2003 04:26 AM
Strange Behavior andrewb758 Linux - Hardware 5 08-31-2003 03:42 PM
strange behavior abhijit Linux - General 3 07-10-2003 12:25 AM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration