LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 08-03-2005, 09:26 AM   #1
Xing
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RH 9, RH 8, RH 7.3,Slackware
Posts: 123

Rep: Reputation: 15
two lan card configuration problem


Hi all,

i have a slack 10.1 machine.. i have put 2 lan cards on it.. one lan card (eth0) is being used for internal LAN and i have configured it with a static IP address and a particular gateway and subnet mask..

the other LAN card (eth1) i want to configure for internet using DHCP (a requirement of my service provider).. using netconfig, it is possible to do so for eth0 only.. how do i configure the eth1 with DHCP and later how do i tell the trafic to route itself from eth1.

also i have noticed that with every reboot, i have to run command "eth1 up" to up eth1.. how to do same at the boot time only?

regards

xing
 
Old 08-04-2005, 06:26 AM   #2
Xing
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RH 9, RH 8, RH 7.3,Slackware
Posts: 123

Original Poster
Rep: Reputation: 15
Well Well, no solution till now..
ok i have solved the problem and now am moving to next step.... allowing other people to access through this gateway..

now other machines on my network are in range 172.16.X.X and connect to eth0. My internet is through eth1 and is configured through DHCP. So now how do i allow other users to access intenet.. Proxy is one way but it is somehow confusing me. Also i have to configure squid in future to restrict the priviledges available to all and hence provide an efficient management.

Enlighten!!

regards

xing
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lan card problem - Two devices for the same card e-freak Fedora 4 08-25-2005 01:07 PM
problem with LAN configuration aditya1 Linux - Networking 5 03-10-2005 02:46 PM
Lan configuration problem - NFS boot problem - RX&TX packets errors 242VDM242 Linux - Networking 4 11-25-2004 02:35 PM
Lan card configuration problem. tushar123 Linux - Networking 1 09-10-2004 10:24 AM
eth0/LAN configuration problem TudeCat Linux - Newbie 2 05-17-2004 09:42 PM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration