LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Trying to SSH through a proxy server (http://www.linuxquestions.org/questions/linux-networking-3/trying-to-ssh-through-a-proxy-server-450005/)

Scotteh 05-30-2006 03:40 PM

Trying to SSH through a proxy server
 
At school, I'd like to be able to SSH home so I can get files from my computer (I won't be a breach of security), but because of the proxy (I think), it doesn't let me. I get an error when trying to connect using PuTTY: "Network error. Connection timed out." Or something of the same meaning. Is there any way to SSH through the proxy so that I can connect to my house? I'm using PuTTY v0.58 and SSH2.

acid_kewpie 05-30-2006 03:50 PM

ssh can run through an HTTP proxy ok, but your firewalls and such need to be configured to permit the destination outbound too. personally i've had good experiences running an ssh server on port 443 as this port has been unused as i don't server https and so you could get straight through that way. if your proxy will try to connect to port 22 directly then that's fine then.

Scotteh 05-30-2006 06:06 PM

Configuring the proxy is not an option because it is run by the school board. I'll try port 443.

joseph 05-30-2006 08:50 PM

Actually default port for ssh is 22, so if the admin of the server didn't change the port to other port, then your attemp to connect to port 443 will be meaningless.

Scotteh 05-30-2006 10:16 PM

Quote:

Actually default port for ssh is 22, so if the admin of the server didn't change the port to other port, then your attemp to connect to port 443 will be meaningless.
I'm not sure I know what you mean. You can specify which port to use in the PuTTY GUI, or I think at the command-line by doing
Code:

ssh hostname:port

joseph 05-30-2006 11:22 PM

Quote:

Originally Posted by Scotteh
I'm not sure I know what you mean. You can specify which port to use in the PuTTY GUI, or I think at the command-line by doing
Code:

ssh hostname:port

This is what i mean :
- default port for ssh is 22.

- if the sys admin didn't change the default port to other port such as 443 then a command like this ssh hostname:443 will be failed.

- if your sys admin never change the default port to other port and has blocked a connection to port 22 or only specified ip can access to port 22 then u cant do anything, unless you know how to hack to the system.

acid_kewpie 05-31-2006 01:00 AM

if the OP wants to ssh "home" to me that suggests that he is the server admin, in which case he can make ssh listen wherever he wants to. Additionally an ADSL router or such like that is already sitting here can be configured to portward external 443 requests to port 22 on the server inside. Mind you, this is only my suggestion when i had no success with any other attempts...

prozac 05-31-2006 01:13 AM

if your school firewall has a policy to drop input/output by default and only allow selective connections then you have a problem. the administrator there must have rules in place for only the packets he wants in/out and that too at certain ports. all other packets are dropped by default in such conditions.
now when you ssh home, you connect to a ssh server running on certain port and a certain ip. your administrator must add a rule to allow this. your other option would be to configure your ssh server at home to use a global port which the administrator at school dare not block. see if you can find out a port that has global access to outside world and then use that port to connect home. that way you would be using a outgoing/incoming connection for which there already is an accept rule in your school firewall.

Scotteh 05-31-2006 06:25 AM

Such as port 8080? How would I configure my ssh server at home to be able to do this?

prozac 05-31-2006 06:37 AM

find your /etc/ssh/sshd_config file and edit it to use port 8080 i guess ;)

acid_kewpie 05-31-2006 07:03 AM

well as above, if you have an ADSL router between your box and the net, then you'd do a port translation on the router and not touch the server tiself.


All times are GMT -5. The time now is 08:46 PM.