-   Linux - Networking (
-   -   trying to setup linux firewal/dhcp server but its not sharing the internet connection (

abefroman 04-30-2005 05:37 PM

trying to setup linux firewal/dhcp server but its not sharing the internet connection
I am trying to setup linux firewall/dhcp server but its not assign ips

Here is my server
Firewall/DHCP Server with 2 NICS
NIC 1 eth0: Cable from dsl router to nic1. Public IP from my dsl provider, this works ok and I can ping out
NIC 2 eth1: Cable From switch to nic2 Private IP, I can ping ok

Computer 1:
cable from switch to nic on computer.

I have dhcpd.conf set to us for ips and to use as the gateway.

Computer 1 is set to automatically assign an ip to itself, it picks
It can ping and it can ping the public IP, but it cannont ping

I tried changing the IP of eth1 on the server to and computer 1 can ping it put it can't ping the default gateway of

Should the IP of NIC1 on the server be or

I also tried:
route add -host dev eth1
but still couldnt ping out

Why arent I able to ping outsite the network(

Andrew Benton 04-30-2005 05:49 PM

What firewall/iptables rules have you set? You'll need to do NAT/Masquerading to get your gatway box to forward packets to the net.

abefroman 04-30-2005 07:07 PM

Thanks that worked, but it is not resolving domains,
It can't ping put it can ping

why wont it resolve domains names?

iptables are set to resolve DNS:
#Accept DNS, cause it's warm and friendly
iptables -A INPUT -p udp --source-port 53 -j ACCEPT
iptables -A INPUT -p udp --destination-port 53 -j ACCEPT

They firewall can resolve domains ok.

Got any tips?

abefroman 04-30-2005 07:18 PM

The actual error I get when tryiing to do an nslookup on computer1 is:
C:\Documents and Settings\Doug>nslookup
*** Can't find server name for address No response from server
*** Default servers are not available
Server: UnKnown

*** UnKnown can't find No response from server

C:\Documents and Settings\Doug>

Andrew Benton 05-01-2005 04:39 AM

Can you ping numerical addresses from computer1? What does it say in /etc/resolv.conf on computer1? it should look something like this
nameserver aaa.bbb.ccc.ddd

where aaa.bbb.ccc.ddd is the numerical address of your ISP's nameserver

Oh, hang on, that C:\Documents and Settings\ looks suspicious, you didn't say computer1 has gone over to the dark side. I don't know how to set it up on windows. It'll be on the control panel, in network connections?

All times are GMT -5. The time now is 12:25 AM.