-   Linux - Networking (
-   -   trying to setup linux as router for laptop (

spooge 08-31-2004 09:33 PM

trying to setup linux as router for laptop
i'm trying to get my wife's laptop up on the network(internet) with wlan.

currently i have a server, and 2 workstations on lan to linksys router.
(samba, named, bind9, nfs, mysql, blah blah blah).

i installed a wireless pci (xterasys)on one of my workstations(rh9 ) for testing,
before i set this up on my server( for obvious reasons), and a wireless
on her laptop( winxp for now).

i just want to get internet acces for the laptop, through the rh9 workstation,via wlan0.
i don't want to use dhcp as in another post i found here.

all i need is some direction in this matter, i do read, and search....
i figured this didn't need to be in wireless forum, seeing this could be done
the same with lan

some info:
laptop sees rh9 box, good signal

named started ( default config)

thanks !

bobwall 08-31-2004 10:04 PM

I think all you need to do is configure the client:

1. Start menu -> network connections

2. Goto the options dialog of the wireless card

3. Goto the properties dialog of TCP/IP networking

4. Manually enter your IP address and the ip address of the linux box
as your default gateway.

5. From a command prompt, execute ping to see if it works.

Actually, also make sure that ip forwarding is enabled on the linux box.
If not,
echo 1 > /proc/sys/net/ipv4/ip_forward

spooge 08-31-2004 10:29 PM

thanks bobwall,

no luck

i gonna do some serious reading. firewall/masq.
and wireless.

spooge 09-01-2004 10:00 PM

sep 1: 9:55pm
I can ping both machines!
after 12hrs at work work, every day, i'm gettin it.

looks like an iptable rule now. found a script to test
oops hopes thats ther right one, 2 nights of heavy drinkn

after 3 years of linux
havn't touch't iptables !
oh boy

with more threads like this..... i'll make it to guru status, and tell the newbs to go google/linux !


bobwall 09-01-2004 10:17 PM

Here's how I share my lousy dialup connection:

iptables -F
iptables -t mangle -F
iptables -t nat -F
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

(as always, make sure ip forwarding is on)

I know that its evil security wise, but hey, it works every time.

spooge 09-01-2004 10:37 PM

thanks bob

i got the laptop up on net!
but then with no firewall active on rh9 box

i'l try your advise

All times are GMT -5. The time now is 01:52 PM.