LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-30-2003, 01:18 PM   #1
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
trying to set up my linux box, two network cards.


Hello

I am trying to set up a my linux box (Computer 1) and my Desktop computer(Computer 2) so that my desktop is routed through my linux box.

I have two network cards in it. A D-link one (which uses the 8139too module and works fine) and a Real-tek one. Both of my computers are currently going through a central hub in my flat. I want to take the connection from my computer out of the hub and put it through my linux box and, subsequently, to the hub.

I just put the Real-Tek driver in today and I can't get it to be recognised. I do not have a monitor for the box so I am doing everything by SSH. I assumed that when I put the network card in, it would instantly be recognised, but it wasn't.

While looking at the kernel menuconfig window to find a driver for the Real-Tek card, I noticed that it was the same as the one used by the D-Link one (the one which works). Could it be that they won't work together as they both need the same module?

What I would like to know is:

How can I get the Real-Tek card to be recognised?
Could there be a problem with them both using the same module?

Thanks
Hamish
 
Old 10-30-2003, 01:52 PM   #2
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
You can get 2 cards to work using the same driver, what is required is an alias in your modules.conf file that points one card to eth0 and another to eth1.

Unfortunately, I couldn't give you the exact sytax of what you need to add to the file, but try searching around on google and on LQ and I bet you can find an example of a modules.conf file that uses aliases for multiple devices.

HTH.

slight
 
Old 10-30-2003, 02:14 PM   #3
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
I found a bit in my modules.conf saying:

# Aliases - specify your hardware
########################################################################

alias eth0 8139too
alias eth1 off
alias tr0 off
alias scsi_hostadapter off
alias fb0 off


I changed the "alias eth1 off" line to "alias eth1 8139too" and rebooted. HOwever, that didn't seem to do anything. Ifconfig still says that I only have one ethernet card.

thanks
hamish
 
Old 10-30-2003, 02:26 PM   #4
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
What does lspci show?
 
Old 10-30-2003, 03:17 PM   #5
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
lspci shows :

pi:~ # lspci
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset Graphics Controller] (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 02)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 02)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 02)
01:0b.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev 01)
01:0c.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
01:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

The Network Controller: Harris Semiconductor is my wireless lan card (which I also have to set up).

It seems that the computer knows that the controller is there.

I have added eth1 to ifconfig (with the same IP). Still doesn't work.

hamish
 
Old 10-30-2003, 03:50 PM   #6
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
Hmmmm.....

I have a handful of multi-homed machines here, one of which has two identical nics. I don't have any alias for eth0 or eth1, works fine.

How about looking in /var/log/messages, /var/log/syslog, etc. Also try 'dmesg | less' immediately after reboot. Look for anything interesting...

You can try loading the module with the argument debug=<n>. What n should be is anyones guess - my quick look at the driver says its a bitmask, so you might try 127 or 255 or 65535.
 
Old 10-30-2003, 03:54 PM   #7
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
You could also try modprobe 8139cp. Apears to be another driver that supports the 8139C, which is what the Realtek card is using.
 
Old 10-30-2003, 04:22 PM   #8
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
I looked at the boot in and it didn't have any mention of the NIC in quesiton. When I plug my network cable in, the green lights go on, so I imagine it is not broken.

I have found a reference to 8139 in the kernel menu, so I now have to recompile. (it wasn't able to be modularised).

It isn't actually a module, it seems, just some sort of support for the 8139 series. Do you reckon it is the right thing?

hamish
 
Old 10-30-2003, 08:39 PM   #9
JoAnywhere
Member
 
Registered: Oct 2003
Location: denver
Distribution: Debian
Posts: 97

Rep: Reputation: 15
Linux Flavour

What flavour of Linux are you using?

If its Redhat (or anything else using a SysV style of startup) you'll need to check in the /etc/sysconfig/network-scripts directory

currently you'll see that you if an ifcfg-eth0 file

you'll need to make a copy of this to ifcfg-eth1

edit ifcfg-eth1 so that it makes sense for your network card (things like DHCP, or static etc etc)

reboot (or probably just type
Code:
/etc/rc.d/init.d/network restart
) and see what happens

Regards
 
Old 10-31-2003, 08:31 AM   #10
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
I'm using SuSE 8.2 Pro.

I use RH on my other computer and I found the file on RH that you are talkinga bout.

However, I cna't find it in SuSE.

Do you know where it would be?

I grepped for ifcfg-eth0 in /etc/sysconfig on the SUSE machine, but that only returned two things, both at .sh files.

thanks
Hamish
 
Old 10-31-2003, 09:42 AM   #11
JoAnywhere
Member
 
Registered: Oct 2003
Location: denver
Distribution: Debian
Posts: 97

Rep: Reputation: 15
Does anyone know if Suse uses the SysV style startup stuff? Thats well beyond my level of expertise.

Cheers
Jo
 
Old 10-31-2003, 11:37 AM   #12
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
There are likely two RealTek support options in the kernel config menu: RTL-8139 and RTL-8139 C+. Enable them both and give it a try.

What version of the kernel are you running?
 
Old 10-31-2003, 07:37 PM   #13
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
running 2.4.22. I will recompile over the weekend. Do you think that enabling those two options will make it work?

I think they have to be compiled INTO the kernel and can't be done as modules.

Hamish
 
Old 11-01-2003, 10:58 AM   #14
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
They can be built as modules. If you can't set the module option, then maybe you did not enable module support for the kernel.

If you use 'make menuconfig' (which I find the easiest), it's the second option on the list 'Loadable module support --->'
 
Old 11-01-2003, 11:09 AM   #15
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
I have module support.

The RealTek RTL-8139 PCI Fast Ethernet Adapter support is already compiled as a module and that is the one I'm using for my current NIC.

I cannot, however, see the RTL-8139 C+ option. I assume it will be in the Network Device Support --> Ethernet (10 or 100mbit).

The only thing similar is: Support for uncommon RTL-8139 rev. K (automatic channel equalization). I can only build this into the kernel.

thanks
Hamish
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux box with 3 ethernet cards norus Linux - Networking 9 10-20-2005 08:06 PM
Having trouble setting up Linux box with two ethernet cards. GreenerLinux Linux - Networking 8 01-05-2005 03:20 PM
Wireless network cards, recognized out of the box fatrandy13 Linux - Wireless Networking 6 07-04-2004 12:21 AM
strange behavior with 2 ethernet cards in my linux box newnew Linux - Networking 3 03-19-2004 08:33 PM
Can I turn my box into a "Hub" with 2 network Cards?? Atmosphere Linux - Networking 2 10-21-2003 10:03 PM


All times are GMT -5. The time now is 11:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration