LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-14-2008, 08:58 PM   #1
crutch52
LQ Newbie
 
Registered: Mar 2008
Posts: 9

Rep: Reputation: 0
Trying to connect to telstra bigpond next G


Hi, I've been trying to connect to to a wireless internet sevice using a sierra airprime 880U card on Arch linux. the card seems to be recognised OK but any attempt to connect ends with the modem hanging up.

I'm trying to use wvdial but have not had any more luck with pppd or kppp. My config file for wvdial is

[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Phone = *99#1
ISDN = 0
Username = ***********
Init1 = ATZ
Password = *******
Modem = /dev/ttyUSB0
Baud = 9600

(note i've removed my username and password for this)

Initially when I start my computer I have problems with the ppp daemon
(This could well be the source of my problem but I don't really understand this) this is best illustrated using pppd

[bruce@crutch etc]$ sudo pppd call gsm
Password:
pppd: pppd is unable to open the /dev/ppp device.
You need to create the /dev/ppp device node by
executing the following command as root:
mknod /dev/ppp c 108 0

Running this command seems to help but I still get the modem hanging up

[bruce@crutch etc]$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99#1
--> Waiting for carrier.
CONNECT 7200000
--> Carrier detected. Waiting for prompt.
--> Don't know what to do! Starting pppd and hoping for the best.
--> Starting pppd at Sat Mar 15 10:52:58 2008
--> Pid of pppd: 6616
--> Using interface ppp0
--> pppd: ��[06][08]p�[06][08]
--> pppd: ��[06][08]p�[06][08]
--> pppd: ��[06][08]p�[06][08]
--> pppd: ��[06][08]p�[06][08]
--> pppd: ��[06][08]p�[06][08]
--> pppd: ��[06][08]p�[06][08]
--> Disconnecting at Sat Mar 15 10:52:59 2008
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99#1
--> Waiting for carrier.
CONNECT 7200000
--> Carrier detected. Waiting for prompt.

And this carries on untill I abort the process.

Can someone please explain some of this?
 
Old 03-14-2008, 08:59 PM   #2
crutch52
LQ Newbie
 
Registered: Mar 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Note that I would usually use the number *99# rather than *99#1
 
Old 09-01-2009, 12:34 PM   #3
jsbjsb001
LQ Newbie
 
Registered: Mar 2009
Location: South Australia, Australia
Distribution: OpenSUSE 11.0
Posts: 13

Rep: Reputation: 0
Smile

I also have a Telstra wireless modem (sierra aircard) and have written some guides on how to get it working.

Here's the link: http://en.opensuse.org/Using_Your_Te...Wireless_Modem

Hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bigpond Video wayno Linux - Desktop 2 07-09-2007 11:11 PM
Telstra Bigpond ISDN NT1 Plus 2 in Mandrake 10 Appleman1234 Linux - Networking 0 08-18-2004 10:16 PM
Bigpond cable Bull Terrier Slackware 1 03-06-2004 12:27 PM
Anyone using Telstra BPA with Smoothwall 1.0?? GKFC Linux - Networking 2 02-14-2003 07:49 PM
Telstra cable and Mandrake 9.0 kde3 Muddy001 Linux - Networking 0 10-17-2002 09:16 AM


All times are GMT -5. The time now is 06:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration