LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-24-2005, 02:52 AM   #1
opsraja
Member
 
Registered: Sep 2004
Posts: 37

Rep: Reputation: 15
Troubleshooting DNS


I have a Redhat server hosting several sites and one or two of the sites are not pulling up by name (host could not be found), only by ip address;

here is what i tried so far:

checked httpd.conf (i know this wasn't necessary but hey u never know)
went to /etc/rc.d and checked the ips file for ip address (it is listed)

ran ./bind.pl, tried binding and unbinding the ip address, but to no avail.

the zone file is fine as well.

I did a whois on the website, that worked out fine as well.

Is there anything else that I missed that would prevent a website from coming up by name?
 
Old 02-24-2005, 03:29 AM   #2
linuxxed
Member
 
Registered: Feb 2004
Posts: 273

Rep: Reputation: 30
Is the name server properly registered for your domain? If not then you need to correct it through your registrar.

Here's some info that you can use to debug.

Pick a machine connected to the internet away from your server (not on the same net)


nslookup
>set type=ns
>yourdomain.com

This should give your the nameserver that you've registered for that domain. If incorrect then you would need to change that.

>set type=A
>your domain.com

This will give you the IP address(es) that this domain will resolve to.



What happens when you type "nslookup www.yourdomain.com"? If yu're trying from the server then check your /etc/resolv.conf.



Changes to registry take 24-48 hrs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
troubleshooting how-to? chilehead Linux - Hardware 2 02-06-2005 04:58 PM
Sound troubleshooting in 10.1 matsgl Mandriva 12 12-18-2004 01:36 PM
Postfix troubleshooting davee Linux - Networking 0 09-03-2003 07:10 AM
Installation Troubleshooting Lucifa Linux - General 5 06-15-2002 11:04 PM
troubleshooting smoothwall Barry Linux - Networking 1 11-30-2001 06:15 AM


All times are GMT -5. The time now is 10:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration