LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-12-2003, 02:49 PM   #1
paulbell
LQ Newbie
 
Registered: Sep 2003
Distribution: Red Hat
Posts: 2

Rep: Reputation: 0
trouble with 3Com NIC in RH 7.0


Hey eveyrone,
Boss told me to install RH7.0 on a new box for reason even I dont understand. It is a Asus A7V mbrd with DDR333 RAM, and IDE hdd. I had a new D-Link NIC in there, but coudlnt get it to come up, tried an old SMC NIC, coudl get it to come up, now I have 3COM 3C905-TX that i was told was well supported in old RH versions.

ifconfig gives me the loopback but not eth0. netconfig thinks it installs everything, but it still does not give me eth0 in ifconfig.
lsmod gives me:
Module Size Used by
lockd
sunrpc
usb-uhci
usbcore

service network restart gives me:
Setting network parms: OK
Bringin up lo: OK
Bringing up etho: Delaying etho initialization [FAILED]

so ya htis sucks.......RH 7.3 worked fine with all teh compnents.....but I cant do what i need to do in 7.3....has to be 7.0.

Any help would be greatly appreciated!
 
Old 09-12-2003, 04:23 PM   #2
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Rep: Reputation: 30
Whats the output of thse commands:

lspci -v
scanpci -v
dmesg
cat /lib/modules/`uname -r`/kernel/drivers/net


--tarballedtux
 
Old 09-12-2003, 04:47 PM   #3
paulbell
LQ Newbie
 
Registered: Sep 2003
Distribution: Red Hat
Posts: 2

Original Poster
Rep: Reputation: 0
This last cat /lib/modules....didnt work, i am running 2.2.16-22 kernel.

Output from lspci -v:
00:00.0 Host bridge: VIA Technologies, Inc.: Unknown device 0305 (rev 02)
Subsystem: Asustek Computer, Inc.: Unknown device 8033
Flags: bus master, medium devsel, latency 0
Memory at e4000000 (32-bit, prefetchable)
Capabilities: [a0] AGP version 2.0
Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc.: Unknown device 8305 (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: e1800000-e3dfffff
Prefetchable memory behind bridge: e3f00000-e3ffffff
Capabilities: [80] Power Management version 2

00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super] (rev 22)
Subsystem: Asustek Computer, Inc.: Unknown device 8033
Flags: bus master, stepping, medium devsel, latency 0

00:04.1 IDE interface: VIA Technologies, Inc. VT82C586 IDE [Apollo] (rev 10) (prog-if 8a [Master SecP PriP])
Flags: bus master, medium devsel, latency 32
I/O ports at b800
Capabilities: [c0] Power Management version 2

00:04.2 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 10) (prog-if 00 [UHCI])
Subsystem: Unknown device 0925:1234
Flags: bus master, medium devsel, latency 32, IRQ 10
I/O ports at b400
Capabilities: [80] Power Management version 2

00:04.3 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 10) (prog-if 00 [UHCI])
Subsystem: Unknown device 0925:1234
Flags: bus master, medium devsel, latency 32, IRQ 10
I/O ports at b000
Capabilities: [80] Power Management version 2

00:04.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
Flags: medium devsel
Capabilities: [68] Power Management version 2

00:09.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
Flags: bus master, medium devsel, latency 32
I/O ports at 9400

00:11.0 Unknown mass storage controller: Promise Technology, Inc.: Unknown device 0d30 (rev 02)
Subsystem: Promise Technology, Inc.: Unknown device 4d33
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at 9000
I/O ports at 8800
I/O ports at 8400
I/O ports at 8000
I/O ports at 7800
Memory at e1000000 (32-bit, non-prefetchable)
Capabilities: [58] Power Management version 1

01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c) (prog-if 00 [VGA])
Subsystem: ATI Technologies Inc: Unknown device 0084
Flags: bus master, stepping, medium devsel, latency 64
Memory at e2000000 (32-bit, non-prefetchable)
I/O ports at d800
Memory at e1800000 (32-bit, non-prefetchable)
Expansion ROM at e3fe0000 [disabled]
Capabilities: [50] AGP version 1.0

From scanpci -v:
pci bus 0x0 cardnum 0x00 function 0x0000: vendor 0x1106 device 0x0305
VIA Device unknown
CardVendor 0x1043 card 0x8033 (Card unknown)
STATUS 0x2210 COMMAND 0x0006
CLASS 0x06 0x00 0x00 REVISION 0x02

pci bus 0x0 cardnum 0x01 function 0x0000: vendor 0x1106 device 0x8305
VIA Device unknown
STATUS 0x2230 COMMAND 0x0007
CLASS 0x06 0x04 0x00 REVISION 0x00
HEADER 0x01 LATENCY 0x00
PRIBUS 0x00 SECBUS 0x01 SUBBUS 0x01 SECLT 0x00
IOBASE 0xd000 IOLIM 0xdfff SECSTATUS 0x0000
NOPREFETCH_MEMBASE 0xe1800000 MEMLIM 0xe3dfffff
PREFETCH_MEMBASE 0xe3f00000 MEMLIM 0xe3ffffff
NO_FAST_B2B NO_SEC_BUS_RST NO_M_ABRT VGA_EN NO_ISA_EN NO_PERR_EN

pci bus 0x0 cardnum 0x04 function 0x0000: vendor 0x1106 device 0x0686
VIA VT 82C686 MVP4 ISA Bridge
CardVendor 0x1043 card 0x8033 (Card unknown)
STATUS 0x0210 COMMAND 0x0087
CLASS 0x06 0x01 0x00 REVISION 0x22
HEADER 0x80 LATENCY 0x00

pci bus 0x0 cardnum 0x04 function 0x0001: vendor 0x1106 device 0x0571
VIA VT 82C586 MVP3 IDE Bridge
STATUS 0x0290 COMMAND 0x0007
CLASS 0x01 0x01 0x8a REVISION 0x10
BIST 0x00 HEADER 0x00 LATENCY 0x20 CACHE 0x00
BASE4 0x0000b801 addr 0x0000b800 I/O
MAX_LAT 0x00 MIN_GNT 0x00 INT_PIN 0x00 INT_LINE 0xff
BYTE_0 0x3a02c203 BYTE_1 0x00 BYTE_2 0x806ac20 BYTE_3 0xffffffff

pci bus 0x0 cardnum 0x04 function 0x0002: vendor 0x1106 device 0x3038
VIA VT 82C586 MVP3 USB Controller
CardVendor 0x0925 card 0x1234 (Card unknown)
STATUS 0x0210 COMMAND 0x0017
CLASS 0x0c 0x03 0x00 REVISION 0x10
BIST 0x00 HEADER 0x00 LATENCY 0x20 CACHE 0x08
BASE4 0x0000b401 addr 0x0000b400 I/O
MAX_LAT 0x00 MIN_GNT 0x00 INT_PIN 0x04 INT_LINE 0x0a
BYTE_0 0x31200 BYTE_1 0x00 BYTE_2 0x806af98 BYTE_3 0xffffffff

pci bus 0x0 cardnum 0x04 function 0x0003: vendor 0x1106 device 0x3038
VIA VT 82C586 MVP3 USB Controller
CardVendor 0x0925 card 0x1234 (Card unknown)
STATUS 0x0210 COMMAND 0x0017
CLASS 0x0c 0x03 0x00 REVISION 0x10
BIST 0x00 HEADER 0x00 LATENCY 0x20 CACHE 0x08
BASE4 0x0000b001 addr 0x0000b000 I/O
MAX_LAT 0x00 MIN_GNT 0x00 INT_PIN 0x04 INT_LINE 0x0a
BYTE_0 0x31200 BYTE_1 0x00 BYTE_2 0x806b310 BYTE_3 0xffffffff

pci bus 0x0 cardnum 0x04 function 0x0004: vendor 0x1106 device 0x3057
VIA VT 8501 MVP4 ACPI Bridge
STATUS 0x0290 COMMAND 0x0000
CLASS 0x06 0x00 0x00 REVISION 0x30

pci bus 0x0 cardnum 0x09 function 0x0000: vendor 0x10b7 device 0x9050
3COM 3C905 100bTX
STATUS 0x0200 COMMAND 0x0005
CLASS 0x02 0x00 0x00 REVISION 0x00
BIST 0x00 HEADER 0x00 LATENCY 0x20 CACHE 0x00
BASE0 0x00009401 addr 0x00009400 I/O
MAX_LAT 0x08 MIN_GNT 0x03 INT_PIN 0x01 INT_LINE 0xff
BYTE_0 0x16302d8 BYTE_1 0x00 BYTE_2 0x806ba00 BYTE_3 0xffffffff

pci bus 0x0 cardnum 0x11 function 0x0000: vendor 0x105a device 0x0d30
Device unknown
CardVendor 0x105a card 0x4d33 (Card unknown)
STATUS 0x0210 COMMAND 0x0007
CLASS 0x01 0x80 0x00 REVISION 0x02
BIST 0x00 HEADER 0x00 LATENCY 0x20 CACHE 0x00
BASE0 0x00009001 addr 0x00009000 I/O
BASE1 0x00008801 addr 0x00008800 I/O
BASE2 0x00008401 addr 0x00008400 I/O
BASE3 0x00008001 addr 0x00008000 I/O
BASE4 0x00007801 addr 0x00007800 I/O
BASE5 0xe1000000 addr 0xe1000000 MEM
MAX_LAT 0x00 MIN_GNT 0x00 INT_PIN 0x01 INT_LINE 0x0b

pci bus 0x1 cardnum 0x00 function 0x0000: vendor 0x1002 device 0x4742
ATI Mach64 GB
CardVendor 0x1002 card 0x0084
STATUS 0x0290 COMMAND 0x0087
CLASS 0x03 0x00 0x00 REVISION 0x5c
BIST 0x00 HEADER 0x00 LATENCY 0x40 CACHE 0x08
APBASE 0xe2000000 addr 0xe2000000
BLOCKIO 0x0000d801 addr 0x0000d800
REGBASE 0xe1800000 addr 0xe1800000
BASEROM 0xe3fe0000 addr 0xe3fe0000 not-decode-enabled
MAX_LAT 0x00 MIN_GNT 0x08 INT_PIN 0x00 INT_LINE 0xff
SPARSEIO 0x2ec Block IO enabled Disable 0x46E8

from dmesg:
Linux version 2.2.16-22 (root@porky.devel.redhat.com) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Tue Aug 22 16:49:06 EDT 2000
Detected 1210801 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 2418.28 BogoMIPS
Memory: 517024k/524160k available (1048k kernel code, 412k reserved, 5612k data, 64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 524288 (order 9, 2048k)
Page cache hash table entries: 131072 (order 7, 512k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: L1 I Cache: 64K L1 D Cache: 64K
CPU: L2 Cache: 256K
CPU: AMD AMD Athlon(tm) Processor stepping 02
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xf10f0
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Enabling I/O for device 00:48
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 524288 bhash 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing RT netlink socket
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.13)
Real Time Clock Driver v1.09
RAM disk driver initialized: 16 RAM disks of 4096K size
VP_IDE: IDE controller on PCI bus 00 dev 21
VP_IDE: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdcMA, hddio
hda: IBM-DTLA-307030, ATA DISK drive
hdc: AOpen Inc. DVD-ROM DVD-1640 PRO 0113, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: IBM-DTLA-307030, 29314MB w/1916kB Cache, CHS=3737/255/63
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
pII_mmx : 2807.589 MB/sec
p5_mmx : 3230.880 MB/sec
8regs : 1842.135 MB/sec
32regs : 1327.404 MB/sec
using fastest function: p5_mmx (3230.880 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
hda: hda1 hda3
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
Adding Swap: 1044216k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.232 $ time 16:53:56 Aug 22 2000
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xb400, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
usb.c: USB new device connect, assigned device number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xb000, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
usb.c: USB new device connect, assigned device number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: USB new device connect, assigned device number 2
hub.c: USB hub found
hub.c: 4 ports detected
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 2
usb.c: USB new device connect, assigned device number 2
hub.c: USB hub found
hub.c: 4 ports detected
3c59x.c:v0.99H 01Aug00 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
eth0: 3Com 3c905 Boomerang 100baseTx at 0x9400, 00:60:97:dc:6e:39, IRQ 0
*** Warning: IRQ 0 is unlikely to work! ***
8K word-wide RAM 3:5 Rx:Tx split, autoselect/MII interface.
MII transceiver found at address 24, status 786f.
Enabling bus-master transmits and whole-frame receives.


Hope all this crap helps....i have been working on it, now running ifconfig eth0 shows me the stuff for eth0, but no transmissions are sent or received.....and when i do ifconfig eth0 up, i get: SIOCSIFFLAGS: Resource temporarily unavailible....if i hit ifconfig eth0 192.168.100.80 up, i get the same msg as above, but twice, and then the system crashes.....

Thanks in advance for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 NIC Card Not Working! 3com 3c501 NIC. Mustard010 Linux - Networking 16 08-15-2007 03:22 AM
3Com Nic Issue BittaBrotha Fedora 2 07-26-2005 06:57 AM
3Com Nic Not Connected BittaBrotha Fedora 6 11-07-2003 06:06 PM
3Com Wireless NIC Jay53 Linux - Wireless Networking 19 04-25-2002 10:57 AM
Mandrake 8 w/3com NIC hbmcda Linux - Networking 3 08-17-2001 09:52 AM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration