LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-05-2003, 07:13 PM   #1
eww
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Rep: Reputation: 0
Trouble getting an IP address with DHCP Dec 12140 Nic. Works in Windows


Hi,

I have a network card with a Dec 12140 chipset. I am running Fedora 1. I have tried running on this computer SuSE and redhat 7 and the same thing happens. When the computer boots up it will not get an IP address. How ever, if I unplug the network cable and plug it back it back in and try to bring the nic up, it works instantly. Other wise DHCP just times out. I can try bringing up the nic repeatadly but it won't work until I unplug the network cable and plug it back in. This same computer has no trouble picking up an IP from windows 98SE(dual boot) or W2K. The other computers on my lan running Win98SE and Mac OS don't have any issues.

The DHCP server is runing on my SuSE linux box. It has an IP of 192.168.0.1. This box is my router/gateway. It connects to a DSL modem and I have NAT on it too. Here is my dhcpd.conf
max-lease-time 14400;
default-lease-time 7200;
option domain-name-servers 209.115.152.150, 209.115.152.130;
option routers 192.168.0.1;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
#option domain-name "local";
ddns-update-style none;

subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.100 192.168.0.200;
}

All 4 computers are connected with a dlink dss-8+ switch

Here is a TCP dump from my box when it doesn't work:
16:24:56.849312 > 0:60:67:36:21:4f 344:
16:25:03.007887 > 0:60:67:36:21:4f 344:
16:25:22.007942 > 0:60:67:36:21:4f 344:
16:25:30.007886 > 0:60:67:36:21:4f 344:
16:25:44.007961 > 0:60:67:36:21:4f 344:
16:25:58.007889 > 0:60:67:36:21:4f 344:
16:26:10.007887 > 0:60:67:36:21:4f 344:
16:26:21.007887 > 0:60:67:36:21:4f 344:
16:26:23.092709 arp who-has 192.168.0.1 tell 192.168.0.195
16:26:24.087653 arp who-has 192.168.0.1 tell 192.168.0.195
16:26:25.087655 arp who-has 192.168.0.1 tell 192.168.0.195
16:26:26.087685 192.168.0.195 > 192.168.0.195: icmp: host 192.168.0.1 unreachable [tos 0xc0]
16:26:26.087709 192.168.0.195 > 192.168.0.195: icmp: host 192.168.0.1 unreachable [tos 0xc0]
16:26:26.087718 192.168.0.195 > 192.168.0.195: icmp: host 192.168.0.1 unreachable [tos 0xc0]

Here is when it works:
16:08:27.007447 > 0:60:67:36:21:4f 344:
16:08:27.010580 192.168.0.1.bootps > 192.168.0.195.bootpc: udp 300 [tos 0x10]

Any idea's?

Thanks,

Eric Wiens
 
Old 12-05-2003, 07:38 PM   #2
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
is your client configured to refuse arp packets?
I'm not sure but give this a try (only temporary: unsafe):
ALL: 192.168.0.1
in your /etc/hosts.allow
(and shut down any active firewall on the client)
 
Old 12-05-2003, 07:58 PM   #3
eww
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Just tried editing the hosts.allow. Didn't work. I am behind a firewall so I am not worried about my system being compromised.

I made sure not to install the firewall when I installed Fedora.

I have tried 2 versions of Red hat and one of SuSE and both did the same thing.

My switch shows 100/full duplex and virutally no activity when DHCP request is going on.

It's wierd that unplugging the network cable and pluging it back in would cause it to work. Could it be something with the switch? or a setting that get's reset on the nic? It's wierd!
 
Old 12-05-2003, 08:18 PM   #4
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
I have a nic card that only worked after a cold startup, i.e. not rebooting from win9x, due to missing reset, but that's an old bios on a crappy hardware. In this case your nic card actually works:
16:26:24.087653 arp who-has 192.168.0.1 tell 192.168.0.195
but your pc seems to be expecting a different answer.

Note that when you plug in and it works, it's not via dhcp, but via bootp!
I never used dhcp. Try searching your dhcp server manpage for different answering protocols. Sorry, i can't be of any more help

Last edited by ac1980; 12-05-2003 at 08:20 PM.
 
Old 12-05-2003, 09:11 PM   #5
rgheck
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora Core 3
Posts: 29

Rep: Reputation: 15
is the card itself properly configured at boot? it looks like you're just not reaching the network at all, and unplugging is causing some kind of reset. maybe you should try a different nic and see if that has any effect. (you can get 'em free with a rebate....)
 
Old 12-06-2003, 12:24 AM   #6
eww
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Maybe your right. I should just pick up another nic. Though I won't learn anything

Just tried something else. I unpluged my network cable from my PC while the BIOS booted up. When I got to grub I plugged the cable back into the nic. The problem was still there. I think there might be some setting in linux then that is causing this problem.

Does this help?
Dec 5 18:59:32 localhost kernel: Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
Dec 5 18:59:32 localhost kernel: PCI: Found IRQ 4 for device 00:0d.0
Dec 5 18:59:32 localhost kernel: PCI: Sharing IRQ 4 with 00:04.2
Dec 5 18:59:33 localhost kernel: PCI: Sharing IRQ 4 with 00:04.3
Dec 5 18:59:33 localhost kernel: PCI: Sharing IRQ 4 with 00:09.0
Dec 5 18:59:33 localhost kernel: tulip0: EEPROM default media type Autosense.
Dec 5 18:59:33 localhost kernel: tulip0: Index #0 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
Dec 5 18:59:33 localhost kernel: tulip0: Index #1 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
Dec 5 18:59:33 localhost kernel: tulip0: Index #2 - Media 10baseT-FDX (#4) described by a 21140 non-MII (0) block.
Dec 5 18:59:33 localhost kernel: tulip0: Index #3 - Media 100baseTx-FDX (#5) described by a 21140 non-MII (0) block.
Dec 5 18:59:33 localhost kernel: tulip0: MII transceiver #1 config 3100 status 782d advertising 05e1.
Dec 5 18:59:33 localhost kernel: eth0: Digital DS21140 Tulip rev 34 at 0xc8903000, 00:60:67:36:21:4F, IRQ 4.
Dec 5 18:59:33 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Dec 5 18:59:33 localhost kernel: Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
Dec 5 18:59:33 localhost kernel: PCI: Found IRQ 4 for device 00:0d.0
 
Old 12-06-2003, 01:12 AM   #7
eww
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for all the help... I got it to work. I don't understand why though. That's the next part. It found an IP as fast as you can say swiss cheese!

I went and added to my modules.conf
options tulip options=4

I saw some people mentioning problems with full duplex ect... so I thought I would try to change it. http://www.scyld.com/network/tulip.html says:
debug int The debug message level, 0 (no messages) to 31 (all messages).
options int[] The media type override and card operation settings (See list below.)
full_duplex int[] Force full duplex (obsolete -- for backwards compatibility with existing installations only).
max_interrupt_work int Maximum number of events to handle at each interrupt, default 25.
multicast_filter_limit int Breakpoint for switching to Rx-all-multicast mode, default 32 multicast addresses.
rx_copybreak int See driver source for tuning details.
csr0 int PCI Bus Performance register. See driver source for tuning details.

Here's what the driver pages says for options:
index media
0 Auto-select (default to the 10baseT link)
1 10base2
2 AUI
3 100baseTx
4 10baseT-FD
5 100baseTx-FD
6 100baseT4
7 100baseFx
8 100baseFx-FD
9 MII 10baseT
10 MII 10baseT-FD
11 MII (autoselect)
12 Serial 10baseT (no autoselect)
13 MII 100baseTx
14 MII 100baseTx-FD
15 MII 100baseT4
16 MII 100baseFx-HDX (half duplex)
17 MII 100baseFx-FDX (full duplex)
18 MII Home-PNA 1Mbps

I also found that i could probe a module for options buy doing an /sbin/modinfo tulip that
filename: /lib/modules/2.4.22-1.2115.nptl/kernel/drivers/net/tulip/tulip.o
description: "Digital 21*4* Tulip ethernet driver"
author: "The Linux Kernel Team"
license: "GPL"
parm: tulip_debug int
parm: max_interrupt_work int
parm: rx_copybreak int
parm: csr0 int
parm: options int array (min = 1, max = 8)
parm: full_duplex int array (min = 1, max = 8)

and here's what my syslogs say on boot now:
Dec 6 00:01:33 localhost kernel: Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
Dec 6 00:01:33 localhost kernel: PCI: Found IRQ 4 for device 00:0d.0
Dec 6 00:01:33 localhost kernel: PCI: Sharing IRQ 4 with 00:04.2
Dec 6 00:01:33 localhost kernel: PCI: Sharing IRQ 4 with 00:04.3
Dec 6 00:01:33 localhost kernel: PCI: Sharing IRQ 4 with 00:09.0
Dec 6 00:01:33 localhost kernel: tulip0: Transceiver selection forced to 10baseT-FDX.
Dec 6 00:01:33 localhost kernel: tulip0: EEPROM default media type Autosense.
Dec 6 00:01:33 localhost kernel: tulip0: Index #0 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: Index #1 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: Index #2 - Media 10baseT-FDX (#4) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: Index #3 - Media 100baseTx-FDX (#5) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: MII transceiver #1 config 3100 status 782d advertising 05e1.
Dec 6 00:01:33 localhost kernel: eth0: Digital DS21140 Tulip rev 34 at 0xc8903000, 00:60:67:36:21:4F, IRQ 4.
Dec 6 00:01:33 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Dec 6 00:01:33 localhost kernel: Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
Dec 6 00:01:33 localhost kernel: PCI: Found IRQ 4 for device 00:0d.0
Dec 6 00:01:33 localhost kernel: PCI: Sharing IRQ 4 with 00:04.2
Dec 6 00:01:33 localhost kernel: PCI: Sharing IRQ 4 with 00:04.3
Dec 6 00:01:33 localhost kernel: PCI: Sharing IRQ 4 with 00:09.0
Dec 6 00:01:33 localhost kernel: tulip0: Transceiver selection forced to 10baseT-FDX.
Dec 6 00:01:33 localhost kernel: tulip0: EEPROM default media type Autosense.
Dec 6 00:01:33 localhost kernel: tulip0: Index #0 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: Index #1 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: Index #2 - Media 10baseT-FDX (#4) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: Index #3 - Media 100baseTx-FDX (#5) described by a 21140 non-MII (0) block.
Dec 6 00:01:33 localhost kernel: tulip0: MII transceiver #1 config 0100 status 7809 advertising 05e1.
Dec 6 00:01:33 localhost kernel: eth0: Digital DS21140 Tulip rev 34 at 0xc8903000, 00:60:67:36:21:4F, IRQ 4.
Dec 6 00:01:33 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Dec 6 00:01:33 localhost kernel: eth0: Using user-specified media 10baseT-FDX.

Anyhow it works. I now know what to do. Though it's sure a pain to figure out. I am comfortable searching the net and editing this and that file but a newbie would be screwed. Heck I have been fighting this problem on/off for two years now. When ever I would try linux I would just live with it. Now I just might keep it on my machine!

Thanks for the help. You have been helpfull. You offered support which helped keep me going to find a resolution to this issue.

Should I report this to anyone so I don't have to keep mudlling with it every time I install a new distro?
 
Old 12-06-2003, 07:18 PM   #8
vincebs
Member
 
Registered: Oct 2003
Location: Mississauga, ON
Distribution: Ubuntu 9.04
Posts: 494

Rep: Reputation: 30
^^ I'm a newbie and I'm screwed. Could anyone explain how to fix this problem in general terms? I have an SMC 1660T network card and I'm running Suse 9. Everytime it queries the DNS server for an IP address, it times out. What do I do?
 
Old 12-07-2003, 12:48 AM   #9
eww
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Original Poster
Rep: Reputation: 0
I need more information than that. What can you give me? Does your nic pick up an ip address? Can you ping other computers?
 
Old 12-07-2003, 03:49 AM   #10
vincebs
Member
 
Registered: Oct 2003
Location: Mississauga, ON
Distribution: Ubuntu 9.04
Posts: 494

Rep: Reputation: 30
Quote:
Originally posted by eww
I need more information than that. What can you give me? Does your nic pick up an ip address? Can you ping other computers?
No, it doesn't pick up anything. I can't ping anything either.
 
Old 12-07-2003, 07:30 AM   #11
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
R U on a large network or home net?
In the latter case, the simplest way to check if your hardware is ok is to give a try with a static ip (different from server's ip, of course). Backup your /etc/network/interfaces first!
if you're on a large net, check if the corresponding light in the hub you're connected to is on.
 
Old 12-07-2003, 05:48 PM   #12
eww
LQ Newbie
 
Registered: Dec 2003
Posts: 8

Original Poster
Rep: Reputation: 0
vincebs

Ok... What happens when you type "ifconfig" in a terminal? You probably have to be logged in as root or else us "/sbin/ifconfig" to run it.

It should print out something like this:
eth0 Link encap:Ethernet HWaddr 00:60:67:36:21:4F
inet addr:192.168.0.195 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5697 errors:0 dropped:0 overruns:0 frame:0
TX packets:5761 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4649511 (4.4 Mb) TX bytes:826432 (807.0 Kb)
Interrupt:4 Base address:0x3000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1849 errors:0 dropped:0 overruns:0 frame:0
TX packets:1849 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1706827 (1.6 Mb) TX bytes:1706827 (1.6 Mb)

If you just have lo then your not getting an IP address from a DHCP server due to a problem. If you have eth0 then you are getting an IP from a DHCP server. During the install I hope you choose to get an IP from a DHCP server. If you set it manually then it won't work. I am assuming you don't get eth0. If that is the case we have to figure out what is wrong.

Check your syslogs and find out if you nic is being detected. I don't know how to do this in SUSE. But the file to open is /var/log/messages. In fedora there is a utility that lets you view them. You should see something like this:

Dec 7 11:53:01 localhost kernel: Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
Dec 7 11:53:02 localhost kernel: PCI: Found IRQ 4 for device 00:0d.0
Dec 7 11:53:02 localhost kernel: PCI: Sharing IRQ 4 with 00:04.2
Dec 7 11:53:02 localhost kernel: PCI: Sharing IRQ 4 with 00:04.3
Dec 7 11:53:02 localhost kernel: PCI: Sharing IRQ 4 with 00:09.0
Dec 7 11:53:02 localhost kernel: tulip0: EEPROM default media type Autosense.
Dec 7 11:53:02 localhost kernel: tulip0: Index #0 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
Dec 7 11:53:02 localhost kernel: tulip0: Index #1 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
Dec 7 11:53:02 localhost kernel: tulip0: Index #2 - Media 10baseT-FDX (#4) described by a 21140 non-MII (0) block.
Dec 7 11:53:02 localhost kernel: tulip0: Index #3 - Media 100baseTx-FDX (#5) described by a 21140 non-MII (0) block.
Dec 7 11:53:02 localhost kernel: tulip0: MII transceiver #1 config 1000 status 782d advertising 05e1.
Dec 7 11:53:02 localhost kernel: eth0: Digital DS21140 Tulip rev 34 at 0xd0903000, 00:60:67:36:21:4F, IRQ 4.

This is your network card detection by linux. If you don't see this then you have a problem. I believe it should say something about NE2000? If not read this red hat support email:

https://listman.redhat.com/archives/.../msg00231.html

So enough for you to figure out. Let me know what you find.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux dhcp client can't get address on Windows network km4hr Linux - Networking 12 03-10-2005 08:35 PM
DHCP only works after previous boot in Windows amosml Linux - Networking 4 12-31-2004 05:59 AM
Static address works but DHCP doesn't... devahl Linux - Networking 1 05-03-2004 04:55 PM
Trouble with NIC card DEC 21040 on redhat 7.3 rockrules Linux - Hardware 0 03-25-2004 03:41 PM
DHCP works / Trouble w/manual network configuration. 360 Linux - Networking 2 08-28-2001 05:13 AM


All times are GMT -5. The time now is 10:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration