LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-11-2006, 05:30 PM   #1
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Rep: Reputation: 30
transfers between LAN machines is slow - I've got ethereal output!


I'm a linux junkie, but not really good with networking. This problem has been killing me for MONTHS. I try to transfer a file between two linuxes boxes on my lan. I use NFS, Samba, FTP, you name it. I can't get more the 500KB/s. That's getting or putting. I've tried wired and wireless. What finally knocked me for a loop was when I booted into Windows XP under Vmware, and tried to transfer a file via Samba to the other linux box. I got 5MB/sec of blistering speed! That file was done in SECONDS! So, I'm figuring that the problem is how the linux boxes are talking to each other.

So, I got off my rear end and installed ethereal. The text file for the transfer (a few seconds of it) is below. I see a ton of TCP out-of-orders and retransmissions. Again, I'm not a network expert, but I think this may be the problem.

I've heard full and half duplex tossed around here in relation to problems similar to this. How do I force full duplex on a wifi card? Ethtool won't work on it.

Thanks for any and all help on this!

********Wow, that ethereal file is 83MB. I can't even open it. Notable quotes in black and yellow are:

[TCP Out-of-Order]
[TCP Retransmission]

Over and over again, every few lines. Is that enough info?

--Akshun J
 
Old 09-11-2006, 05:49 PM   #2
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 187
Blog Entries: 1

Rep: Reputation: 38
check out your nic multi is on: ifconfig
check your host.conf multi on
Recompile your kernel and check out Network Options TCP/IP multicasting
 
Old 09-11-2006, 07:12 PM   #3
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Original Poster
Rep: Reputation: 30
Hmmm, multicast seems to be enabled in hosts.conf, as well as in ifconfig:

Link encap:Ethernet HWaddr 000:B7:54:3F:CB
inet addr:192.168.0.7 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2626 errors:0 dropped:0 overruns:0 frame:0
TX packets:2113 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3073242 (2.9 MiB) TX bytes:257335 (251.3 KiB)
Interrupt:11

So why would I be recompiling my kernel? I'm not sure I understand where you're going. Thanks for the reply, though...

--Akshun J
 
Old 09-11-2006, 09:58 PM   #4
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Rep: Reputation: 52
You've tried in a wired network and it's still that slow? What does the output of 'mii-tool -v' say?

-twantrd
 
Old 09-11-2006, 10:27 PM   #5
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Original Poster
Rep: Reputation: 30
My desktop is wireless right now, so mii-tool won't work. At least it says no interfaces found. The other box IS wired, though, so I'll post the output tomorrow.

Yes, I've gotten the slow speeds both wirelessly AND wired. Makes no difference. But, again, when I use WinXP on VMware, I'm blazing. It's using the SAME hardware (the wifi pci card) at the SAME time! I'm BAFFLED!!!

Thanks for the reply!

--Akshun J
 
Old 09-12-2006, 07:29 PM   #6
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Original Poster
Rep: Reputation: 30
Here's what mii-tool has to say:

eth0: negotiated 100baseTx-FD flow-control, link ok
product info: Intel 82555 rev 4
basic mode: autonegotiation enabled
basic status: autonegotiation complete, link ok
capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

It looks like everything is okay on this end. Any suggestions?

--Akshun J
 
Old 09-12-2006, 07:49 PM   #7
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Original Poster
Rep: Reputation: 30
And here's my ethtool output:

root[akshunj]# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Current message level: 0x000020c1 (8385)
Link detected: yes
 
Old 09-13-2006, 02:16 AM   #8
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,438

Rep: Reputation: 52
Wow, that's interesting. Hmmm, any services running on both of your linux boxes? Any services having connections being established? You can check with netstat -an.

-twantrd
 
Old 09-13-2006, 09:54 AM   #9
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Original Poster
Rep: Reputation: 30
Hmmm. No extra services. These are really just desktop boxes. Upon further investigation, I believe my routers may be part of the issue. Here's my setup:

Cable Modem --> Linksys Wired router/phone adapter (Vonage VOIP) --> Netgear wireless G router/printserver --> All desktops and laptops

Somehow I think the Netgear router is not routing the packets correctly along the lan. Perhaps my WinXP on VMware sends them in a different form? In any case, the speed difference between WinXP and Linux was not all that pronounced in the first place. 1.5Mb/sec in WinXP, and between 500 and 900 Kb/sec native linux. In any case, I should be getting faster speeds than either platform has demonstrated.

I was fiddling with the router settings last night. I read something about RIP when there is more than one router on a network? Anyone know anything about this? Should I enable it?

Update: My router seems to have wigged out. It won't properly report the devices attached to it. The list is always short by one computer... (Sigh) Maybe it's time for a new router...

--Akshun J
 
Old 09-13-2006, 04:41 PM   #10
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 187
Blog Entries: 1

Rep: Reputation: 38
Check cable, may not apply, but check it anyway, most network problem was caused by bad cable/interferances etc. disable autosensing.

the DNS setting, or resolv.conf file, see how your netowrk resolve its address, which is the second cause of network problem.

firewall on the router, I doubt it much, but check it anyway. see if you have default route in the net table.

Last edited by number22; 09-13-2006 at 04:46 PM.
 
Old 09-16-2006, 12:18 AM   #11
akshunj
Member
 
Registered: Sep 2002
Location: Atlanta, GA
Distribution: Linux Mint Gloria, Slackware 12.2
Posts: 165

Original Poster
Rep: Reputation: 30
Lessons learned? MANY!

For those interested, I have mostly fixed my issue. The first thing I did was put my Vonage router BEHIND my Netgear wireless router. Then I sat down and learned the difference between bits and bytes. For the longest time I had been thinking that the 300kilobytes per second transfers I was getting were soooo far short of the 54Megabyte per second transfers advertised by my wifi cards and router. And then I realized after much googling, that 54Mb/sec was actually 54MegaBITS! That's more like 6750kilobytes per second. Yes, still far short of what I was getting, but now I had some perspective. I have some 802.11b bottlenecks, so maybe the best I could expect was 1375kilobytes per second (11Megabits). Sure as can be, when I powered my network back up, I was cranking 1375kilobytes. I also learned that setting a dynamic preamble can boost overall wireless throughput and stability!

So, now I'm MUCH happier with my network speed. But I'm planning on hopping on over to the wireless forum to find out how I can get my whole 6750KB/sec (54Mb)!

Thanks for all of the suggestions, guys. I hope my info can help someone else!

--Akshun J
 
  


Reply

Tags
lan, networking, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow network file transfers purelithium Linux - Networking 4 02-14-2006 05:28 PM
reading ethereal output... pAn1k Linux - Networking 6 11-19-2004 03:26 PM
Slow ftpserver transfers svearike Linux - Newbie 1 09-03-2004 04:37 PM
lan file transfers crash my box hank43 Linux - Networking 1 03-01-2004 07:36 AM
slow ftp transfers using in.ftpd mrdiet Linux - Networking 2 06-10-2001 05:53 PM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration