LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-12-2008, 11:13 AM   #1
PATRINOS06
LQ Newbie
 
Registered: Jan 2007
Posts: 6

Rep: Reputation: 0
Totally messed up with squid3 as transparent proxy


Hi there.

I'm trying to set up squid3 as a transparent proxy for my home gateway.It uses eth0 (192.168.1.100) for the external network and eth1 (172.16.0.1) for the internal.So far,after spending the whole day googling and trying various parameters in the squid3.conf i've ended up to this

/etc/squid3/squid.conf


Code:
http_port 172.16.0.1:3128 transparent
cache_mgr poscaman@gmail.com
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
cache deny QUERY
acl apache rep_header Server ^Apache
access_log /var/log/squid/access.log squid
hosts_file /etc/hosts
refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern .               0       20%     4320
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 563      # https, snews
acl SSL_ports port 873          # rsync
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443 563     # https, snews
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl Safe_ports port 631         # cups
acl Safe_ports port 873         # rsync
acl Safe_ports port 901         # SWAT
acl purge method PURGE
acl CONNECT method CONNECT
http_access allow manager localhost
http_access deny manager 
http_access allow purge localhost 
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localhost
acl lan src 172.16.0.0/24
http_access allow localhost 
http_access allow lan
http_access deny all
http_reply_access allow all 
icp_access allow all
visible_hostname Router
always_direct allow all
coredump_dir /var/spool/squid 800 16 256
although the config files seems to be ok,an squid3 goes on,i mention that port 3128 is not open
Code:
nmap localhost

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-10-12 22:07 EEST
Interesting ports on localhost (127.0.0.1):
Not shown: 1677 closed ports
PORT    STATE SERVICE
22/tcp  open  ssh
111/tcp open  rpcbind
113/tcp open  auth
also browser responds

Code:
Proxy Server Refused Connection
could u pls take a look at my squid.conf?what is the real problem?

thanks a lot.
Dimitris
__________
 
Old 10-12-2008, 01:06 PM   #2
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,887

Rep: Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774
Quote:
Originally Posted by PATRINOS06 View Post
Hi there.

I'm trying to set up squid3 as a transparent proxy for my home gateway.It uses eth0 (192.168.1.100) for the external network and eth1 (172.16.0.1) for the internal.
It uses a non-routable address for the external network and a routable address for the internal? Are you sure that you haven't interchanged these?

What does squid then connect to, an ethernet modem/router or something else?
 
Old 10-12-2008, 01:10 PM   #3
PATRINOS06
LQ Newbie
 
Registered: Jan 2007
Posts: 6

Original Poster
Rep: Reputation: 0
an ethernet modem/router under 192.168.1.1 (bridged mode)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Totally messed up the user permissions.*want to cry* hottdogg Slackware 6 08-31-2007 05:00 AM
Totally messed up the user permissions.*want to cry* hottdogg Slackware 2 08-30-2007 02:13 PM
sound totally messed up djlosch Linux - Hardware 8 09-02-2004 09:24 PM
GRUB is totally messed up! is blaster to blame randyriver10 Linux - Software 6 03-22-2004 05:28 PM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration