LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-06-2005, 04:32 PM   #1
nicolasdiogo
Member
 
Registered: Oct 2003
Location: UK
Distribution: debian lenny x64
Posts: 129

Rep: Reputation: 20
tomcat on suse 9.3 - admin tool does not work; it shows a blank page


hi all,

i have installed suse 9.3 and configured Apache2 and Tomcat with mod_jk
wiithout a problem; you can and test their samples.
but when i try to connect to the administration tool of Tomcat, i only see
a blank page.
i checked the variables that point to the admin ($catalina_home =
/usr/share/tomcat5) and i can start & stop without a glitch.
the pages are all there on /usr/share/tomcat5/server/webapps/admin. And
Struts is installed - very strange.

i have utilised suse 9.2 with apache2 and tomcat5 without any problem, but
this time it is rather impossible to get it working.

thanks in advance for your assistance & time.

Nicolas

www.jegue.net
 
Old 06-07-2005, 09:11 AM   #2
fbouzema
LQ Newbie
 
Registered: Jun 2005
Location: Paris - France
Posts: 1

Rep: Reputation: 0
Hi, I think you have to install the tomcat5-admin-webapps
package...

Tell me if it helps, thank you
 
Old 06-07-2005, 03:16 PM   #3
nicolasdiogo
Member
 
Registered: Oct 2003
Location: UK
Distribution: debian lenny x64
Posts: 129

Original Poster
Rep: Reputation: 20
Cool thanks

i have installed all packages linked with tomcat5 ( struts, mod_jk, tomcat5, admin, web-examples )
the configuration is the default, and i also tried the mod_jk as described on their README file.
but it still does not show the admin section.
i have no idea what the problem is; most interisting is the fact that all exaples work fine with localhost:8080/jsp-examples or localhost/jsp-examples.

i do need some assistance here please?!

nicolas
 
Old 06-14-2005, 02:15 AM   #4
nicolasdiogo
Member
 
Registered: Oct 2003
Location: UK
Distribution: debian lenny x64
Posts: 129

Original Poster
Rep: Reputation: 20
tomcat - admin

i have found that tomcat admin tool 5.0.30 comes with a problem on the struts-admin.xml file and that we can download a corrected one from jakarta.apache.org/tomcat. however, this file did not work for me.
has anyone else experienced similar problems? i have posted this issue with Novell by there has been no response from them as yet?!

does anyone know where i can find guidance on compiling and installing or RPM for a newer Tomcat version for Suse 9.3 + ?

thanks,

nicolas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tomcat start page in SuSE 9.1 Pro [GOD]Anck Suse/Novell 1 01-14-2005 04:58 AM
Suse 9.1 - Can't get Tomcat work aSimpleTux Linux - Software 1 09-27-2004 11:11 PM
IMP shows blank page! k. kirk Linux - Software 2 07-02-2003 03:14 AM
SWAT-Admin tool nero64 Linux - Newbie 8 12-15-2002 05:15 AM
admin tool gunz Linux - General 2 10-01-2002 03:22 AM


All times are GMT -5. The time now is 03:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration