LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-11-2003, 11:10 AM   #1
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Rep: Reputation: 46
telnet to port 25 connects but without reply?


I know, I know, telnet isn't secure. I am just using it to test connectivity to my recently configured mail server. When I telnet to it I get the following..

> telnet <mailsvr-ip> 25
connected to <mailsvr-ip>
Escape character is [^


And nothing else...

It should respond with something like
Postfix version blah blah etc etc

I checked the server, port 25 is open and postfix is running.
Anyone know why it would let me telnet to it without any reply?

Last edited by Pcghost; 04-11-2003 at 11:18 AM.
 
Old 04-11-2003, 11:57 AM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Re: telnet to port 25 connects but without reply?

Quote:
Originally posted by Pcghost
> It should respond with something like
Postfix version blah blah etc etc
Why would it respond like that? You are using the telnet protocol on an smtp port. In my experience the "Escape character is [^" means that the port is open and you are connected to it. If you type a few things, it doesn't matter what you type, you should get a connection closed message because again you are using the telnet protocol.

What are you trying to accomplish by telnetting into the smtp port?
 
Old 04-11-2003, 12:34 PM   #3
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Original Poster
Rep: Reputation: 46
When I telneted to port 25 on my domino server it would reply with
Lotus Domino R5.0.5 on raptor status up etc etc

I figured it would do the same with postfix. I am trying to test the postfix installation/configuration. The mx records on the internet have yet to update so sending mail to my domain doesn't use this server, it uses our old mail server.
What is the best way to test a mail servers forwarding? I cant use the ip address in the to: field right?
 
Old 04-11-2003, 01:46 PM   #4
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 587

Rep: Reputation: 32
Quote:
Originally posted by Pcghost
I cant use the ip address in the to: field right?
Not right.
In properly configured MTA the mail addresses like
john@some.domain and john@[x.y.z.v] are equivalent if some.domain is FQDN of x..y.z.v
 
Old 04-11-2003, 03:39 PM   #5
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Original Poster
Rep: Reputation: 46
Can anyone tell me which of the settings in main.cf sets up forwarding of all incoming mail to an internal server? I know they say it's easier than Sendmail, but I don't remember Sendmail giving me this much trouble..
 
Old 04-20-2003, 07:23 PM   #6
albracco
Member
 
Registered: Jan 2003
Posts: 48

Rep: Reputation: 15
From what I've read, you use "transport_maps". I am trying to setup Postfix also and am having a devil of a time.
 
Old 04-21-2003, 06:07 PM   #7
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Original Poster
Rep: Reputation: 46
I found a HOWTO at redhat that has helped alot. I now have it setup but am fighting with the connectivity between our two mail servers. They keep rejecting the mail I forward to them as relaying. Sigh... It is easier than Sendmail in the design of the conf files..
 
Old 04-24-2003, 06:23 PM   #8
fbennett
LQ Newbie
 
Registered: Apr 2003
Location: Canada
Distribution: Mandrake 10.x
Posts: 10

Rep: Reputation: 0
No one has answered your question yet about telnetting to port 25. Yes you *can* test your smtp server like that. I do it all the time. You might want to turn on local_echo in your telent client first; I find that it helps to see what I'm typing. How to do that would depend on your telnet client - try "set localecho" or "set local_echo" at the telnet cmd prompt. Then "open ip.addr.xxx.xxx 25". You may not see any response yet. Type "HELO testdomain.com" and you should see a response. Then "MAIL FROM: me@otherdomain.com" should get you another Ok response. Then "RCPT TO: myuser@mydomain.com" should give another Ok. Then "DATA" <cr> followed by "Subject: blah, blah" <cr> text of test message... <cr> and finally "." followed by a final <cr> should place the message in the queue for delivery. "QUIT" to end your telnet session and you're done. The message should be delivered by the time you quit.

As for all the other configuration issues, I find it much easier to use Webmin at least for the initial configuration. If you're not familiar with it, webmin is a browser based server configuration tool. It incorporates a built-in web server so you don't need to have Apache running. You do need to have X windows installed though.

Hope that helps.
 
Old 08-31-2003, 02:45 PM   #9
jeveren
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
I was wondering how you'd fixed your problem. I have the same. I installed postfix, a portscanner says that port 25 is open, I can telnet to port 25, but I can't see: blablabla postfix ...If I type helo me (enter) it does not respond.

If I go to the shell, and stop postix, the connection is lost. I am puzzled.

Dennis
 
Old 08-31-2003, 03:19 PM   #10
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
See above regarding local echo.

By the way, you can telnet to ANY TCP application port, and if they're a simple cleartext protocol with no special negotiation (like SMTP, HTTP, etc) it will work! You just have to know what sequence to enter the commands in, what syntax to use, and if you want to have any clue what's going on, make sure you set local echo.

I've used telnet to complete entire SMTP transactions, verify that I can download the correct information from a web site, used it for proprietary provisioning protocols developed by a company I worked for, verify ssh banner (ssh requires complicated handshaking that is not possible for a human to mimic), etc.
 
Old 09-02-2003, 01:11 PM   #11
jeveren
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
nah, it is not the local echo. Cauz I am still a newbie, I forgot one thing: create an alias! I know stupid. Created the alias, logged in using telnet, and bingo, I saw the 220 postfix ...line. Thanks anyway!
 
Old 12-03-2003, 04:56 AM   #12
kaasi
LQ Newbie
 
Registered: Oct 2003
Distribution: redhat
Posts: 9

Rep: Reputation: 0
jeveren,
i have d same problem. i'm a newbie. how do i create the alias?
 
Old 12-04-2003, 09:20 AM   #13
jeveren
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Well, I edited the file /etc/postfix/aliases. Now I have webmin running, which is enableing me to easy administer postfix. Does this solve your problem?
 
Old 01-19-2004, 10:03 PM   #14
tjhack
LQ Newbie
 
Registered: Jan 2004
Posts: 1

Rep: Reputation: 0
Postfix has an "inet_interfaces" entry in the /etc/postfix/main.cf file with several possibilities:

#inet_interfaces = localhost
#inet_interfaces = all
#inet_interfaces = $myhostname
inet_interfaces = $myhostname, localhost

you probably want the last one uncommented (as shown). My guess is the inet_interfaces=localhost is active (by default?). If so, you would be able to "telnet 127.0.0.1 25" or "telnet localhost 25" and get the expected results, while "telnet <hostname> 25" won't connect.

After making the change, "telnet <hostname> 25" will work as expected.
Don't forget to restart postfix (/etc/init.d/postfix restart) after the change is made. Good luck.

tj
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PLESK [Solution] Change port to 23 (telnet) instead of default port 8443 x5452 Linux - Software 6 05-10-2009 05:58 AM
Telnet & FTP localhost connects then hangs Derekeigentek Linux - Newbie 3 12-30-2005 10:46 AM
post reply & submit reply buttons annehoog LQ Suggestions & Feedback 10 01-05-2004 06:43 PM
DNS reply port for firewall countcobolt Linux - Networking 5 12-07-2003 03:50 AM
telnet connects but login prompt does not appear jhess Linux - Software 2 10-10-2003 06:05 AM


All times are GMT -5. The time now is 05:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration