LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 08-25-2002, 08:36 PM   #1
hcmk
LQ Newbie
 
Registered: Aug 2002
Posts: 5

Rep: Reputation: 0
Question telnet connection refused


i am configuring suse 8.0 and i can't telnet to my machine. can't telnet to 127.0.0.1 from within either.

i get error message "connection refused" on loopback address. and when i'm trying to telnet from my windows box, i get "connection to host lost" before it gives me a login dialog.

inetd is started becuase i can ftp to my machine with no problem. i checked the settings in inetd.conf and the telnet line is not commented out. i also checked the rc.config and the ports are open.

i also can't send mail from the command line. (e.g. /usr/sbin/sendmail root < message) i get a connection refused.

any ideas??

thanks,
h
 
Old 08-25-2002, 11:02 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
did you start the telnet daemon?
Are you running a firewall?
Is the sendmail daemon started?
 
Old 08-26-2002, 03:03 PM   #3
manaskb
Member
 
Registered: Jan 2002
Location: India
Distribution: Suse , Mandrake
Posts: 121

Rep: Reputation: 15
Hi hcmk,
You can do a nmap to see if you have any listeners for these daemons on you system. Alternatively you can use YaST2 con check the status of the daemon and also activate them if they are not running. Try YaST2->Network Basic ->Strat Stop Service( Inetd). Her you can see what processers are active and also activate process.
Thanks,
Manas
 
Old 08-26-2002, 03:56 PM   #4
hcmk
LQ Newbie
 
Registered: Aug 2002
Posts: 5

Original Poster
Rep: Reputation: 0
thanks everyone for your help.

it's fixed.
 
Old 08-29-2002, 12:07 PM   #5
hwert
LQ Newbie
 
Registered: Aug 2002
Location: Central Florida
Distribution: SuSE 8.0
Posts: 4

Rep: Reputation: 0
SuSE 8.0 telnet failure

What did you do to correct the problem? I have been fighting this for weeks.
Thanks
 
Old 10-22-2002, 03:14 AM   #6
kalyandhar
LQ Newbie
 
Registered: Oct 2002
Posts: 1

Rep: Reputation: 0
Question how did you solve the problem?

hello sir,
by the way how did fix the telnet problem?
plese let me know i have the same problem
kalyan
 
Old 10-22-2002, 11:52 AM   #7
hcmk
LQ Newbie
 
Registered: Aug 2002
Posts: 5

Original Poster
Rep: Reputation: 0
i am trying to remember how i solved the problem. i believe that it was as simple as inetd was not scheduled to run at startup. i edited the runlevel editor to start inetd in runlevels 3 & 5. then i rebooted. it has been fine since then. for some reason in SuSE 8.0 inetd is not enabled by default on install. i had just installed 8.0 and i thought it would be.
 
Old 10-23-2002, 06:34 AM   #8
correro
Member
 
Registered: Oct 2002
Distribution: RedHat 8.0
Posts: 140

Rep: Reputation: 15
I have the same problem for weeks:
telnet/ftp localhost return "Connection refused"
I have no firewall installed.
What exactly should I do to make it work?
 
Old 10-23-2002, 06:47 AM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
you should use the search button up there, and make sure you try all the standard anwers first...
 
Old 10-28-2002, 12:04 PM   #10
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
it's probably disabled in xinetd.d/telnet if your system has that


[david@www david]$ cat /etc/xinetd.d/telnet
# default: on
# description: The telnet server serves telnet sessions; it uses \
# unencrypted username/password pairs for authentication.
service telnet
{
disable = yes
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
}
 
Old 10-28-2002, 12:07 PM   #11
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
as far as ftp goes

[david@www david]$ cat /etc/xinetd.d/wu-ftpd
# default: on
# description: The wu-ftpd FTP server serves FTP connections. It uses \
# normal, unencrypted usernames and passwords for authentication.
service ftp
{
disable = no
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.ftpd
server_args = -l -a
log_on_success += DURATION USERID
log_on_failure += USERID
nice = 10
}
 
Old 10-28-2002, 12:08 PM   #12
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
and of course make sure the servers are running

Last edited by DavidPhillips; 10-28-2002 at 12:09 PM.
 
Old 10-29-2002, 12:04 PM   #13
nonamenobody
Member
 
Registered: Oct 2002
Posts: 138

Rep: Reputation: 22
This post seems a little cluttered, so I would like to clarify.

On SuSE (8.0 and 8.1 at least), telnet is not enabled by default. First you need to make sure 'inetd' and 'telnet-server' are installed. Then you need to start 'inetd' using the runlevel editor in YaST2. Finally you need to edit your inetd.conf, the simplest way to do this is using the 'Start/stop services (inetd)' in YaST2.

You do not need to start a telnet server, inetd takes care of this.

One final point, you should really be using SSH rather than telnet. In addition to being more secure, it supports file copying (scp and sftp) and X11 forwarding.

>> inetd is started becuase i can ftp to my machine with no problem.

HCMK, FYI (just incase you have spotted it yet) ftp is an independant service (in SuSE), and is not started by inetd.
 
Old 09-02-2006, 03:31 PM   #14
malbery
Member
 
Registered: Aug 2004
Distribution: Debian sarge 2.6.8-2-k7
Posts: 60

Rep: Reputation: 15
I was having problems, this worked for me in Ubuntu 6.06:

Install inetutils-telnetd and xinetd. Verify that the file /etc/xinetd.d/telnet contains:

Code:
service telnet
{
        flags           = REUSE
        socket_type     = stream
        wait            = no
        user            = root
        server          = /usr/sbin/telnetd
        log_on_failure  += USERID
        disable         = no
        groups          = yes
}
You might need to restart xinetd for changes to take effect. Any problems should show up in /var/log/daemon.log.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
telnet connection refused Marcusj2 Linux - Networking 22 09-07-2006 11:35 PM
telnet connection refused turbo_acura Linux - Networking 8 11-21-2004 10:07 AM
Telnet connection refused naveenpn Linux - Networking 2 02-17-2004 08:16 AM
telnet: Connection refused hnash53 Linux - Networking 2 01-23-2004 03:12 PM
Telnet: Connection Refused Erice60rng Linux - Security 7 01-20-2003 07:15 PM


All times are GMT -5. The time now is 07:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration