LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 07-07-2004, 10:30 AM   #16
rmsat
LQ Newbie
 
Registered: May 2004
Location: Southern California
Posts: 21

Rep: Reputation: 15

Thanks for your caution captain. I first attempted to use SWAT with SSL a while ago and loading it up was a bit overwhelming for me at that time. I am only on a small LAN so security concerns are not the greatest at this time, as we grow though....
Any suggestions as to an "easy" way to load SSL?
D
 
Old 07-13-2004, 11:42 AM   #17
brucerowe
LQ Newbie
 
Registered: Jun 2004
Location: California
Distribution: Suse 11.0
Posts: 12

Original Poster
Rep: Reputation: 0
Problem solved!

I found it. The problem is not Samba or Swat at all. It's Apache.

Evidently, it's a security feature. In the default setup, Apache will only listen to port 80. You need to tell it to listen to another port, as well.

Click on the Green Lizard | Control center | YAST2 | Network services | HTTP server.

You will see, "Service enabled." Underneath, you will see a list of ports that the web server is listening on. By default, the only port is 80.

Click on Edit | Add. Add port 901 to the list for All. Click on OK and you are done.

The new Swat program looks pretty much the same as the old one. There are a few more options, as you might expect.

Have fun.

Bruce
 
Old 09-11-2008, 11:45 AM   #18
ksclps
LQ Newbie
 
Registered: May 2006
Posts: 19

Rep: Reputation: 0
SWAT/SMB difficulties raise their ugly head again

Hello. Four years after this thread begun and I too am researching how to solve my SWAT difficulties. I am running FC8, and have installede Samba 3.0.30.0 and its respective SWAT. I have verified my smb.conf file exists as well as the swat binary in /etc/xinetd.d. That file includes the modified disable = no as well as the added protocol = tcp that captainp mentioned. Trying to invoke SWAT using http://127.0.0.1:901 doesn't work, neither does the localhost approach.

Any helpful suggestions would be greatly greatly appreciated.

TIA,

John M
 
  


Reply

Tags
smb, swat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SWAT cannot connect to localhost port 901 KhmerDucky Linux - Networking 1 06-10-2005 01:17 PM
Samba - Swat: Cannot Connect to Localhost:901 Sloppyunderfoot Linux - Networking 3 02-10-2005 12:26 PM
help setting swat up and opening port 901 tarax Linux - Security 7 03-18-2004 07:49 PM
SAMBA & SWAT - Connection refused when attempting to connect Localhost:901 ScooterB Linux - Networking 3 12-24-2003 04:15 PM
SWAT does not work when calling localhost:901 themorph Linux - Networking 2 03-06-2002 11:04 PM


All times are GMT -5. The time now is 08:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration