LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 09-12-2010, 06:22 PM   #1
amgenhammer
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Exclamation Suspected Networking Problem with Ubuntu Server 10.04lts


Having a bit of an issue connecting to my apache2 server. I'm running Ubuntu Server 10.04lts. I can only connect to my website via ip address global, ip address local, and the dyndns domain I have linked to my ip address. I have DMZ setup for my server with a local static address of 192.168.1.100. I can only connect to the default apache page via lan, and It wont load when I try via proxy. Help please, lol. I need to know how to configure my router (wndr3300) so that I can connect to my server (address 192.168.1.100) and the pages from outside of my network. Thanks!

Last edited by amgenhammer; 09-12-2010 at 06:25 PM. Reason: Clarifying that this does belong in networking. Question about network config, not about apache
 
Old 09-12-2010, 07:01 PM   #2
MJBoa
LQ Newbie
 
Registered: May 2008
Posts: 15

Rep: Reputation: 0
Quote:
I can only connect to my website via ip address global, ip address local, and the dyndns domain I have linked to my ip address.
This seems like exactly what you want... how else do you want to access it?
Check your apache configuration to make sure it's listening on all IP addresses.

By the way, it's a much better idea to simply forward the ports you need to forward to your web server. 80, 443, 22, whatever. More secure and simpler this way.
The way your DMZ setup will work is this. All ports not already forwarded will be forwarded to your web server. You will only be able to access it (outside your network) using the same IP your router has, your global IP for every computer on that network. All of your machines connected to the router appear to have one IP address to every computer outside your router.

Last edited by MJBoa; 09-12-2010 at 07:08 PM.
 
Old 09-12-2010, 07:17 PM   #3
amgenhammer
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Still a no-go. I used the ports.conf default Listen 80 and changed it to Listen 192.168.1.100:80 but it still wont connect. Maybe a port issue? Do i need port forwarding enabled as well?
 
Old 09-12-2010, 07:41 PM   #4
MJBoa
LQ Newbie
 
Registered: May 2008
Posts: 15

Rep: Reputation: 0
Often people answer networking questions and totally confuse the asker by not explaining, so I will try to illustrate very clearly.

You have your webserver local address 192.168.1.100. This is only accessible by machines on your local subnet.
You have your global address 50.1.1.1. 50.1.1.1 routes to your router from anywhere on the internet.
Without DMZ or any ports forwarded, all incoming connections to 50.1.1.1 are dropped by your router's firewall.

Right now, on your LAN when you trying to access 102.168.1.100, it works fine, right?

Go into your router configuration, forward port 80 to 192.168.1.100.
Turn off DMZ completely.

You should now be able to access http://50.1.1.1 and it should be your webpage, assuming you don't have any sort of firewall setup on your server.

Oh and leave the ports.conf as Listen 80.
 
Old 09-12-2010, 09:27 PM   #5
never say never
Member
 
Registered: Sep 2009
Location: Indiana, USA
Distribution: SLES, SLED, OpenSuse, CentOS, ubuntu 10.10, OpenBSD, FreeBSD
Posts: 195

Rep: Reputation: 37
One note to MJBoa's post. You will probably not be able to access http://50.1.1.1 from your LAN. This is called NAT Reflection and most routers get rather confused and will fail to do it, so you will need to test from some other internet point (a smart phone not connected to your WIFI for example).
 
Old 09-12-2010, 11:11 PM   #6
amgenhammer
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Okay, I followed your instructions. Still a no-go. With DMZ disabled and portforwarding enabled, there is NO connection at all, inside lan or out. Any suggestions? The router is WNDR3300 if that helps. I have port 80 configured on apache and port forward.
 
  


Reply

Tags
apache2, hosting, networking, ports, server


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OOo 3.2 crashes in Ubuntu 10.04lts dgermann Ubuntu 7 08-18-2010 10:37 PM
Cant install ubuntu 8.04LTS on my server. forcevision Linux - Server 6 05-26-2009 04:33 PM
[Ubuntu 8.04LTS] Kernel Recompiling laurens Linux - Newbie 0 04-29-2009 05:05 AM
Help for wine installation on Ubuntu 8.04LTS Ye Myint Linux - Newbie 4 09-29-2008 05:48 AM
Ubuntu 8.04LTS + Samba (how to join active domain in Windows Server 2008) PatrickBEN Ubuntu 1 06-01-2008 07:32 AM


All times are GMT -5. The time now is 05:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration