LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Suspected Networking Problem with Ubuntu Server 10.04lts (http://www.linuxquestions.org/questions/linux-networking-3/suspected-networking-problem-with-ubuntu-server-10-04lts-831760/)

amgenhammer 09-12-2010 05:22 PM

Suspected Networking Problem with Ubuntu Server 10.04lts
 
Having a bit of an issue connecting to my apache2 server. I'm running Ubuntu Server 10.04lts. I can only connect to my website via ip address global, ip address local, and the dyndns domain I have linked to my ip address. I have DMZ setup for my server with a local static address of 192.168.1.100. I can only connect to the default apache page via lan, and It wont load when I try via proxy. Help please, lol. I need to know how to configure my router (wndr3300) so that I can connect to my server (address 192.168.1.100) and the pages from outside of my network. Thanks!

MJBoa 09-12-2010 06:01 PM

Quote:

I can only connect to my website via ip address global, ip address local, and the dyndns domain I have linked to my ip address.
This seems like exactly what you want... how else do you want to access it?
Check your apache configuration to make sure it's listening on all IP addresses.

By the way, it's a much better idea to simply forward the ports you need to forward to your web server. 80, 443, 22, whatever. More secure and simpler this way.
The way your DMZ setup will work is this. All ports not already forwarded will be forwarded to your web server. You will only be able to access it (outside your network) using the same IP your router has, your global IP for every computer on that network. All of your machines connected to the router appear to have one IP address to every computer outside your router.

amgenhammer 09-12-2010 06:17 PM

Still a no-go. I used the ports.conf default Listen 80 and changed it to Listen 192.168.1.100:80 but it still wont connect. Maybe a port issue? Do i need port forwarding enabled as well?

MJBoa 09-12-2010 06:41 PM

Often people answer networking questions and totally confuse the asker by not explaining, so I will try to illustrate very clearly.

You have your webserver local address 192.168.1.100. This is only accessible by machines on your local subnet.
You have your global address 50.1.1.1. 50.1.1.1 routes to your router from anywhere on the internet.
Without DMZ or any ports forwarded, all incoming connections to 50.1.1.1 are dropped by your router's firewall.

Right now, on your LAN when you trying to access 102.168.1.100, it works fine, right?

Go into your router configuration, forward port 80 to 192.168.1.100.
Turn off DMZ completely.

You should now be able to access http://50.1.1.1 and it should be your webpage, assuming you don't have any sort of firewall setup on your server.

Oh and leave the ports.conf as Listen 80.

never say never 09-12-2010 08:27 PM

One note to MJBoa's post. You will probably not be able to access http://50.1.1.1 from your LAN. This is called NAT Reflection and most routers get rather confused and will fail to do it, so you will need to test from some other internet point (a smart phone not connected to your WIFI for example).

amgenhammer 09-12-2010 10:11 PM

Okay, I followed your instructions. Still a no-go. With DMZ disabled and portforwarding enabled, there is NO connection at all, inside lan or out. Any suggestions? The router is WNDR3300 if that helps. I have port 80 configured on apache and port forward.


All times are GMT -5. The time now is 03:29 AM.