LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-07-2005, 06:22 AM   #1
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Rep: Reputation: 15
Question SuSE 9.3 ADSL/router config problem


Potted history:
Weeks of frustration with FC4 install issues, tried SuSE9.3 and it went straight on without a hitch. Trying to configure a Belkin ADSL modem/wireless router on PC#1 for internet connectivity (the next stage is a home wireless LAN, but I fancy thatís a way off yet).

The problem:
I can now access the Belkin Management Console, but cannot connect to the outside world.

I have the correct username, password and settings for my ISP (Wanadoo UK), & on the Belkin Management Console, once my details are entered, I get the status: connected. Looking at the status screen, I have the following test function/results:

Connection Status:
ADSL pass
PPPoE pass
ppp pass
IP ping pass
DNS pass
OAM F4-ETE ping fail
OAM F4-SEG ping fail
OAM F5-ETE ping pass
OAM F5-SEG ping pass

Does that suggest anything?

My default gateway is set to 192.168.2.1 (the config add for the router) and checking my kernel routes, the command /sbin/route -n gives me the following output:

local1:~# /sbin/route -n
Kernel IP routing table

Destination Gateway Genmask Flags Metric Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 lo
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 eth0

Does this yield any clues? Any thoughts/help/suggestions/requests for further file output, gratefully received.

Kaine.
 
Old 11-07-2005, 10:10 AM   #2
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
As I see you use PPPoEand yŁu get any messages from your ISP...
You are already local
add one line iin
/etc/sysconfig/network/pppoe
usepeerdns
 
Old 11-09-2005, 02:23 AM   #3
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Original Poster
Rep: Reputation: 15
Hmmm...

Looking under etc/sysconfig/network/, I don't find a 'pppoe' file, so I'm not sure where I should add the line usepeerdns

The only file that looks to be of any editable benefit is the config file relating to my NIC:
ifcfg-eth-id-00:0f:b5:f5:d0:73

Still unsure..... and still not connected.....

Kaine.
 
Old 11-09-2005, 03:18 AM   #4
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
You are right,
it is
/etc/ppp/peers/pppoe

otherwise try
find / -name pppoe -print

Paul
 
Old 11-10-2005, 02:09 AM   #5
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Original Poster
Rep: Reputation: 15
Thanks again for your input Paul, unfortunately I have tried adding that command to both the pppoe file, and pppoe-rp file, but without any difference.

Any other ideas?

Kaine.
 
Old 11-10-2005, 07:10 AM   #6
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
What you find in /etc/resolv.conv ?
But there a valid IP address and the system will exchange to a valid number
 
Old 11-10-2005, 01:15 PM   #7
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Original Poster
Rep: Reputation: 15
OK, in /etc/resolv.conf I have:

nameserver 192.168.1.100
searchsite

And nothing else. I don't recognise that number as anything that I have determined in any of the configuration so far.

Kaine.
 
Old 11-11-2005, 12:25 AM   #8
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
nameserver 192.168.1.100
searchsite

I think you have do remover searchsite. And ask your provider for the nameserver IP and replace this numbers
 
Old 11-11-2005, 01:44 AM   #9
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Original Poster
Rep: Reputation: 15
OK, so you suggest I remove the searchsite line?
And when I speak to my ISP, it's the nameserver address I'm asking for and not DNS? (The reason I want to be clear is that I have the DNS settings already) That number doesn't relate to my default gateway at all then (192.168.2.1)?
 
Old 11-11-2005, 08:20 AM   #10
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
class A 10 x.x.x
class B 172.?.x..x
class C 192.168.x.x
are special ip-addresses which are not be routed inside the net.Everybody can use them inside his
provide network without any trouble. Your gateway should have second ip-adress which speaks
to the world. Every ip-package which is not a part of you lan (local area network) will be send to your
to your default gateway. The gateway masquerade your IP-Package (that means it exchange your local
IP-Address with a valid address which you get from your provider). This address you will get from
DNS and or DHCP and it valid during your complete session. After you restart your System the IP-address could be the same but normally it not the same.
Paul
 
Old 11-12-2005, 01:11 AM   #11
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Original Poster
Rep: Reputation: 15
Paul, sincerest thanks for your help and for your patience.

Looking at that line again (nameserver 192.168.1.100) made me realise, that I had not entered the correct DNS addresses for my NIC.

Finally, I am online with SuSE!

Kaine.
 
Old 11-12-2005, 08:44 AM   #12
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
That makes me happy.
If you are online now check your /etc/resolve again!
Now you will see your real named -server address
regards
Paul
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot access config web-page for adsl router tireseas Linux - Networking 6 03-19-2005 04:13 PM
Looking for an ADSL router for SuSE 9.1 spariggio82 Linux - Hardware 2 06-24-2004 02:39 AM
ADSL Routers Setup- Microsom Deskporte router 100 and Planet ADSL modem router mabonline Linux - Hardware 1 02-27-2004 05:36 PM
RH 7.2 Config to get HTTP via ADSL Modem/Router getunit.com Linux - Networking 3 05-02-2002 02:44 AM
SuSE 7.1 Pro config of ADSL????? SloHands Linux - Distributions 4 11-15-2001 08:50 PM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration