LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-06-2004, 06:35 AM   #1
mikemrh9
Member
 
Registered: Nov 2003
Distribution: Arch
Posts: 136

Rep: Reputation: 21
SuSE 9.1 YaST Online Update and Proxy Settings


Hi.

I'm having problems getting YaST Online Update to work. I'm using a MS ISA server as an http proxy, and have configured the Proxy settings in 'Network Services, Proxy' to the following:

http proxy: http://x.x.x.x:8080/
ftp proxy: http://x.x.x.x:8080/ (have also tried ftp://x.x.x.x:8080/, but it's an http proxy server)

When I try one of the http servers from the list of update servers specified in YaST, initially I get a message saying it's retrieving information, but then I get an http 404 error.

When I try one of the ftp servers froom the list, I get the 'Retrieving information' dialogue followed by the error: 'Signature check for patch information file failed, Cannot load patch information.'

All the server url's are accessible through the proxy using a browser.

I need the updates for the samba client, and this is driving me nuts!!
 
Old 07-08-2004, 06:31 PM   #2
46&2
Member
 
Registered: Mar 2004
Location: Idaho, USA
Distribution: Gentoo
Posts: 67

Rep: Reputation: 15
I have the exact same situation and problem. Is there anyone out there who can help shed some light on this?
 
Old 07-09-2004, 09:57 AM   #3
mikemrh9
Member
 
Registered: Nov 2003
Distribution: Arch
Posts: 136

Original Poster
Rep: Reputation: 21
I've got it working now. Unfortunately, I made many changes before retrying YOU, so i don't know exactly what enabled it to work!

Anyway, here's what I did:

Disabled the firewall on the local machine.

Went to Control Centre, Network Services, Proxy and set the proxy to http://x.x.x.x:8080 and stuck in my authentication settings in the format; domain\user, password.

Went to ControlCentre, YaST Modules, Internet and Network, Proxy and stuck in my addresses and credentials again, and ticked off the box; 'Use Persistant Connection to Proxy'.

The online update worked fine after this, and my SAMBA client now works.

Hopefully, this is all you will need to do, as the rest of my changes happened to involve a complete custom re-install from scratch.....
 
Old 07-09-2004, 05:01 PM   #4
46&2
Member
 
Registered: Mar 2004
Location: Idaho, USA
Distribution: Gentoo
Posts: 67

Rep: Reputation: 15
ok, in the yast module, i entered my user name as:

domain\user

and when i go to put the same information in the control center proxy area, it won't let me specify authentication details (i.e., user and password). instead, it is stuck on "prompt as needed" and won't let me specify it myself.

???
 
Old 07-11-2004, 05:56 PM   #5
mikemrh9
Member
 
Registered: Nov 2003
Distribution: Arch
Posts: 136

Original Poster
Rep: Reputation: 21
Thats just how I left mine, but I used a forward slash instead of a backslash in 'domain/user'. Sorry!!
 
Old 07-11-2004, 06:01 PM   #6
46&2
Member
 
Registered: Mar 2004
Location: Idaho, USA
Distribution: Gentoo
Posts: 67

Rep: Reputation: 15
i'll be sure to try that when i go back to work monday. thanks for the replies, btw.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 10.0 YaST online update daily bunkenburg Suse/Novell 2 03-02-2006 05:21 PM
Suse 8.1 Yast online update (not working) Sparks_ITCS Linux - Newbie 1 08-26-2005 06:16 PM
SuSE 9.1 - problems after YaST online update sgray Suse/Novell 7 05-25-2005 02:31 AM
Configuring proxy settings for yast update behind a firewall fintan Suse/Novell 2 02-05-2005 01:01 PM
Suse 8.1 yast online update notworking gonus Linux - Distributions 0 11-05-2002 10:04 AM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration