LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-11-2004, 12:03 AM   #1
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Rep: Reputation: 15
Unhappy (SuSE 9.1) Unable to find any workgroups in your local network


HI all!

I have SuSE 9.1 Pro Just installed and i am not able to browse my network.

I had it work out just fine when i used 9.0 Pro

I tried to configure it the same way i did with suse 9.0 but to no avail.

One thing that is missing is in the "Control Center, Internet & Network, Local Network Browsing" is the Lisa configuration tabs. I tried to reinstall the Lisa RPM but no change. It may be that SuSE has located it at an other place.

I have Lisa running
I have NMB running
I have SMB running
I configured my SMB.CONF file
I used Yast to configure the samba Client and server

I can not get it to work

Any suggestion?

Do any of you have made it work? What did you do to make it work?

Thank you

Frank

I got it working by configuring my firewall the correct way.

Last edited by frank-01; 06-11-2004 at 02:47 AM.
 
Old 06-11-2004, 02:00 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Is your network card working and correctly configured?
 
Old 06-11-2004, 02:04 AM   #3
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
There was a problem with using Konqueror browsing samba which was fixed in a YaST online update a couple of days ago - that solved my client browsing problems.
 
Old 06-11-2004, 02:45 AM   #4
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Original Poster
Rep: Reputation: 15
It was my fierwall that was blocking all of it.

so i got it working
 
Old 07-28-2004, 10:11 PM   #5
dropdeadlooks
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
What do you mean when you say "configuring the firewall the correct way" ? What exactly did you do ?

I am having the same problem - I can see the workgroup when I turn off the firewall but I don't want to do that. Any suggestions would be greatly appreciated.
 
Old 07-29-2004, 06:38 AM   #6
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Rep: Reputation: 32
i have the same problem! i have to turn my fw off to connect to win workgroup...and i have tried to open ports 135-139...

 
Old 07-29-2004, 07:29 AM   #7
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
IIrc, you also need port 445 open. That may be the port the Windows Samba server wants to communicate on.
 
Old 07-29-2004, 01:16 PM   #8
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Rep: Reputation: 32
tried to open 445 as well...still can't find any windows workgroups...
 
Old 07-29-2004, 01:54 PM   #9
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Is your firewall blocking internal network communications (netmask 192.168.*.) as well as communication from the Internet (anything else)?
 
Old 07-29-2004, 02:15 PM   #10
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Rep: Reputation: 32
internet is working fine, just my internal network is blocked. i can ping 10.0.0.2 (my win box) though...and i have turned off the option "protect from internal network" in the fw setup
 
Old 07-30-2004, 09:39 AM   #11
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Original Poster
Rep: Reputation: 15
Here is my settings so you can try it.

Go to YaST and Firewall setup.

Step 1:

External Interface: PPPo

Internal Interface: eth0

Step 2:

I have no server of any kind so for this step i have no "X" on all the boxes and no additional serverces specified.

Step 3:

I have only put a "X" in: Protect all running services

That should do the job.

I remember that putting an "X" in: Protect internal network, i think that caused the probleme.

Frank
 
Old 07-30-2004, 09:46 AM   #12
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Rep: Reputation: 32
it seems to be the same as mine, except that i only have one interface, eth0.
do you think the problem can be related to my DHCP giving IP addresses in the 10.0.0.x range, and not in 192.168.x.x range??
i dunno if i can change that anyways, its default on my router....
 
Old 08-26-2004, 08:24 AM   #13
Bloodeye
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Updating with YOU did solve the problem for me, too. Since my firewall is deactivated this couldn't have been the problem. So there's probably a bug in the SuSE 9.1 kde-samba client package stuff which is fixed when doing the update.

Hope this helps
 
Old 09-06-2004, 05:44 PM   #14
craigs80
LQ Newbie
 
Registered: Sep 2004
Location: Scarborough, UK
Distribution: Suse / Ubuntu
Posts: 16

Rep: Reputation: 0
Cool Firewall port settings fixed it for me.

After upgrading kde to v3.3 my smb:// stopped working, after allowing the ports you all specified on my firewall, all is singing and dancing! cheers. )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to get SAMBA working "Unable to find any workgroups in your local network." shodekiagari Linux - Networking 1 07-08-2005 01:32 PM
(SuSE 9.1 Pro) - Unable to find any workgroups in your local network poqonos Linux - Networking 0 09-15-2004 08:35 AM
No workgroups found on local network Bauke P. Linux - Networking 2 08-10-2004 10:46 AM
unable to find any workgroups when only 2 pc are connected morrissey Linux - Networking 0 02-27-2004 02:37 PM
(SuSE 9.0) Unable to find any workgroups frank-01 Linux - Networking 7 01-17-2004 11:23 AM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration