LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-10-2004, 01:52 PM   #1
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Rep: Reputation: 15
suse 9.1 router dhcp problem realtek


hi i just installed suse 9.1, everything went fine until the internet test on install
the message "dhcp client already running on eth0" occured

my realtek rtl8029 card was recognised and configured though (but with dhcp option, not static)
later, when i first booted it said "dhcp already running" and it couldn't get an ip from the dhcp
so that failed

once in suse, i tried ifconfig which returned

"lo .. somethingblablabla"

and

"eth0 ....
up broadcast notrailers running multicast
...
rx packets: 0 errors: 0 ....
tx packets: 0 errors: 60 ....
etcetera ...."

when i try ifdown eth0 and then ifup eth0 it sais
"starting DHCP Client Daemon on eth0 . . . . no ip address yet . . . backgrounding"

now when i try to ping my router (192.168.123.254) it sais "network is unreachable"

when i set ip as static (192.168.123.198) and in extra set default gateway as 192.168.123.254 and ping i just get that basic ping fail message

i can ping localhost though (so my card works)

typing dhcpcd doesn't help
it just does nothing for like 2 minutes and then returnes to konsole

i have disables iptables and set 192.168.123.198 as dmz in router

i can perfectly use the network card in windows on the same computer

has anyone had the same problem ??? i'm sorry the ifconfig msg isn't complete btw but that's because i couldn't copy it from linux to windows without any connection offcourse
 
Old 10-10-2004, 02:29 PM   #2
bbenz3
Member
 
Registered: Feb 2002
Location: Orlando
Distribution: Whatever I feel like at the time I install.
Posts: 284

Rep: Reputation: 30
try this from the command line:
(since I run redhat it might not be quite the same but similar)

. /etc/init.d/network stop

then type:

. /etc/init.d/network start

If you get starting eth0 and it fails to pull a connection then something is up with the dhcp or your router.
I know that I had big problems with a 3c905B card and redhat 8.0.
 
Old 10-10-2004, 03:20 PM   #3
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
:(

thanx for your reply, but ./etc/init.d/network stop & start didn't help
the command was recognised in suse and stop worked, but when i started some text showed up very quickly and then konsole shut down so i wasn't able to read the text ... i suppose that isn't normal

when i ifconfig'ed afterwards

Quote:
lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:63 errors:0 dropped:0 overruns:0 frame:0
TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3978 (3.8 Kb) TX bytes:3978 (3.8 Kb)
only lo showed up, not eth0

oh by the way , the wonders of modern technology have allowed me to store everything on usb stick so i can give u more specific results


ifconfig :

Quote:
eth0
Link encap:Ethernet HWaddr 00:80:C8D:FD:E3
inet6 addr: fe80::280:c8ff:fedd:fde3/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:41 dropped:0 overruns:0 carrier:41
collisions:697 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:15910 (15.5 Kb)
Interrupt:11 Base address:0xc800

lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:63 errors:0 dropped:0 overruns:0 frame:0
TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3978 (3.8 Kb) TX bytes:3978 (3.8 Kb)

pingin my router

Quote:
linux:/home/steefje # ping -c 5 192.168.123.254
connect: Network is unreachable
Quote:
linux:/home/steefje # ifdown eth0
eth0 device: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
eth0 configuration: eth-id-00:80:c8:dd:fd:e3
linux:/home/steefje # ifup eth0
eth0 device: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
eth0 configuration: eth-id-00:80:c8:dd:fd:e3 Starting DHCP Client Daemon on eth0... . . . . . no IP address yet... backgrounding.
linux:/home/steefje #

Last edited by steefje; 10-10-2004 at 03:23 PM.
 
Old 10-10-2004, 04:27 PM   #4
bbenz3
Member
 
Registered: Feb 2002
Location: Orlando
Distribution: Whatever I feel like at the time I install.
Posts: 284

Rep: Reputation: 30
OK I didn't expect the stop start thing to work. What I wanted to see is if it created an error. Do this type

script
. /etc/init.d/network stop
. /etc/init.d/network start

this will create a file called typescript that you can then look at and see what happened.
 
Old 10-10-2004, 04:57 PM   #5
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
the script showed no errors network stop went fine
and network start showed something like this

eth0 device: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
eth0 configuration: eth-id-00:80:c8:dd:fd:e3 Starting DHCP Client Daemon on eth0... . . . . . no IP address yet... waiting
...

this isn't the real text, just a copy of my last post, but is sais +/- the same except for some "[" stuff etc ...

no errors except "no ip address"

should i make my "waiting for mandatory services" time longer ?
 
Old 10-10-2004, 07:36 PM   #6
bbenz3
Member
 
Registered: Feb 2002
Location: Orlando
Distribution: Whatever I feel like at the time I install.
Posts: 284

Rep: Reputation: 30
well your current problem is that you are not pulling an IP addy so you can't do anything. I am not totally sure how SUSE does dhcp. I know that redhat waits for a specified amount of time and then it will time out and give you an error stating it didn't get an IP. Not sure where to go from here. You might want to see if there is an updated driver for your NIC.
 
Old 10-11-2004, 10:50 AM   #7
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
hmm my card just uses the ne2k-pci module which comes with any distro these days...
too bad .. i really don't know how to solve this problem
strange, i have been able to use this card on red hat 8 for a while , untill i got my new router i think
chould the problem be my router because i can perfectly use it in windows xp
i guess i'll just have to keep using windows xp pro for now
 
Old 10-11-2004, 12:41 PM   #8
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
do you think it matters whether i use coax or utf because for some strange reason red hat 8 worked with coax while windows also worked with utp

in this case it doesn't work with both

Last edited by steefje; 10-11-2004 at 02:51 PM.
 
Old 10-13-2004, 07:33 AM   #9
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
i think i have found the problem ... when in windows the 'link' light that confirms the physical connection with my card starts lighting up when windows has loaded

while in linux the lights doesn't light up at all ... never ... chould that be because i allways switch between windows an linux by rebooting, and never turning off my computer completely ?
maybe my nic is still expecting a connection with a windows enviroment or something ...

i will now try turning my computer off completely
 
Old 10-13-2004, 08:11 AM   #10
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
hi , err i 'll try to be as complete as possible, because what i found out might be a little confusing, since you're not here ... behind my computer

when i used to use red hat linux 8 , at first, i also couldn't access the internet, but, by accident, i found out that when using a coax cable instead of utp ( coax = round plug, in europe same cable as cable tv ) i COULD use internet, and since everything worked, i really didn't bother finding out why utp didn't work ...

now .. as said in my last reply, i have tried shutting down completely but with an utp cable, the link light just doesn't light up ... so, now knowing a 'link' wasn't obvious, i tried connection a coax cable to my card, transforming the other end in utp with a cross-blabla thingy, and then plugging it into my router ...
the result was that there was a link ! yet, the light staid continous for like 5 seconds, and after that , it just flickered very fast ( like 4 times a second )
i tried pinging my router but host was still unreachable
i then brought down and back up my card, which also didn't work
so ... now ..

i really don't mind using that extra cable for linux but what chould the reason be that there still isn't a decent connection ?? i must tell you that in windows ... the link light from the coax cable also flickers rapidly ...

i hope this isn't too confusing
 
Old 10-13-2004, 12:36 PM   #11
bbenz3
Member
 
Registered: Feb 2002
Location: Orlando
Distribution: Whatever I feel like at the time I install.
Posts: 284

Rep: Reputation: 30
Well since I have never used coax on a network before I am not too sure how to set that up.

But try this. In windows (I am assuming XP or 2k here) go to start run, type cmd and hit enter. Then type ipconfig /all and record all the information there about your network setup. Then reboot into linux.

Now we want to manually setup the IP address on the NIC card. I am not exactly sure how to do this in SuSe. However you could also simply edit some file instead of doing the GUI way. The files I have to edi ton a redhat system are located here:
/etc/sysconfig/network-scripts/ifcfg-eth0
Now I bet yours will be similar if not the same.
In there should be some "variables" that you can set. Just change the values on the right side of the = sign. This will setup a statically assigned IP so that you won't have to worry about dhcp in case this is the problem. Once you have done this try to ping the router.
 
Old 10-14-2004, 06:14 PM   #12
yylam
LQ Newbie
 
Registered: Oct 2004
Posts: 5

Rep: Reputation: 0
Hi,

I am having similar problem. And found following document from Suse support web site, will try it and see.

---
Waiting for Mandatory Device
Applies to: SUSE LINUX 9.1

Symptom
During the boot process, the following message appears: ...waiting for mandatory device...
...

---

Please use the URL to find the document.

http://portal.suse.com/sdb/en/2004/0...evices_91.html

Let me know if it work for you.

Frank
 
Old 10-15-2004, 10:50 AM   #13
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
hi, thanx for your replies, but the problem 's solved now . i realized that i had the exact same nic in an older computer of mine. thinking it would probably not help, just for the heck of it, i tried using that card instead of my current realtek 8029(as).
guess what .. everything worked immediately !!
my card was automatically configured by dhcp, i could ping my router, and web pages, after deleting the configuration of the other card, so i guess i'll never know what the problem was, because the exact same card, in the same computer, using the same router DID work ...
 
Old 10-18-2004, 02:05 AM   #14
yylam
LQ Newbie
 
Registered: Oct 2004
Posts: 5

Rep: Reputation: 0
Hi

Good to hear that your NIC is working now. For my case, I have to disable the APM and ACPI when system boot. I added options to the grub.conf file like:

apm=off, acpi=off, noapic

and Suse is then able to get the IP address from DHCP server properly. I did not do further research about ACPI. It is something call Advanced configuration & Power Interface - and it is able to take some device configuration such as address/IRQ from PC's bios.

Frank
 
Old 02-20-2007, 01:10 PM   #15
radu.miron
LQ Newbie
 
Registered: Jan 2007
Distribution: Ubuntu 7.04 Fiesty Fawn
Posts: 13

Rep: Reputation: 0
Hello!

I have the same problem on my laptop, a Toshiba Satellite A100-529,with a dual boot Suse 9.3 with Windows XP. I edited the /etc/grub.conf file, which looks like this:
[HTML]setup --stage2=/boot/grub/stage2 (hd0) (hd0,6)
quit[/HTML]
and added just before "quit" the line that yylam suggested:
[HTML]apm=off, acpi=off, noapic[/HTML]
but the problem persists.....I have no idea why in Windows the network connection works fine, and in Suse it doesn't. I had several distros installed on dual boot, Ubuntu 6.06, FC5, FC6, Debian 3.1, and never had this sort of issue with them. On the other hand, i read on the internet that this is some sort of bug of Suse 9.3, and also of Suse 10.1 (perhaps even in other later versions, can't remember exactly)


I know this is an old thread, but maybe someone will be able to give me a hand in solving this.


Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no DHCP response with ndiswrapper 0.11 and RealTek 8180 tbkih Linux - Wireless Networking 6 10-27-2004 06:41 AM
Strange problem using my Realtek 8180 based Netgear Card via Ndiswrapper and SuSE 9.1 ClaireValentine Linux - Wireless Networking 4 07-21-2004 11:18 PM
Suse 8 Realtek 8139 Problem Suse_isnice Linux - Networking 1 07-03-2004 04:05 AM
suse 9.0 ftp install: realtek 8139 problem dtheorem Linux - Hardware 4 03-30-2004 01:04 AM
Can't get internet working on Slackware 9.1, kernel 2.4.22, realtek 8139 with dhcp ygnas Slackware 6 03-02-2004 11:06 AM


All times are GMT -5. The time now is 12:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration