LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 01-03-2004, 04:51 PM   #1
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Rep: Reputation: 15
Unhappy (SuSE 9.0) Unable to find any workgroups


Error message after clicking Local Network "Unable to find any workgroups in your local network."

I installed SuSE 9.0 Professional on 2 computer and both say the same error.

One computer is able to see the other but not the other way around.

I check all of samba config files and all is OK as far as i can see.

Can anyone help

Thanks in advance.

Frank...
 
Old 01-04-2004, 11:15 AM   #2
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
Login as root.
Do you have samba running?
What is the output from
ps -ef | grep sm[b];

If it is not running then.
Do you have samba installed?
rpm -qi samba;
If it is not installed you need to install it. You can download it from
Server
ftp://ftp.suse.com/pub/suse/i386/9.0...a-139.i586.rpm
Client
ftp://ftp.suse.com/pub/suse/i386/9.0...a-139.i586.rpm
You then need to update you /etc/samba/smb.conf using yast2.
(on the menu at choose Start->system->yast
once yast starts choose network services then samba server).
That should be it. It it still does not work you need to post the output from
iptables -L -n;
cat /etc/samba/smb.conf;
Good Luck
 
Old 01-04-2004, 02:01 PM   #3
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Original Poster
Rep: Reputation: 15
I got the computer that is not accessible to work. It was the firewall that was blocking it.

yes i have samba ruining as server on both computer. Each can access the other (browse, read, write)

I still get the error message that there is no workgroup after i click on local network icon.

If i put a win98 computer to the network, the workgroup show up?

the smb is working if i use the ip address

Any ideas?

Frank
 
Old 01-04-2004, 02:05 PM   #4
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
Is the proecss nmbd running on the server. How are you resolveing netbios names on the linux server.
What is the output of
cat /etc/samba/smb.conf | grep WIN;
or better yet the how file.
 
Old 01-04-2004, 09:42 PM   #5
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Original Poster
Rep: Reputation: 15
yes i did a command for a samba manual for troubleshooting:

ps -ef | grep nmbd

this is what i got:

root 1656 1 0 21:00 ? 00:00:00 /usr/lib/samba/classic/nmbd -D - s /etc/samba/smb.conf
log 2758 2747 0 21:28 pts/1 00:00:00 grep nmbd

as far as the manual and also all the other test for nmbd suggested in it all is working fine.

i tried your line "/etc/samba/smb.conf | grep WIN;" but it told me that i do not have permission. i tried in root but the same thing. i do not understand what you are asking me.

i am including my smb.conf file below.

[global]
workgroup = internet
os level = 2
time server = Yes
unix extensions = Yes
encrypt passwords = yes
map to guest = Bad User
printing = CUPS
printcap name = CUPS
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
wins support = No
veto files = /*.eml/*.nws/riched20.dll/*.{*}/
security = user
server string = log
add user script =
domain master = false
domain logons = no
local master = no
preferred master = auto
;; ldap server = 127.0.0.1

from my and of thing i am still trying to find a solution.
 
Old 01-15-2004, 11:17 PM   #6
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Original Poster
Rep: Reputation: 15
Talking

I changed 2 lines in smb.conf file and it work

domain master = true
local master = yes

it only work after i have reboot the computer.

I hope it help other.

Frank

Last edited by frank-01; 01-17-2004 at 11:56 AM.
 
Old 01-16-2004, 04:54 AM   #7
babbahaude
LQ Newbie
 
Registered: Jan 2004
Location: Wiesbaden/Germany
Distribution: SUSE 9.0 PRO
Posts: 1

Rep: Reputation: 0
Thumbs up

Quote:
Originally posted by frank-01
I changed 3 lines in smb.conf file and it work

domain master = true
domain logons = no
local master = yes

it only work after i have reboot the computer.

I hope it help other.

Frank
Hi Frank,

I just found your entries here - because having exactly the same problems as you described. I'll try it this evening at home - hoping that your settings work for me as well.
Short Question to you: I can only see two lines changed - is this a typo?

Greetings from Wiesbaden/Germany

Dieter

Last edited by babbahaude; 01-16-2004 at 05:32 AM.
 
Old 01-17-2004, 12:23 PM   #8
frank-01
Member
 
Registered: Nov 2003
Location: Quebec City Canada
Distribution: SuSE 9.1 Pro.
Posts: 30

Original Poster
Rep: Reputation: 15
My mistake.

Greetings to you also from Canada and a happy new year, may the Lord bless you abundantly above all that you can ask and think.

You are right, i did not have time to change my post before you reply, i was going to change it this morning.

there are only 2 changes.

I have tried to get the thing to work for the past few weeks. I notice that the computer need to reboot to get the change do be implemented.

From what i understand from my search is that in order for the workgroup to show up there must be a master supplying the information. Win98 dose that for when i plug a win98 computer, the workgroup show up. but i wanted it to work with only Linux computers. If you want to make all your Linux computer to work for the workgroup when the master is not on line, change those 2 lines and the line "os level = 2" from 2 to 3 an so on. the number determines the boss. so you should put the highest number to the computer you want to be the boss and the other one in between by order you want them. For a Linux computer to be the boss of a win98 you have to specify a number above 32 i think. I remember reading it somewhere but i am fussy about the exact number.

I tried to change only one of those line but it only work with the 2 changed.

I also notice that it take a little time to search the network and all the computer to show up so i put all the IP address of all the connected computer in the file: "etc/hosts".

To see if your configuration work, your computer should see itself and act the same way as if your are trying to log on from an other computer in your network, i suggest to get the computer your are trying to config to work right, before you go on the network and then compare the behavior of each computer as you click on icons when your are browsing to see if all do the same thing and do want your want them to do.

Hope this help

Frank

Last edited by frank-01; 01-17-2004 at 12:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to get SAMBA working "Unable to find any workgroups in your local network." shodekiagari Linux - Networking 1 07-08-2005 02:32 PM
Unable to find software on SuSe installation cd Hockeyfan Linux - Software 6 01-03-2005 10:52 AM
(SuSE 9.1 Pro) - Unable to find any workgroups in your local network poqonos Linux - Networking 0 09-15-2004 09:35 AM
(SuSE 9.1) Unable to find any workgroups in your local network frank-01 Linux - Networking 13 09-06-2004 06:44 PM
unable to find any workgroups when only 2 pc are connected morrissey Linux - Networking 0 02-27-2004 03:37 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration