LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-03-2006, 08:40 PM   #1
manjagu
LQ Newbie
 
Registered: Jun 2005
Location: New Hampshire
Distribution: Ubuntu Feisty
Posts: 8

Rep: Reputation: 0
SuSE 10.0 failing to serve home directories


I realize this has been rehashed a bit, but, I have a new and strange problem.

First, Yast did not configure httpd.conf correctly. You can enable mod_user in Yast, but it doesn't insert the correct entry into httpd.conf (or any of the other .conf files) despite saying that it had. So, I manually edited httpd.conf and added the line

# enable user directory hosting
Include /etc/apache2/mod_userdir.conf

mod_userdir.conf contains

#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#

<IfModule mod_userdir.c>
# not every user's directory should be visible:
UserDir disabled root

# to enable UserDir only for a certain set of users, use this instead:
#UserDir disabled
#UserDir enabled user1 user2


# the UserDir directive is actually used inside the virtual hosts, to
# have more control
UserDir public_html

<Directory /home/*/public_html>
#AllowOverride All
AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec

<Limit GET POST OPTIONS PROPFIND>
Order allow,deny
Allow from all
</Limit>

<LimitExcept GET POST OPTIONS PROPFIND>
Order deny,allow
Deny from all
</LimitExcept>

</Directory>

# enable cgi scripting
<Directory /home/*/public_html/cgi-bin/>
Options ExecCGI
SetHandler cgi-script
</Directory>

</IfModule>

Adding these things and setting the correct permissions on my public_html directory solved my problems the first time. Then I decided to try Yast again (because editing the .conf files manually messes up the yast hash). So, I re-installed Apache2 with all the defaults I had originally started with. Once again, yast failed to do the job, so I decided to restore everything to what I just explained. Now, once again, the home/*/public_html directories are not served, resulting in a 404 error.

Any thoughts?

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache Root/Home Directory and setting up FTP for home directories? Mankind75 Linux - Newbie 6 07-23-2006 02:37 PM
securing /home directories danimalz Debian 21 11-30-2005 03:30 AM
NIS and home directories (Suse 10) linuxmfx Linux - Networking 3 10-19-2005 10:28 AM
Home Directories - Backup kwigibo Linux - General 1 08-23-2002 08:29 AM
How do I get Apache to serve the right docs from the right directories? gomer1701ems Linux - Software 1 06-11-2001 09:29 PM


All times are GMT -5. The time now is 05:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration